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Bold and Italic 

Bold is used when referring to names of menus, menu options, dialog boxes, 
buttons, tabs, field labels, keyboard and mouse buttons and other named items in 
the user interface. 

Italic is used for text to be typed in by the user. 

 

File / Menu Paths 

We try to orient the user by starting with the first thing the user needs to look for. 
For example:  
From the Items menu, select List Items > All…  
not:  
Select List Items > All… from the Items menu.  
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1 Introduction 

1.1  About the user’s guide 

This user’s guide is divided into four main sections. 
 
The first is showing the basic steps of Weight monitoring. 
 
The second part handles the basic steps of Estimating Weight and CoG. 
 
The third section gives information on some of the additional features beyond 
the basic estimation and weight monitoring. 
 
The last part of the guide deals with the administration of ShipWeight. 
 

1.2  Context sensitive help 
ShipWeight comes with context-sensitive help. Pressing the F1 key in a dialog 
box will bring up help for that dialog box. Pressing F1 on the main window will 
bring up generic help. 
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1.3  Contact information 
If you have any questions regarding ShipWeight, please do not hesitate to 
contact us. 
 
BAS engineering AS 
Myrabakken Næringssenter    Phone: + 47 70 15 03 60 
N-6010 Ålesund        Fax:  + 47 70 14 24 91 
Norway           Email: office@bas.no 

 
 
For our representatives outside Norway, please see www.shipweight.com 
 
 

mailto:office@bas.no
http://www.shipweight.com/
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1.4  General overview of the ShipWeight system 
The ShipWeight system serves two main purposes: Weight monitoring and 
estimation. During the weight monitoring process, data from weight take off 
during construction is structured and stored together with relevant parameters 
for the items.  
 
When the vessel is complete and the weight data is corrected according to the 
results from the inclining test report, the ship is ready to be exported to the ship 
database. 
 
As long as the weight monitoring of a project is ongoing, the data is stored in a 
project database, and cannot be used for estimation. The project database can 
contain several projects, and is separated from the ship database to prevent 
doing estimates based on incomplete vessel data. 
 
When a project in the project database is complete, the data should be exported 
to the ship database. The ship database should contain data from all completed 
projects. When a new estimation project is started, estimation can be done on 
basis of the past ship data in the ship database.  
 
Usually the estimation progress continues until a construction contract is signed 
and there is a contract weight to relate to. Then a new ShipWeight project 
should be created and you can start weight control activities and weight take 
off. 
 
During the weight control activities, the project file can be compared to the 
design project file to find deviations and to measure the progress in the project. 
 
When the project is complete, a new file is ready to enter the ship database, 
and the experience basis of past ship data has increased. As more and more 
projects are exported to the ship database, the better the system will be to 
estimate new vessels. 
 



 

4 
 

1.4.1  The breakdown structure systems 

All available breakdown structures in ShipWeight are hierarchical. The reason 
for breaking up the ship is to make more accurate estimations by trying to 
isolate weight groups that can more easily be compared from ship to ship.  
 
Also breaking up the ship gives statistical cancellation effects. This means that 
the different errors in the estimation of weight groups will sometimes give a 
higher -and sometimes a lower weight. Thus the errors will to some extent erase 
each other. 
 
The figure below shows the four top levels in the standard ShipWeight break 
down structure. The total structure contains more than 300 weight groups 
divided into six levels. 
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The ShipWeight standard structure is the default structure. Also the US Navy 
“Ship Work Breakdown System” (SWBS) comes with ShipWeight. In addition 
Rig estimation breakdown system and General offshore breakdown structure 
can be delivered upon request. 
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1.5  Definitions 
 
CoG Center of gravity 
VCG Vertical center of gravity 
LCG Longitudinal center of gravity 
TCG Transversal center of gravity 
VCG_min / Lower The lowest vertical point of the weight item 
VCG_max / Upper The uppermost vertical point of the weight item 
LCG_min / Aft The longitudinal aft point (starting point) of the weight item 
LCG_max / Fore The longitudinal fore point (endpoint) of the weight item 
TCG_min / PS The minimum transverse point of the weight item 
TCG_max / SB The maximum transverse point of the weight item 
Weight item A steel part, a machinery part or an equipment unit that has 

a specific weight. 
Weight group A post in the breakdown structure that can contain weight 

items 
Breakdown 
structure 

The system describing the vessel by breaking it into several 
parts, ordered hierarchical in groups. (See Chapter 1.4.1 
The breakdown structure systems) 

 
 

1.6  Unicode Compliance 

ShipWeight 11.60 is Unicode compliant.  This means that all input fields, reports 
and output data will be able to handle all types of regional character systems, 
such as far-east characters. 
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2 Weight Monitoring 

2.1  Starting ShipWeight 

ShipWeight can be started by clicking the icon on the desktop.  
 

 
 
Alternatively, open the Windows Start menu and select All Programs. Then 
navigate to the ShipWeight Enterprise folder and select ShipWeight. 
 
When starting ShipWeight, the Login dialog box will appear. To start working 
with ShipWeight you need to enter a valid user name and password. The first 
time ShipWeight is started, you must log on with the following user name and 
password: 
 
User name:  Administrator 
Password:   admin 
 
Next, use the System dropdown list to select the appropriate system 
breakdown structure. Click OK to continue. The main window of ShipWeight 
will now be opened. 
 
The User name and System fields are preset with the values from the previous 
session.  
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ShipWeight 11.60 main window improves user friendliness and increase 
flexibility on the work breakdown structure. 
 

 
Picture 1: ShipWeight main window 

In the main window the grids and the weight group hierarchy have been 
merged.  The result is a more intuitive way of navigating in the weight group 
hierarchy, and also the number of weight groups on the same level of the 
structure is no longer restricted by the grids – there is no limitation to this 
anymore. 
 

 
 
 

Icons are used in the new main window to inform the user about the origin of 
the weight group summary.  
A Grid icon indicates that the weight group is a summary of weight items in that 
weight group. 
A Sigma icon indicates that the value is a summation of subgroups – not items. 
Finally, a Graph icon will indicate that the value is estimated by parametric 
formula.  
Grid and Graph icons are also clickable and will open the Items dialog box and 
Graph dialog box respectively. 
  

Picture 2: Icons indicate value origin 
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In the right part of the main window, several information 
windows are shown.  This shows Project Info, Parameters, 
and Codes.  This area can be hidden all in one by clicking 
the Hide info >> button, in case maximum space is required 
for the weight group hierarchy.  Each individual window may 
also be hidden by clicking on the Show/Hide button (small 
arrow) to the right in the heading.  Clicking this button will 
show/hide the area for every second click.  The heading title 
itself is also clickable and works as a hyperlink to open up 
windows for editing the information in the area. 

 
An extended submenu has also been 
added to the new main window, available 
by right-clicking the mouse button.  The 
submenu includes various selections for 
expanding and collapsing weight groups, 
resetting column widths and copying the 
information to the clipboard. 
 
In addition to displaying the values for parameters, the 

Codes window will also show a summary of the weight per code. This can 
potentially slow down speed on very large projects, so there is an option in the 
Options dialog box to turn off this summation. 
 

 

 

Picture 3: Information areas 

Picture 4: Summary per custom code 
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The icons showing weight group types are: 
 

   Remainder 

  DeadWeight 

  Lightship / LightWeight 

  Machinery 

   Hull 

   Equipment 

   Temporary 
 
The icons showing status of a weight group may be set to: 
 

   Checked 

    Unchecked 
 
    (No icon) Neutral  
 
To set the status, select one of the options on the Checking menu. 
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2.2  Creating a new project 
To start a new project, from the Project menu, select New or click the New 
project button on the toolbar:   
 
The Project Info dialog box appears. First you can enter General data: 
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And then, you can also fill in Additional data: 
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The fields Database ID and Project ID have to be filled in, the others are 
optional. The available fields are: 
 
Database ID: This is the name of the SQL database. The ID cannot be changed 
after the project has been created. Please note that one database can contain 
several projects. 
 
Project ID: The name of the current project. Default: Master 
 

Important! 
From version 7.5 and onwards, a project is defined by a database ID and a 
project ID. This means that you can store any number of projects on a single 
project-database. 
 
 
Use Parents: The name of an existing project (in the same database) from 
which the current project will inherit weight items. 
 
All weight information read from the database is read from the project and the 
parent project, i.e. Items dialog box, main window, summaries and reports. 
 
All weight information that is written is written to the project only. The weight 
items inherited from the parent project cannot be edited from within the current 
project. To change information in the parent project, the parent project must be 
opened separately. 
 
Name: The name of the ship needs to be maximum 30 characters. 
 
Owner: Enter the name of the ship owner or select one of the previously 
registered ship Owners from the dropdown list. Alternatively, click the Browse 

button    to open the Owner library. Maximum 50 characters. 
 
Main type: Select one of the available Main types from the dropdown list, or 
use the Browse button to open the Select Shiptype dialog box. 
 
Type: Select one of the available Types from the dropdown list, or use the   
Browse button to open the Select Shiptype dialog box. 
 
Registration pers.: Maximum 50 characters. 
 
Registration date: Maximum 10 characters. 
 
Frame spacing: Definition of the frame spacing. The syntax is:  
 
DX1#FR1; DX2#FR2; DXn#FRn 
 
Where DXn is the frame spacing from FRn-1 to FRn 
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FRn is the frame number where the spacing changes, given in the order of 
increasing frame numbers 
 
Example 1: A ship with a frame spacing of 0.7 m. up to frame number 10, 0.8 
m. up to frame 120 and 0.7 m. further ahead is specified as following: 
 
0.7#10;0.8#120;0.7# 
 
Example 2: A ship with constant frame spacing of e.g. 0,6 m. is specified as 
following: 
 
0.6# 
 
 
If #0 and X=0 are not congruent, this is adjusted by setting ±<distance>;<frame 
spacing> where <distance> is the distance between X=0 and #0 and <frame 
spacing> is frame spacing defined as above. 
 
Example 3:  X=0 resides in AP and #0 is located 0.2 meter ahead of AP (positive 
direction towards FP).  Frame spacing is as in Example 1. 
Frame spacing definition would then be: 
  
+0.2; 0.7#10;0.8#120;0.7# 
 
Coord. ref. point: By entering data for Coord. ref. point and Coord. ref. dir., 
a secondary coordinate system is defined. Coord. ref. point is the origin of the 
secondary coordinate system: 
 
VCG: Global reference point in z-direction 
LCG:  Global reference point in x-direction 
TCG:  Global reference point in y-direction 
 
Coord. ref. dir.: Set the positive direction of the axis of the secondary 
coordinate system: 
 
VCG: Sign for the z-axis. If positive upward 1, if positive downward -1 
LCG:  Sign for the x-axis. If positive forward 1, if positive backwards -1 
TCG:  Sign for the y-axis. If positive toward starboard 1, if positive toward 

portside -1 

Tip! 
To activate the alternative coordinate system, from the Weight Group menu 
select Show reference CoG. Alternatively, click the Show reference CoG 

button on the toolbar:    
 
Units: Metric or US 
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Build year 
 
Plan file: The name and path of the section drawing file. The drawing must be 
of type bmp or jpg. Maximum 255 characters. 
 
Arrangement File: The name and path of the GA drawing file. The drawing 
must be of type dxf or dwg. Maximum 255 characters. 
 
Designer: The name of the Ship designer, maximum 50 characters. 
 
Construction Site: The name of the Shipyard, maximum 50 characters. 
 
Design: The name of the design, maximum 255 characters. 
 
Class: The name of the class, maximum 255 characters. 
 
Comment: A comment field, maximum 255 characters. 
 
Click OK when you are done. 
 
Next you are asked to specify the top-level weight group (post). In most cases 
this will be LW Lightship. 
 

 
 
Select LW Lightship and click OK. 
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Next the Parameters dialog box pops up, with the Main Parameters tab 
activate, and you should fill in all the ship particulars that are available. 
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2.3  Opening an existing project 
To open an existing project, from the Project menu, select Open or click the 

Open project button on the toolbar  
 

 
 
 
In the Open SQL database dialog box, set the following properties: 
 
Server   Select one of the available SQL servers. 
 
Database  Select database. 
 
Project ID  Select project. 
 
 
Click OK to open the project. 
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2.4  Moving through the hierarchy 
The way to move through the hierarchy is simply by expanding and collapsing 
the tree view. This is done by clicking in front of the weight group. 
 

  
 
When this is done the actual weight group will expand or collapse. 
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Important! 
 
The logic of summarizing in ShipWeight is based upon the rule that a weight 
group is the sum of the weight groups below. This means that if you split one 
weight group to fill in weight items on a lower level, you will lose the value in the 
weight group above. However the value can be saved in Comment… dialog 
box (found on the Weight Groups menu) for history tracking. 
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2.5  Finding the right weight group 
You are now set to start entering weight information into the different weight 
groups (posts) in the breakdown structure. There are two ways of finding the 
right weight group for the weight item that you want to store. The first one is by 
using the Search dialog box, which can be found under Weight Group on the 
menu bar. 
 

 
 
In this Search dialog box you can choose between SFI-search and Index-
search. Either way you enter the SFI number or the item name into the edit 
box, and by clicking Show wgt.grp., the lower window shows the suggested 
weight groups for this item. If you accept the suggested groups you can double-
click right on the suggestions, and you will be taken to this weight group 
automatically. 
 
Currently this is implemented for the ShipWeight work breakdown structure 
only. 
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2.6  The Items dialog box: entering weight 
information 

The Items dialog box is used to add new and edit existing weight items. 
 
The Items dialog box can be accessed in several ways. Make sure to navigate 
to the desired weight group. Then do one of the following: 

 On the toolbar in the main window, click the Item level button   

 From the Items menu, select List Items > All… 

 In the tree-view, click the Item level button . 

 In the lower grid in the main window, click on Items  
 

 
 
The information which is normally tagged to a weight item can be categorized 
as following: 
 
Id and description 
Quantities, weights, position and extension 
Various codes and drawing references 
Calculated fields 
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The Items dialog box contains four main parts: a toolbar (at the top), the single-
record view (upper half), the table view (lower half) and totals (at the bottom). 

   
 
 
The toolbar includes the following buttons: 
 

 Undo last action 
  
 

 Cut selection 
 
 

 Copy selection 
 
 

 Paste selection 
 
 

 Delete selected items 
 
 

 Re-query record set – refresh data 
 

 Filter – create a filter using the Filter dialog box. Only items corresponding 
to the selection in the Filter dialog box will be listed in the table-view. 
 
 

 Clear filter 
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 Sort – items in the table-view will be sorted according to the rules given in 
the Sort dialog box. 
 
 

 Clear sorting 
 
 

 Options 
 
 

 Load setting… – Load a custom dialog box setting (layout). 
 
 

 Save setting – Save the current dialog box setting. 
 
 

 Save setting As… – Save the current dialog box setting with a different 
name. 
 
 

 Dropdown list to select dialog box layout. Same function 
as the Load settings… button. 
 
 

 Dialog box settings… – opens the Item settings dialog box. 
 
 

 Dropdown list to select item weight group. 
 
 

 Open the Select Item Weight Group dialog box. 
 
 

 Dropdown list to select Local coordinate system. 
 
 

 Open the Local coordinates dialog box. 
 
 

 Close Items dialog box 
 
 
 
The single-record view displays information of the selected weight-item. The 
single-record view is divided into groups. Each group contains different fields. 
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This way similar information can be grouped and presented together. E.g. all 
information concerning weight and center of gravity is collected in the group 
Weight & CoG. 
 
The table view shows all the items of the selected weight-group. 
 
The totals field shows the sum of the item weights and centers of gravity. In 
addition, all calculated code fields are summarized. 
 

 
Navigation – go to first, previous, next or last item. 
 

2.6.1 Adding Items 

The Items dialog box is mainly used to add, edit and delete weight items. New 
weight items can be added and edited both using the Single record view and 
the Table view. 
 
Adding an item: 
To add a new item, follow these steps: 

 
 
Click the Last item button (1.). This will clear the fields of the single record view. 
This step is only necessary if there already are weight items defined in the 
weight group. 
 
Click on the WgtGrp field (2.), and select the weight group from the dropdown 
list. 
 
Jump to the next field by pressing the TAB key. 
 
Enter a unique number in the ItemNo field, e.g. 11001, 1100ABCd. 
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Press the TAB key to jump to the Description field. Enter a description, e.g. 
‘Shell Plates’. 
 
Continue jumping to the next fields pressing the TAB key and add data to the 
weight item. 
 
When you have completed entering data, click one of the Navigation buttons 
(First, Previous, Next or Last) to finalize the registration of the item. 
 
Adding an item using the Table view 
Alternatively, new items can be added using the table view. 
 
Select the last record in the table using the mouse, or click the Last item 
button on the toolbar. 
 
Activate the WgtGrp cell in the table by clicking on it with the mouse or by 
pressing the ENTER key. Select weight group from the dropdown list. 
 
Press the TAB key to jump to the ItemNo cell, and enter a unique item number, 
e.g. 11002 
 
Press the TAB key to jump to the Description cell and enter a description. 
 
Continue entering data for the item by jumping to new fields pressing the TAB 
key. 
 
After you have finished entering data for the new weight-item, select a different 
item (click another row in the table). This will ensure that the weight-item is 
properly registered. 
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2.6.2  Deleting Items 

Using the mouse, select the item in the table. You can either select one single 
item or several items. To perform a multiple selection, press the SHIFT key on 
the keyboard while selecting. Pressing the CTRL key adds or subtracts items 
in the selection. 
 
Click the Delete button on the toolbar. Alternatively, right-click the mouse above 
the selection and select Delete Record from the menu. The Delete Record 
command is also available on the Edit menu or by pressing CTRL+D. 
 

2.6.3 Cut, Copy and Paste 

The Items dialog box has Cut, Copy and Paste functionality for the items listed 
in the table. Items can be cut or copied from ShipWeight and pasted into a 
spreadsheet, e.g. Excel. Select one or several rows in the table. Click the Cut 
or Copy button on the toolbar or from the Edit menu select Cut or Copy. 
Alternatively, press CTRL+X to cut or CTRL+C to copy. 
 
Seemingly, large numbers are rounded when copying from ShipWeight to 
Excel. For example, the unit weight 7777777.7777 in ShipWeight will display as 
7777778 in Excel. 
 
To display the correct value in Excel, the proper Cell-formatting must be set. 
Mark all the cells containing numbers, right-click the mouse, and select Format 
Cells…. In the Format Cells window, the cells are of the category General. 
This should be changed to Number. Also set Decimal places to 4. Excel will 
now correctly display 7777777.7777. 
 
Data can be copied from a spreadsheet to ShipWeight. Before copying data 
into ShipWeight, make sure the item numbers are not duplicated. Also verify 
that the order of the data in the spreadsheet is the same as the order of the 
columns in the table of the Items dialog box. To check that the order of the data 
is correct, it can be useful to use the Copy Heading option from the Edit menu 
of the Items dialog box. Now, the heading of the table view can be pasted into 
the spreadsheet to verify the order of the data. 
 
To copy the data back into ShipWeight, select and copy the data in the 
spreadsheet. In ShipWeight, select Paste either on the toolbar, the Edit menu 
or by pressing CTRL+V. The items will now be pasted into the table. 
 
Please note that it is not advisable to copy very large figures from Excel to 
ShipWeight without first formatting the cells in Excel to Number with a proper 
number of decimal places. 
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2.6.4  Filtering 

The Item Filter dialog box is used to create a filter to control which items to list. 
The dialog box can be accessed from the Tools menu by selecting Filter > 
Apply… Alternatively, click the Apply filter button on the toolbar. 
 
The Item Filter dialog box is divided into three areas; Filter name frame, 
Expression area and Filter textbox. 
 
The Filter name frame is used to save and load filter settings. To save the 
current setting, enter a Name and click the Add button. 
 
To load a saved filter, simply select it from the Filter name dropdown list. 
 
The Expression area is used to create the filter. First, select a Table Field and 
an Operator, e.g. VCG and >. Next enter a Value, e.g. 15. As default, Round 
has been checked On, and Decimals are set to 4. 
 
Finally, click Insert. The filter ROUND ([VCG], 4) > 15 will now show in the 
Filter text box at the lower half of the dialog box. 
 
The filter can be extended using the And, Or, Not, ( and ) buttons at the right 
side of the Filter text box. 
 
To apply the filter, click OK. Now only items matching the filter will be listed in 
the table-view. 
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2.6.5  Sorting 

The Sort dialog box is used to apply rules for sorting the items of the table-
view. The dialog box is available from the Tools menu, select Sort > Apply… 
Alternatively, click the Apply sort button on the toolbar. 
 
To add a new line in the table, click the last record (empty line) with the mouse. 
The cell will now include a dropdown list. Click the Arrow button to display the 
list. Select one of the Field Names, e.g. RegUser. Similarly, to set the order of 
the sorting, click the Data Type column to display a dropdown list. Select 
Ascending or Descending in the Sort column. 
 
Click OK to apply the rules for sorting. 
 
It is also possible to perform a quick sorting by clicking the column header of 
the table. To change the sorting from ascending to descending or vice versa, 
simply click the column header once more. 
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2.6.6  Change weight group code 

The easiest way of moving weight items from one weight group to another is to 
use the Change Wgt.grp Code… function. Select the desired items in the 
table, and from the Items menu select Change Wgt.grp Code…. The Select 
item weight group dialog box will appear. Choose a weight group and click 
OK. 
 

2.6.7  Code Enveloped Items 

From the Items menu, the function Code Enveloped Items… will tag selected 
items to a code structure according to given CoG limits. Select a set of items 
and choose Code Enveloped Items…. The Select code type dialog box will 
be opened. Select one of the available code types, which have defined CoG 
limits, and click OK. Now the items will be tagged to codes according to its CoG. 
 

2.6.8  Set Codes by Mapping 

Selected items can be tagged to a code structure in compliance with a defined 
mapping between two different code structures. This requires that the mapping 
between the two code structures has already been defined. First you must 
select which code type should be updated. Next, select which code type the 
update should be based on. 
 

2.6.9  Set field values 

You can use the Set Field Values function to edit several weight items in one 
operation. The fields available for editing are: 
 
Description 
Quantities 
Weight (if not read-only) 
CoG 
Extensions (CoG_min and CoG_max) 
Codes 



 

30 
 

 
Select the desired items, and from the Items menu, choose Set Field 
Values…. Next, choose the field to be changed in the Select field type dialog 
box and click OK. The Set value dialog box will appear. Type a value into the 
field at the upper left corner of the dialog box or select one of the available 
values in the list below. Click OK to apply the changes. 
 

 
 
 

2.6.10 Set SFI Codes 

From the Items menu the function Set SFI Codes… will add the complete SFI 
code to the selected code structure. 

2.6.11 Set CoG by Code Envelopes 

The Set CoG by Code Envelopes function enables multiple definitions of CoG 
based on codes. This function is found on the Items menu of the Items dialog 
box. 
 
In the table-view, select the weight items to update. Alternatively, press 
CTRL+A to select all items. Next, select Set CoG… on the Items menu and 
choose VCG, LCG, TCG or All. 
 
Next, a dialog box asking for code type will pop up. Select the code type to be 
used for setting the CoG and click the OK button. CoG for the selected items 
will now be calculated as halfway between CG_min and CG_max for the 
selected code type. 
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2.6.12 Local coordinates 

Local coordinate systems are only available in the Items dialog box. To set up 
a local coordinate system, click the Local coordinates button on the toolbar, 
or from the Setting menu select Local coordinates. 
 
The Local coordinates dialog box includes a grid with four columns. To create 
a local coordinate system, simply fill in the fields: 
 
Title    Name of the local coordinate system 
Z-ref           Vertical reference point 
X-ref           Longitudinal reference point 
Y-ref           Transverse reference point 
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Up to ten different local coordinate systems can be defined. The unit of the 
VCG, LCG and TCG reference points is determined by the Units selected in the 
Options dialog box: meters when Metric units are selected and feet when US 
units are selected. Please note that the reference points are not converted when 
changing Units from Metric to US units and vice versa. 
 

 
 
When you have finished adding/editing local coordinate systems, click the 
Close button to close the dialog box. 
 
To activate a local coordinate system, simply select it from the Local 
coordinates dropdown list on the toolbar of the Items dialog box. 
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2.6.13 Split item 

 
The Split item… dialog box is used to divide an item into two or more parts. In 
the Items dialog box, select a weight item. From the Items menu, choose Split 
item….  
 
Next, select the number of sub-items to split the item into. Choose whether to 
split the weight or not. Select how to treat the original item: Delete, Keep 
remainder or Keep unchanged. 
 
Click the OK button to create the new items and close the dialog box. 
 

 
 

2.6.14 Check CoG 

Selecting Check CoG in the Options dialog box on the Item tab, will enable 
automatically checking of sanity between CoG and given extension. The CoG 
check is only active in the Items dialog box. 
 
The user gets a warning if: 
 
• CoG is set outside CoG_min / CoG_max 
• CoG_min is set fore of CoG 
• CoG_max is set aft of CoG 
 
Please note that this is only a warning. The user will not be prevented from 
setting an incorrect CoG. 
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2.6.15 Auto CoG 

The Auto CoG function will automatically define CoG and extension for weight 
items. The CoG and extension values are based on code-values. 
 
The Auto CoG function is turned on/off on the Item tab of the Options dialog 
box. In the Options dialog box you also specify which code type the CoG will 
be calculated from. 
 

 
 
For the Auto CoG function to work properly, the code type selected as basis 
for Auto CoG must include code values. For each code value, VCG_min, 
VCG_max, LCG_min, LCG_max, TCG_min, TCG_max must be defined. 
 
To define an Auto CoG code, open the Code Definition dialog box. Add a 
code type, e.g. C05. Make sure FieldType is set to ListBox. 
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Click on the new code type in the tree view, in this case C09. In the table at the 
right side of the dialog box, add a set of code values. Make sure to define the 
VCG_min, VCG_max, LCG_min, LCG_max, TCG_min, TCG_max values for 
each code value. For more information on creating codes, please refer to 
Chapter ‘5.3 The Code Definition dialog box’. 
 

 
 
In the Items dialog box, when this code is changed for a weight item, the user 
is asked whether to update CoG for undefined CoG, all or none. 
 
CoG for the item will be calculated as halfway between CG_min and CG_max 
for the selected code type. 
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2.6.16 Copy/paste log 

The Copy/paste log function, allows you to automatically track copy and paste 
operations in the Items dialog box. When a weight item is copied from or pasted 
into the Items dialog box, the following data is logged: 
 
• Operation (Copied or Pasted) 
• User 
• Date & Time 
 
Example of copy/paste logging: 
 
Copied by Administrator 19.04.2011 13:55:21 
Pasted by Administrator 19.04.2011 13:55:32 
 
The copy/paste log data is stored in a code-field. To activate the Copy/paste 
log, you must first define the code to hold the Copy/paste log data. It is 
recommended to use field-type ‘ReadOnly’ for this code. 
 
Next, you must go to the Item tab of the Options dialog box and select 
Copy/paste log. Select a code from the Copy/paste log dropdown box. 
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In the Items dialog box, make sure to select an item setting showing the 
Copy/paste log code. 
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2.6.17 Cell Formula in Items dialog box 

A formula typed into a grid cell in the Items dialog box (i.e. =5*4+2) is stored 
for later use.  If a grid cell value is calculated from such formula, this grid cell 
will show the formula in a tooltip when the mouse pointer is resting on the cell.  
When editing the grid cell later, the calculated result value transforms back to 
this formula in the cell. 
 

2.6.18 Frame Conversion (entering frame numbers in 
Items dialog box) 

 
 
If Frame spacing is defined in Project Info dialog box (menu View > Project 
Info…) then frame number can be entered into the LCG, LCG_min and 
LCG_max field of the Items dialog box by typing a # sign in front of the value.  
The frame number will then automatically be converted to Metric or US units 
(depending on Units setting) according to the Frame spacing defined.   
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2.6.19 Marking Changed Values in Items dialog box 

 
 
If the selection Mark Edited Cells has been set in the Setting menu in the 
Items dialog box, every cell that gets edited is marked yellow when working 
with a weight item.  Moving to another item will reset the coloring of the edited 
cells back to white. 
 

2.6.20 Easier formatting of values in the Code Definition 
dialog box 

 
 

The Format column in the Code Definition dialog box has a set of predefined 
formats that can be selected from the dropdown list appearing when a cell in 
this column gets focus. 
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2.6.21 Description and Indentation of Custom Codes in 
dropdown lists 

 
 
The description of the sub code (in addition to the Code ID) is shown in 
dropdown lists in the Items dialog box for custom codes defined as ListBox or 
ComboBox. The description is only shown in the dropdown list for reference 
purposes; it is not brought into the field when selection is done. Furthermore, 
the sub codes will be shown indented according to their defined hierarchy 
structure. 
 

2.6.22 “Quick Dump” to Excel from Items dialog box 
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2.6.22.1 Export 
 
The Items dialog box has a function for exporting and importing the table view 
data to and from Excel. This function is currently limited to table views that 
contain 30.000 or less items. The Export will use the current item setting for 
the table view as definition to which columns to export and export the weight 
items that are loaded into the Items dialog box at the time of export. 
The Export function is on menu Items > Import / Export > Export Excel in 
Items dialog box. 
 

2.6.22.2 Import 
 
When importing, the Import Item from Excel dialog box pops up and lets you 
specify the Excel file and sheet to import from, but also set up mappings 
between the columns in the Excel sheet and the columns in the table view. 
This mapping can be set up by selecting a column from Excel in the left list of 
the dialog box and select the corresponding column in the right list (representing 
the table view columns) and map these by clicking the <+> button. 
If the columns to be imported are exactly the same as the one in table view (as 
would be the case if importing an Excel produced by the same Items dialog box 
setting), clicking the <++> button will set the mapping for all columns correct at 
once. 
The lower part of the dialog box will show the current defined mappings. 
Click OK to start import when settings are correct. 

 
 
The Import function is on menu Items > Import / Export > Import Excel in 
Items dialog box. 
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2.6.23 Color coding for item groups 

Assigning color codes to the item groups in the Items dialog box can be done 
by double-clicking the Color column in the Item setting dialog box. This will 
pop up a Color dialog box for color selection. 
 

 
 
 

2.6.24 Merge Items 

In the Items dialog box, several items can be merged into one single weight 
item by selecting (marking) weight items in the table view and from the Items 
menu select Merge Items. 
 

2.6.25 Execute function in Items dialog box 

Mathematical operations such as adding, subtracting, multiplying and dividing 
can be performed on item values in the Items dialog box, on a single item or 
on a multiple selection of items. From the Items menu, select Execute 
Operation… to open a pop up dialog box that lets you select the column you 
want to carry out the mathematical operation on, specify type of operation and 
function value for the operation. 
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When clicking OK, the selected operation will be carried out on the marked 
weight items in the Items dialog box. 
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2.7 Playground Area and Workset 
The new Playground Area in ShipWeight provides a sandbox environment 
where weight data can be changed, added, or deleted without affecting the 
weight data in the project.  Only when the data is transferred from the 
playground area and back into the project, are changes included in calculations 
and output.  The Playground Area can be used in two modes; with and without 
Worksets.  Data in the Playground Area is a copy of the data in the main area. 
 
The graphical user interface for the Playground Area is similar to the Items 
dialog box.  To distinguish and clearly mark the Playground Area from the 
normal Items dialog box, a color (by choice of the user) can be selected in the 
Options dialog box.   

 
 
 
The Playground Area may be opened from the Items menu in the main 
window by selecting List Playground Items… and then All, or by selecting the 
Playground Area button on the toolbar.  
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2.7.1  Using the Playground Area without Worksets 

If the Playground Area is used without Worksets, weight items may be 
transferred from the project data to the playground environment by marking the 
items to be copied and selecting Copy to Playground from the Edit menu in 
the Items dialog box. 
 
Items in the Playground Area, which have been manually added to this area, or 
copied in from the project data, may be transferred back to the project by 
marking the items to be transferred and select Move back to Item from the 
Edit menu while in the Playground Area dialog box. 
Working like this is quite similar to copying items to and from Excel® or other 
spreadsheet tools. 

2.7.2   Using Worksets with the Playground Area 

When Worksets are used in ShipWeight, this sets up a stricter and more 
controlled way of transferring items between the Playground Area and the 
project. 
 
To start working with Worksets a custom code needs to be defined (in the Code 
Definition dialog box) to hold the identifier of the Workset. This custom code 
must be of the type ListBox and a list selection code must be added, each one 
intended to group weight items to be checked in and out of the Playground 
Area. 

 
Once the custom codes have been defined, Worksets must be enabled and 
proper settings for the Playground Area must be defined in the Options dialog 
box.  In the Workset tab in the Options dialog box, Worksets are enabled by 
checking the checkbox Use worksets, followed by selecting the custom Code 
that was set up to identify the Worksets.  This is done in the dropdown list to 
the right of the checkbox.  Other settings include selecting codes to be tracked 

Picture: Custom Code defined to group weight items for Playground Area 
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for the Workset, titles for comment fields, and setting up margins to be used to 
carry net changes when a Workset is checked back into the project.  

 
Picture: Setting Workset options and defining margins 

The margins can be freely defined, including the number of margins, their 
names, and values.  Click the Browse button (…) to open the Margins dialog 
box. 

2.7.3  Checking a Workset with Weight Items out to the 
Playground Area 

When the Worksets have been set up and defined, weight items tagged to the 
various Workset Codes can be checked out into the Playground Area.  The 
checking of items in and out of this area is controlled in a separate Worksets 
dialog box.   You can access this dialog box by selecting Worksets… in the 
Items menu in the main window.  The Worksets dialog box will show a list of 
the defined Codes for the Workset and you can check weight items tagged to 
this Code by selecting the Code and click the Check Out button. 
The Worksets dialog box gives an overview of the status and history of the 
items that have been checked out or in of the Playground Area.  Columns give 
time and user responsible for the operations belonging to the Workset such as 
checking, reviewing, rejecting and/or approving. 
 

 
Picture: The Workset dialog box gives an overview of status 

 
The status and icons in the Worksets dialog box can be as follows: 

 Red arrow means the Workset has been checked out 
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 Red arrow with exclamation mark means the Workset has been 

reviewed and rejected 

 Red arrow with plus sign means a new Workset, previously not existing 

in the main data, has been imported or added manually in the 

Playground Area 

 Green arrow means the Workset has been checked in and approved 

2.7.4  Working with Checked Out Items in the Playground 
Area 

The weight items that have been checked out through the Worksets dialog box 
can be opened in the Playground Area and changes can be made to the 
Workset.  Weight items can be changed, added, and/or deleted.  It is important 
to tag new items added with the correct Workset Code to make sure it is 
accounted for when the Workset is up for review. 

 

2.7.5  Reviewing Worksets (Rejecting or Approving 
Worksets) 

When a job on a Workset is finished, the change details and net change may 
be reviewed and the Workset may be rejected or approved.  From the 
Worksets dialog box, the Workset can be reviewed by selecting the Workset 
marked as Checked Out and click the Review button, this will open up a 
Review dialog box. 

 
Picture: The Review dialog box 

The upper left area of the Review dialog box contains information about the 
current Workset that is up for review.  This includes information about who 
checked it out and when it was checked out, as well as whom and when 
changes last were made to the Workset.  Further, information is displayed for 
Codes belonging to the items in the Workset as selected in the Options dialog 
box. 
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The upper right part of the dialog box gives the opportunity to add comments 
(titles are defined in the Options dialog box) to be saved in the Worksets dialog 
box along with values for the net changes.  Further in this area, information 
about the net change, and selection of the margin for which the net change will 
be deducted from is made.  All of this information will be stored in the Worksets 
dialog box for future reporting when/if the Workset is approved and checked 
back in. 
 
The lower part of the dialog box shows the details of the changes that have 
been made to the Workset.  If a weight item has been changed in the 
Playground Area, the net change for the item will be shown in the lower area.  
A checkbox Show details is available to enable or disable the detailed 
information.  The disabling of the detailed information will prevent slow 
performance of the dialog box in case of a very large number of changes in the 
Workset. 
Colors in front of each change line indicate the type of change.  Green means 
an added item; red means a removed item, while orange means a changed 
item.  Once the details have been reviewed, the user has the option to: 

 Reject the Workset – in which case the items will not be checked back 

into the main data 

 Review the Workset OK – in which case the change is reviewed OK 

but not checked back in 

 Approve and Check the Workset back into the main data 

 

2.7.6  Running a Report of the Net Changes 

When the Review dialog box is closed, actions taken in this dialog box are 
logged in the Worksets dialog box.  The Worksets dialog box has a Print 
button that will produce a simple report of all net changes that have been 
handled through Worksets. 
 
 

2.7.7  User Permission Settings for Playground Area 

A new branch in the Permissions tab in the User Group dialog box has been 
added to control access to the Playground 
Area.  This makes it possible to set up user 
groups that are only allowed to access the 
Playground Area.  The permission setting 
works in a way similar to the Items dialog box 
when run in normal mode. 
 
 
 
  

Picture: User Permission Settings for 
Playground Area 
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2.8 Making the project ready for export to the ship 
database 

 
When all the weight items are entered into the breakdown structure and the 
lightship weight is complete, the weights can be exported to the common ship 
database. However, the main objective is not to export the weights alone. In 
order to establish an estimation coefficient, the estimation parameters should 
be exported together with the weights. 
 
To enlighten this, look at the following example: 
 
In the cargo area the weights has summed up to 300 tons. An estimation 
formula is attached to the cargo area weight group.  
 
The formula goes: W = k * V 
 
The weight equals a coefficient multiplied with the volume of the cargo area.  
 
If we export just the weight and not the volume parameter, a coefficient cannot 
be established for later estimation. Therefore we would like to register the 
volume parameter. After registering all possible parameters the project will be 
ready to be exported. 
 

2.8.1 Filling in missing parameters 

 

 
 
 
In the Parameter list, the user has the possibility to pick  the desired parameter 
and then input the corresponding value in the Power column. 
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2.9 Exporting to the ship database 
When the project is ready to be exported, the export itself is quite simple. From 
the Project menu, select Export > Historical database… to open the 
Historical database dialog box. Click the Select all button and then click the 
Export button. 
 

 
 
 
Now all information from this project can be reused in estimation. 
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2.10  Log activities and results 
Documentation is often a key word when working, and the log feature in 
ShipWeight will help you with this. 
 
Selecting Comment… from Weight Groups menu in the menu bar will provide 
a dialog box useful for logging. This dialog box can be opened at any time. 
 
From the Wgt.grp. dropdown list, select the current weight group. By clicking 
the Get Weight groups button the weight information for this weight group will 
be available in the comment field. 
 
 

 
 
Any notes can be written in the Comment text field, in addition to the weight 
information. 
 
By clicking the Add to log button, the text in the Comment field will be stored 
in a log file together with the date, time, name of user and the code values. 
 
The dialog box has also buttons for editing, deleting and printing the log. 
 
 



 

52 
 

2.11  Reports and documentation 

2.11.1 Standard reports 

From the Project menu you can select Report Setup… to specify the options 
for a standard report. 
 
The Report Setup dialog box has a work breakdown tree where selections can 
be made which weight groups should be included or not in these weight reports.  
When the reports are run, the Report Filter dialog box has extended 
capabilities for filtering; the general filter dialog box has been added on a 
separate tab in the report filter screen, and is opened by the Browse button. 
 

  
 

 
 
 

The user can decide which columns to be 
included in the report. In a list window inside the Wgt.grp. frame VCG, LCG, 
TCG, Aft and Fore are listed and selected. This means that the report will 
include columns containing values for these quantities. By selecting or 
unselecting the quantities in the list, the user can decide whether to include or 
exclude them in the reports. 
 
The Wgt.Grp. frame also contains checkboxes for Comment, Sum and SFI 
code. Selecting Comment will make reports include comments tagged to the 
different weight groups (using the Log dialog box). Selecting Sum will make 
reports with summarized lines after each level instead of setting the report up 
in a hierarchical way as default. Checking the SFI code box will include 
corresponding SFI codes in the report in addition to the weight group codes. 
 
In the Weight groups frame the user can choose which weight groups to 
include in the report. The options are: All, Defined and Input level. Selecting 
Input level will make reports only with weight groups at the lowest level where 
values exist. This means that the summarized weight groups will be excluded. 
 
The report can be sorted by Unit, Area or Object. This can be set in the 
Parameter sort area. 

Selection can be made to decide which weight 
groups are to be included in the weight reports 

A general filter has been added to the filter screen 
of the standard reports 
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The selection of Code type determines which code structure to be reported in 
the Codes report. 
 

 
 
After setting the desired options in the Report Setup dialog box, from the 
Project menu by selecting Reports, reports can be opened in the Print 
Preview dialog box. The 10 available reports are: 
 
Project Info 1-page report with Project Info 
Main Parameters 1-page report with Main Parameters 
Parameters 1-page report with Parameters 
WgtGrp summary Summary report of Weight & COG per WgtGrp 
Code summary Summary report of Weight & COG per Code 
Item listing Listing report of Weight & COG of all Items 
WgtGrp Weight & std.dev. Summary report of Weight & Std.Dev. per WgtGrp 
Envelope Weight & CoG Listing report of Envelope Weight & CoG per Code 
Methods/Coefficients Report of Methods & Coefficients 
Modular Weight Distr. Report of … 
 
 
In addition you can print reports from many of the dialog boxes in ShipWeight, 
and get special reporting from that task. Click the Print button in the specific 
dialog box.  
 
Clicking a Print button or opening a report will always open the Print Preview 
dialog box. This dialog box presents a preview of the output and offers different 
ways of handling it. By clicking on the preview area, the user may zoom in a 
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part of the page. Clicking the Print button will send the report to a print device. 
The Setup button will open a dialog box for selecting a printer and setting its 
properties. Further there are options for output to MS Excel, MS Word and 
Ascii file. 
 

 
 
 
 

2.11.1.1 Filter Settings on Standard Reports 
 
The standard reports 4. Weight & CoG wgt.grp.summary and 6. Weight & 
CoG item listing which are executed from the menu Project > Reports… will 
open a Report Filter dialog box upon report selection for selecting the weight 
items and/or groups to be included in the report. 
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Filters can be set for any combination of weight group, item number, item 
description and/or code.  A blank filter field means no filter setting for this 
quantity, while a percentage sign (%) can be used as wildcard. 
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2.11.2 Special reports: The ShipWeight Reports dialog 
box 

ShipWeight includes a powerful report engine, the ShipWeight Reports dialog 
box. To start ShipWeight Reports, from the Project menu, select Crystal 
Reports…. 
 
The ShipWeight Reports dialog box is built on Crystal Reports by Business 
Objects. Crystal Reports is a tool for designing reports. Custom reports can be 
designed using Crystal Reports and run/viewed in the ShipWeight Reports 
dialog box.  
 
The dialog box contains a Toolbar and a Report Viewer. 
 

 
 
 
To view a report, either select a report from the Select report dropdown list or 
locate a report file with file extension .RPT by clicking the Browse button. Next, 
click the Run report button. 
 
If the report requires parameters, a dialog box will appear, asking for the proper 
parameters. 
 
The report will now be displayed in the View-area. 
 
The View-area consists of two parts: a group tree (at the left side) and the main 
area for displaying the report. 
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The group tree is a hierarchical tree view showing the weight groups. The group 
tree can be used for navigating through the report. You can jump to any part of 
the report by clicking the branches of the tree. 
 
The toolbar includes buttons for viewing, printing and exporting reports. 
 
 
 

 
 
These are: 
 
Export Report   Export the report to PDF, Excel or Word 
Print Report    Open the Print dialog box 
Refresh      Refresh the report 
Toggle group tree  Show or hide the group tree structure  
Navigation    Jump to first, previous, next or last page 
Goto page     Specify a page number to go to 
Search      Find text 
Zoom      Zoom in/out 
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2.11.3 Tutorial: Run a Log report 

In this tutorial we will run a Log report using the ShipWeight Report dialog box. 
The log report shows the weight items of a project at a given time. 
 
From the Project menu, select Crystal Reports… to start ShipWeight Reports. 
 

 
 
The first thing to do is to select the report you want to run. In this example we 
will use the report Weight and cog sample.rpt. Select the proper report from 
the dropdown list. 
 
Alternatively, you can locate the report file on your hard drive. Click the Browse 
button to open the Open dialog box. 
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Normally you find the .rpt report files on C:\ShipWgt\Database. When you have 
located and selected the file Weight and cog sample.rpt, click Open. Now 
Weight and cog sample.rpt will show in the Select report field. 
 
Next, click the Run report button. 
 
Now a new dialog box will pop up, asking you to set the parameter values for 
the report. 

 
 
You must select the project ID from the list. To display the report, click the OK 
button. 
 

 
Now, use the toolbar or the group tree to navigate through the report. Also try 
sending the report to printer (warning: reports may contain a vast number of 
pages) or exporting it to portable document format (PDF), Word or Excel. 
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2.11.4 Weight tracking report 

 
A customizable Weight tracking report is available using the Weight Report 
Setup dialog box. To open this dialog box, from the View menu, select 
Summary Report…. 
The Weight Report Setup dialog box is divided into four tabs: Input, 
Comments, Settings and Graphs. 
 
The Input tab 
The Input tab is used to specify the data presented in the report. This includes 
two frames: 
 
The Current frame 
Revision number of the current project. Important: This must be a number 
between 01 and 10. 
Revision date. The date can be given in any format. 
 
The Project databases frame 
Path: Name of the server, database and projects containing the previous 
revisions. Add a new path by right-clicking the list with the mouse and select 
Set database… 
Date: the dates of the previous revisions. Add a date by right-clicking the list 
with the mouse and select Set date… Please note that you cannot set a date 
for the Estimate. 
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The Comments tab 
 
 

 
 
 
The Settings tab 
 
The Settings tab is used to customize the report. The layout of the Settings 
tab follows the layout of the Weight-tracking report. It is divided into six frames: 
 
1. The General frame 

Report language: default is English 
Company name 
Path to the company logo 
 

2. The Contract figures frame 
Lightship 
VCG 
LCG 
TCG 
Deadweight 1 
Draught 1 
Deadweight 2 
Draught 2 

 
3. The Total section 

Include total    Toggles the Total-frame on/off 
Force new page       Toggles the New page on/off 
Spacing 
Title 
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Footnote 1 
Footnote 2 

 
Change order frame 
Correct:     Toggle CO-correction on/of 
Code type:    Set code type containing CO code 
Code:      Set CO code 
Title 
Weight 
VCG 
LCG 
TCG 

         Comment 
 
4. The Graph 1 section  

Include graph:    Toggles the Graph-frame on/off 
Force new page:       Toggles the New page on/off 
Show total:     Toggles the total-curve of the graph on/off 
Show estimate line:   Toggles the estimate line on/off 
Show graph labels:  Toggles the graph labels on/off 
Spacing 
Title:      Graph title 
Code type:    Select Code to plot 
Codes 
Graph height 

 
Table frame 
Show table:     Toggles the table containing data for Graph1 on/off 
Footnote 

 
Percentage frame 
Show percentage:  Toggles the percent-columns on/off 
Code type:    Code type for percent calculation 
Code:      Code for percent calculation 

 
Comment 

 
5. The Graph 2 section 

Identical with Graph 1 section. 
 
6. The Centre of gravity section 

Include XZ CoG:    Toggles the XZ CoG-frame on/off 
Force new page 
Spacing 
Title 
Show estimate:          Toggles the plot of the estimated CoG on/off 
Show labels:           Toggles the curve labels on/off 
Graph height 
Show YZ CoG:             Toggles the YZ CoG-frame on/off 
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Table frame 
Show table:    Toggles the table containing CoG data on/off 
Footnote 

 
Comment 
 

7. The Weight Distribution section 
Include Weight Distribution XZ:      Toggles the XZ CoG-frame on/off 
Force new page 
Spacing 
Title 
Show weights 
Show polylines 
Show profile 
Plot height 
Include Weight Distribution YZ:      Toggles the XZ CoG-frame on/off 
 

Table frame 
   Show table 
   Footnote 
 
Comment 

 
8. The Total Revision History section 

Include revision comment history:  Toggles the comment history on/off 
Force new page 
Spacing 
Title 

 
9. The Graph1 Revision History section 

Include graph1 comments 
Force new page 
Spacing 
Title 

 
10. The Graph2 Revision History section 

Include graph2 comments 
Force new page 
Spacing 
Title 

 
11. The CoG Revision History section 

Include CoG comments 
Force new page 
Spacing 
Title 
 

12.  The Weight Distribution Revision History section 
 Include weight distribution comments 
 Force new page 
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 Spacing 
Title 

 
13.  The Contact section 

 Show contact 
 Spacing 
 Title 
 Force new page 
 Text 
 Name 
 Telephone 
 Email 
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The Graphs tab 
The Graphs tab contains five new tabs with a preview of the curves Graph1, 
Graph2, Centre of Gravity, Weight Distribution and Y-Z CoG 
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2.11.5 Modular Weight Distribution Report 

 
The Project > Reports > Modular Weight Distribution menu item will start a 
report that calculates three-dimensional mass distribution of weight items within 
the defined boundaries of a unit/module to obtain the weight, center of gravity 
and mass distribution of each unit/module. 
Calculations are based on the SAWE paper no. 785 – “Mass Distribution 
Requirements for Modular Ship Construction in the Preliminary Design Phase” 
by Norris L. Wood and Charles M. Mead, 1969 
The report is showing weight and center of gravity contribution (portion) for each 
weight group / line item on the defined block units (rectangles) and visualization 
of each weight group / line item portion contained within the block units can be 
shown in ShipWeight’s Code Envelope dialog box (menu View > Code 
Envelope…) 
To make the report, a custom code must be assigned as the module code, and 
min/max values for the VCG, LCG and TCG must be defined for the sub codes 
of this code in the Code Definition dialog box (menu View > Code 
Definition…). 
 

 
 

 
 
Next, the custom code holding the unit/module data must be set in the Report 
Setup dialog box (menu Project > Report Setup…) before the report finally 
can be run (menu Project > Reports > Modular Weight Distribution…). 
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2.12  Adding comments to specific weight groups 
 
Using the Comment dialog box, you can store logging information belonging to 
a specific weight group. From the Wgt.grp. dropdown list, select weight group 
and click the Get wgt.grps. button. Current values for weight and CG will be 
added to the Comment field. Enter a note in the comment field and click the 
Add to log button. 
 

 
 
This way logging information that is not general can be tagged and sorted to 
the relevant weight group only. This also makes it possible to produce reports 
where weight group specific comments are included along with the weight 
values for the weight group. 
 
The Comment dialog box opens from the View menu by selecting Comment 
and then Project Comments… / Wgt.grp. Comments… or from the Weight 
Groups menu by selecting Comment…. 
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3 Estimating Weight and CoG 

3.1 Starting a new estimation 

Start a new ShipWeight project. The next step in a new estimation in 
ShipWeight is to select the vessels to be included in the basis for estimation. 
 
From Estimate menu, select Reference Projects…. It can also be opened 
from the Estimation dialog box menu bar under Graph. 
 

 
 
By using the Reference Project, Include all, Exclude all buttons ships to be 
included in this basis can be selected. By selecting a ship and then click on the 
Reference Project button a ship is included. Click once more and the same 
ship will be defined as excluded. Also by selecting a ship and clicking the Sister 
Project button, the user can select a ship to be traced particularly in the 
Estimation dialog box. 
 
A green R represents a ship chosen to be in the basis. 
A gray X indicates a ship excluded from the basis. 
A red S marks the chosen Sister Project. 
 
The Reference Projects dialog box has sorting capability for the columns.  
Sorting ascending/descending is activated by clicking on the header columns.   
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The information in this dialog box may also be copied to and pasted from the 
clipboard, in example to do editing in Excel.  Mark the vessels to be copied in 
the ship list by selecting them with the mouse and select Copy project(s) from 
the submenu when right-clicking the mouse from the ship list in the Reference 
Projects dialog box. 
 
Important! 
This initially selection of vessels in the Reference Projects dialog box is only a 
rough selection of ships. It is therefore advised to include all ships that you have 
weight data you rely on, and then do a more refined selection of vessels and 
coefficient filtering in the Estimation dialog box. 

 

3.2 The Estimation dialog box 

From the Estimate button on the toolbar or from the Estimate menu, select 
Weight, the Estimation dialog box will pop up. 
 

 
 
 
The Estimation dialog box contains four major areas, the Graph area at upper 
left, the Parameter and Coefficient dialog boxes at the upper right, the 
Reference Ships dialog box in the middle to the right and the Comparison 
area in the lower part of the dialog box.  
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3.2.1 The graph area in the Estimation dialog box 

 

 
 
In the Graph area coefficients from vessels in the common ship database are 
plotted. The coefficients are plotted as black dots. The coefficient values can 
be read out of the vertical axis and they are plotted against a set of plot 
parameters on the horizontal axis. A regression line is plotted through the 
coefficients. 
 
The vertical dashed line represents the plot parameter value for the project to 
be estimated. To examine a coefficient represented by a dot, the dot can be 
clicked, and this ship's parameters will be shown in the Comparison area. 
 
The way of selecting the coefficient in the Graph area is to use the Coefficient 
type dialog box.  
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3.2.2 Explanation to the standard selection coefficients 

The regression coefficient is the value calculated in the intersection between 
the regression line in the graph and the plot parameter for the weight group. 
 
The default coefficient is shown by the dotted line in the graph. This coefficient 
is stored in the coefficient database (see Chapter 5 Additional 
databases/libraries in ShipWeight), and are to be used if the basis for the other 
coefficient are none-existing or not satisfactory. 
 
The sister ship coefficient is the coefficient for the ship selected as sister ship 
in the Reference Ships dialog box. 
 
The adjusted sister ship coefficient is the coefficient for the ship selected as 
sister ship in the Reference Ships dialog box, but adjusted according to the 
trend in the regression line. 
 
The average coefficient is the average value of the coefficients in the graph. All 
coefficients are weighing equal when finding the average. 
 

3.2.3 The plotted ships list in the Estimation dialog box 

The plotted ships list displays information of all vessels in the historical 
database, even the vessels are not plotted in the graph. Through the 
checkboxes the user can easily include or exclude single projects. 
  

 
 
The yellow color is added to the parameters that are not fulfilling the current 
vessel selection criteria and thus excluded from the graph.  
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3.2.4 The comparison area in the Estimation dialog box 

 

 
 
When clicking on a coefficient dot in the Graph area that vessel’s parameters 
will be shown in the Comparison area compared to the project’s parameters. 
These parameters also represent the parameters that can be used to set 
constraints on the coefficients to be plotted in the graph. 
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3.3 Filtering the coefficients in the graph 
One of the strong features of ShipWeight is the possibility to do logical 
selections of the coefficients to be plotted in the graph. This makes it easy to 
plot only the relevant coefficients in the graph and thus obtain a good regression 
line and a good coefficient for estimating. 
 
The first and natural way to filter the coefficients is to select which ship types 
are to be plotted. Selecting Ship Types… under Graph in the Estimation 
dialog box menu bar let you do this. Alternatively, click the Shiptype button in 
the Estimation dialog box. 
 
 

 
 
As a default, all the ship types under the main ship type equal to the project’s 
main ship type are selected. By navigating in the tree-structure, using the 
Include and Exclude buttons, ship types can be selected or deselected from 
the plot. When you are set, click Close to go back to the Graph. 
 
 
The other way to put constraints on the coefficients to be plotted is to select a 
comparison parameter in the grid fields in the Comparison area, and then 
select Filter limits… under Graph in the Estimation dialog box menu bar. 
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In this dialog box you can set the upper and lower limit for the comparison 
parameter you have selected. Only ships with parameter value within the given 
limits will be plotted.  
Remember to set both upper and lower limits. 
 
When you are satisfied with the selected coefficients and have estimated the 
weight and standard deviation you can go on with the estimation by one of the 
following options: 
 
Estimate VCG and LCG for that weight group by selecting VCG or LCG in 
Estimate in the menu bar. 
 
Do estimation on another weight group by navigating by selections in the 
Weight group menu in the Estimation dialog box. 
 
Return to the main window by closing the dialog box, navigate to another weight 
group in the main window, and then open the Estimation dialog box again, now 
with the new weight group in focus. 
 
To ensure an efficient use of time, selecting the Most uncertain function from 
Weight group in the menu bar in the main window will guide you to a new 
weight group. Further splitting and estimation on lower levels of this weight 
group will give the greatest impact on the total lightweight. This works only if 
standard deviations have been calculated for each weight group estimated 
earlier. 
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3.4 Graph options 
Under the Graph menu in the Estimation dialog box, many options are 
available for displaying different information in the graph. 
 
 

 
 
Most important are the regression line and the choices regarding the regression 
type. If Auto is checked in the menu, the system chooses the regression line 
that gives the lowest standard deviation coefficient. However, it is important to 
remember that if the number of coefficients is low, it might be wise to judge 
yourself if other types of regression line are more appropriate. By ticking off the 
Auto option, the user is free to decide whether linear, logarithmic, exponential 
or power regression should be used.  
 
Other useful options in the Graph menu are options to view default coefficient, 
labels, standard deviation and average coefficient. A blue- and a green dotted 
line in the graph display the default and average coefficient. The label option 
will label the coefficients plotted in the graph with the ID (filename) of the 
project. The two gray lines display the standard deviation. 
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3.5 Saving your settings in the Estimation dialog box 
 
In the Estimation dialog box you will find the Setting menu: 
 

 
 
The menu makes it possible to save settings in the Estimation dialog box so 
that the next time you enter the weight group you retrieve the same settings in 
the dialog box as you had when you last saved your settings. 
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Saving settings after estimation makes it easier in future to understand why a 
certain coefficient was picked during estimation. It is also possible to save a 
special setting by a name and then retrieve this setting later. This is done by 
selecting Save Current Setting As… 
 

3.5.1 Quick Load/Save of Estimation Settings 

Settings that have been set in the Estimation dialog box can be saved and 
deleted from the leftmost buttons on the toolbar. A setting previously saved for 
a weight group can easily be copied on to a different weight group by selecting 
the name of this weight group from the dropdown list on the toolbar.  
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3.5.2 Importing estimation settings 

Import Estimation setting enables you to import a previously saved estimation 
setting. 
 

 
 
Select the setting you want to import and click Import to use the setting in the 
current weight group. If you have settings in other databases you want to use, 
you can browse and select this.  
  
The Get default setting option in the menu will restore the setting regarding 
vessel type to default (vessels included = same main type) and reference ship 
equal to the one that are picked in the main window. 
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3.6 Taking uncertainty into account 
In the estimation area, the right-hand column contains information about the 
standard deviation. The standard deviation can be given either as an absolute 
value or as a percentage. To switch between these ways of showing the 
uncertainty, select the Std. Dev. in the Estimation dialog box. 
 
The deviation of the selected estimation coefficient is calculated from the 
spread of the coefficients around the regression line. If the number of 
coefficients is less than three, the deviation cannot be calculated. Then a value 
based upon subjective judgment can be manually entered into the grid. 
 
If some of the other parameters are uncertain, an uncertainty value should be 
entered into the grid to the right parameter value. When all parameters have 
got appropriate uncertainty value attached, clicking the Calc.std.dev button in 
the Estimation area gives the total uncertainty for the weight in this weight 
group, and this value is stored. 
 
By the use of successive calculation the uncertainty for a weight group 
containing subgroups, will be calculated on the basis of the uncertainty of the 
subgroups. 
 
Even though the uncertainty is an approximate method to obtain the uncertainty 
for a weight and even if you have to set the values yourself for most weight 
groups, there are several reasons to take the uncertainty into account. First of 
all you will be able to use your resources where they are most needed. When 
selecting Most uncertain under the Std. Dev. menu in the main window, 
ShipWeight will take you to the weight group where a further estimation and 
splitting of the group will give the greatest impact on the total result. This will 
help you to focus on the weight groups that really matter at any stage of your 
estimation. Secondly, taking uncertainty into account will give you a basis to 
compare the uncertainty between different projects. 
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3.7 Using the Remainder group in estimation 

3.7.1 Combining known and estimated weights 

It is possible to estimate weight groups consisting of sums of sub-weights. This 
is particularly useful when some of the weights are known while others must be 
estimated. If an estimate is carried out on a weight group containing data in any 
of its subgroups, the difference between the estimated value and the values of 
the subgroups automatically will be added to the Remainder-subgroup. 
 
For example: you are to estimate the weight group M1 (Machinery), but already 
know the weight of some of its subgroups e.g. M1.1 (Diesel-engine for 
propulsion). Make sure to enter the known weights of the subgroups. Then 
estimate the weight group M1. The difference between the estimated weight for 
the group and the weight of the subgroups is added to M1.R (Remainder 
machinery). 
 

3.7.2 Dynamic Remainder: Freezing the above weight-
group 

It is possible to keep the value of the above weight group unchanged while 
estimating. This is done by adjusting the Remainder according to the new 
estimate. 
 

 
 
To activate this mode, select Freeze Wgt.Grp. Over on the Estimate menu or 
click the corresponding button in the main window (key):  
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3.8 Automatic Calculation of Weight Groups as 
Percentage of other Weight Groups  

In some cases it may be desirable to have a weight group calculate itself 
automatically based on another weight group or based on several weight 
groups.  An example of this would be to have a margin group calculate its own 
weight as 5% of the lightship weight.   This is possible to achieve by using the 
Weight Group Percentage Setting dialog box. This dialog box is opened from 
ShipWeight main window menu Wgt.Grp > Percentage setting… 
 

 
 

 Add a relationship between groups 

Select the weight group to be automatically updated from the left 

dropdown list in the dialog box.  Next to the dropdown list, type the 

percentage to be used when calculating the weight automatically.  

Select the weight group which value the calculation should be based 

upon from the dropdown list to the right.  Click the Add button to 

register the relationship.  The relationship will be listed in the list below. 

 

 Delete a relationship between groups 

Select the relationship to be deleted from the list.  Click the Delete 

button to remove the automatic calculation relationship.  You may also 

delete all defined relationships at once by clicking Delete all button. 

 

 Edit a relationship between groups 

Select the relationship to be edited from the list.  Make the appropriate 

changes in the dropdown lists and percentage field and click Edit 

button to update 

 

 Import relationship from other projects 

Click Import project button to open up a project selection dialog box 

and select the project from where you want to import relationships. 
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 Export and Import relationships through text files 
Use Export ASCII and Import ASCII buttons to create and import 
relationships through text files between projects on different servers. 
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3.9 Starting a new project based on the results from 
the estimation 

When the weight activity turn from estimation into a weight take off (WTO) 
activity, we establish a new project. 
 
There are two philosophies for the weight control activity;  
 
Start with an empty project and enter weights toward 100% 
Start with the estimate and continuously replace weights with more exact 
(reliable) ones.  
 
In the last-mentioned case, we will always have 100% in the database. 
 
In both cases it will be useful to reuse a certain amount of the information stored 
in the estimate database. 
 
An import function is available from the Project menu by selecting Import > 
ShipWeight 11.0 Data…  
 
First you select from which project database and project you want to import 
information from. 
In the Import Values to Project Database you specify what kind of information 
you want to import. 
 
If you just want to import the parameter-values from the design project, you just 
select Parameters from the list and then click the Import button. If you also 
want to import weight and CoG information, you select the Weight, VCG, LCG, 
TCG & distribution topic from the list.  
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4 Additional features 

4.1  Weight distribution 

The Weight Distribution dialog box is opened from the View menu by 
selecting Weight Distribution… > Curve…. Alternatively, click the Weight 

Distribution Curve button on the toolbar:   
 
When you are estimating or registering weight items, the extension of the item 
can be given: 
 
LCG_min (Aft) 
LCG_max (Fore) 
VCG_min (Lower) 
VCG_max (Upper) 
TCG_min (PS) 
TCG_max (SB) 
 
Together with the Center of Gravity of the weight item, this will make a trapezoid 
approximation to the weight distribution for that single item. 
 
When summarizing all the approximated distributions, a weight distribution 
curve for the total ship is obtained. 
 

 
 
 
Weight distribution curves can be plotted in longitudinal, transverse and vertical 
directions. To change the direction of the weight distribution curve, simply click 
one of the tabs X-Z-dir, Y-Z-dir or Z-Y-dir. 
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It is important that all items are given values for the start point and end point of 
the item: LCG_min, LCG_max, TCG_min, TCG_max, VCG_min and 
VCG_max. If an item lacks one of these values, the default value for extension 
will be applied. The default extension value is set in the Options dialog box, on 
the General tab. 
 

 
 
Two values can be given for Extent: default and min. 
 
The default value is applied if any of the values LCG_min, LCG_max, TCG_min, 
TCG_max, VCG_min and VCG_max are missing. 
 
Example: The ‘default’ extension value is set to 10 m: 
 
 
 
 
 
 
 
 
The min value will be used if the given extension of a weight item is less than 
the minimum value. 
 
Example: The ‘min.’ extension value is set to 2 m: 
 
 
 
 
 
 
 

 Given 
value: 

Value used in 
wgt.dist. curve: 

LCG 20 m 20 m 

LCG_min Not given 15 m 

LCG_max Not given 25 m 

 Given 
value: 

Value used in 
wgt.dist. curve: 

LCG 25 m 25 m 

LCG_min 24.8 m 24 m 

LCG_max 25.2 m 26 m 
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If the Weights checkbox in the dialog box is checked, then all weight items will 
be plotted into the distribution area as a visual check.  
 
Each point in the graph will symbolize an item and its position. The green points 
are equipment items, the black points are steel items and the red points are 
machinery items. 
 
By clicking on one of the points and holding the mouse button down, the user 
will get short information about the item. This way you can check any suspicious 
looking items and find errors. 
 

 
 
If the Polylines checkbox is checked a sidebar pops up. 
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The dialog box will extend to the right when Polylines is checked. In the tree 
structure that appears to the right, the appropriate parameters can be entered 
or edited by clicking the parameter in the window.  
 

 
 
The weight distribution curve can be plotted either with metric/US or frame 
spacing as plot unit. 
 
There are four ways of plotting the weight distribution curve: 
 
Accurate: Plot the curve as accurately as possible. 
 
Wgt.grps. 
 
Step: Set the minimum step for the curve. 
  
Station: The curve is plotted with a given number of stations 
 
The Update button updates the curve if changes have been made to the project 
after the distribution dialog box has popped up. 
 
 

4.1.1  Weight Distribution Calculations in ShipWeight 

The following attempts to describe how weight distribution is calculated in 
ShipWeight.  In general, ShipWeight approximates the distribution for each 
individual weight item to either a uniform, triangular or trapezoid distribution.  
These individual items are then added together making up the total “accurate” 
distribution.  The accurate distribution can be converted to a distribution of 
stations or bars. 
 
Consider the following weight items: 
 
Nr Weight LCG LCG_min LCG_max 

1 10000 50 0 100 

2 6000 40 20 60 

3 2000 30 10 40 

4 2000 58 50 70 

 
 
 
 
 
In ShipWeight, the distribution of these items will individually be represented 
like this: 
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1.  Item with uniform distribution: 

 
 

2.  Item with uniform distribution: 

 
 

3. Item with triangle distribution – LCG located at 2/3 of the items 
extension 
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4. Item with trapezoid distribution – LCG between 1/3 and 1/2 of the items 
extension 

 
 
When ShipWeight calculates its “accurate” distribution, the items are added 
together.  Compare the colors in the individual representations with the colors 
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of the “accurate” representation to locate each weights item’s contribution to 
the total curve. 
 
 

 
 
The user may choose to represent this curve in stations.  ShipWeight calculates 
the stations by dividing the “accurate” curve into the number of stations to be 
plotted.  Each share of the “accurate” curve is integrated giving the area under 
the curve between the stations.  Next this area will be represented by a station 
or bar with the same area as the curve area it replaces. 
 
This secures a one to one relationship in area between the “accurate” curve 
and the station curve.  Further, this means that the area contribution from 
individual items which distribution is covering more than one station will be split 
into appropriate parts in each station.  This secures the best possible 
conversion between “accurate” and station curve. 
 
See figure on next page representing the station version of the curve.  Again, 
the colors will help compare the curves to visually inspect how conversion takes 
place. 
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In both cases, the area under the distribution curve equals 20 tons.  The figure 
below shows the “accurate” curve drawn in red with the station curve 
superimposed and drawn in green.  This shows how the curve is transformed 
and the area preserved. 
 

  
  
Of course, the same reasoning is also valid with any other number of stations, 
not just 10.  The figures below shows same principles for the distribution curves 
as discussed above, only this time with a 20 station curve. 
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4.1.2 Individual Station Settings in Weight Distribution 
dialog box 

 
By setting Curve Type to “Individual Stations” you may individually set the 
start and stop points for the different stations of the weight distribution curve.  
The station setting is set on the format X1;X2;X3;…Xn where X is the LCG 
endpoint of each station (except the last station). 
 

 
 
 
 

4.1.3 Creating a SAWE RP12 station profile 

To automatically create a station profile that complies with SAWE 
(www.sawe.org) recommended practice 12, right-click the Graph area with the 
mouse and select Create SAWE stations from the submenu. 
  

http://www.sawe.org/
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4.1.4  Inserting a Vessel Profile from a JPG file 

 
 
If a JPG file has been added to the Graphic Drawing field of the Project Info 
dialog box (menu View > Project Info…) then this file can be applied to the 
weight distribution curve. Profile checkbox must be checked in the Weight 
Distribution dialog box.  Use the mouse to right-click the Graph area and 
select  Maximize Profile and next Set AP and Set FP to indicate on the drawing 
where the aft and fore perpendiculars are located.  This way ShipWeight is able 
to scale the drawing correctly into the weight distribution curve. 
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4.1.5  Exporting weight distribution 

Clicking the Print/Export button in the dialog box makes it possible to send the 
curve to a printer or file, either graphically or numerically. It is also possible to 
export the weight curves in formats to be read by GHS, Tribon, NAPA and 
AutoShip. 
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4.2 Gyradius 
When selecting Gyradius… under the View menu, approximated key values 
for gyradius can be obtained.  
 

 
 
 
The following formulas are used for calculation of Roll gyradius: 

 
Kxx = gyradius 

w = weight of item 

 = displacement  
Itx = sum of transference inertia of elements itx 
Iox = sum of item inertia of elements iox  

(= 0 when ‘Include 2.term of Steiner theorem’ is not 
selected) 
x,y = location of the item with respect to CoG 
a,b = extension of the item 

 
Similar formulas are used for Pitch and Yaw calculations. 
 
For Pitch/Yaw calculations, the following formula applies: 

 
 
 

Similar formulas are used for Roll/Yaw and Roll/Pitch calculations. 

)(
12

)(

22

22

,,

ba
w

i

yxwi

iI

III

I
K

ox

tx

oxtxoxtx

oxtxxx

xx

xx














)( zywiyz 



 

97 
 

If Include 2.term of Steiner theorem is selected, the following rules will apply 
when calculating moment of inertia: 
 
If a weight item is defined with extension in all 3 dimensions, self-inertia will be 
calculated for that item and included in the total moment of inertia 
 
If a weight item is defined without extension in all 3 dimensions, self-inertia will 
be neglected for that item. 
 
When calculating the self-inertia, the shape of the weight item will be 
approximated to a box 

 
The Gyration dialog box buttons Item filter and Wgt.Grp. filter enables the 
calculation of gyration for parts of the vessel defined by the filter specifications.  
Clicking these buttons will pop up the standard filter dialog box as used in Items 
dialog box and Weight Distribution dialog box. 
 
The Gyration dialog box will list gyration contribution from each single weight 
item in the details list of the lower part of the dialog box.  The canned print report 
from this dialog box also has the option of whether or not to include the item 
details in the report. 
 
The Gyration dialog box gives the opportunity to include self-inertia defined in 
custom codes by checking the Predef.Val. checkbox and referring to the 
custom codes holding self-inertia values by selecting these from the 
corresponding dropdown lists x, y, and z –axis. 
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4.3 Comparing projects 
Projects can be compared on weight group level basis. The dialog box is 
opened from the View menu by selecting Compare… . You will be asked to 
open another project and this can now be compared to the project you were 
working in. The different property sheet tabs in the dialog box are used to select 
which of the user defined different codes structures the projects will be for 
compared according to. 
 

 
 
Several options in the dialog box let the user do different comparisons: 

 
List can be done for all weight groups or only for the ones containing 

values 
 
Sort  sort the listing either by hierarchy order or by deviation 
 
Show CoG  the user can specify if VCG, LCG or TCG should be included  
 
Deviation  can be shown in absolute values or in percentage 
 
Predict linear prediction will assume the total weight if the deviation in the 

project continues with the same percentage deviation for future 
weight registering as up to now. Constant prediction will predict 
total weight if the rest of the project has no deviation. 
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4.3.1 Tree view in Compare dialog box and Total CoG 
Impact from Changes 

The Compare dialog box may be switched to an explorer tree mode by 
selecting Tree in the View frame of the dialog box.  This way it is easier to 
navigate and compare weight groups between projects. 
 

 

4.3.2 Column for Checking Change Impact 

When checking the checkbox Show in the CoG impact frame in the Compare 
dialog box, a column named Impact will appear next the center of gravity 
Deviation columns and show the impact each single deviation has on the total 
center of gravity for the project. 
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4.4 The Auto estimation… dialog box  
The Auto weight & CoG estimation… dialog box is a three step quick estimate 
providing automatic results based upon the ship database. The dialog box is 
found under the Estimate menu by selecting Auto estimation… Alternatively, 
click the Auto Estimation button in the main view: 
 

 
 
The first step is to choose which detail level to calculate.  
 
If you select Auto, the system will detect the weight groups to estimate. 
 

User defined lets the user define which weight groups to be 
included in the estimate. By clicking the Browse button (…) 
to the right of the radio button, the user can define the weight 
groups to be included by ticking them in a tree resource. 
 
Second, Third, Fourth and Bottom gives calculation on all 
weight groups for the level chosen. 

 
 
 
 
Next the user specifies which estimation methods should be used.  
 
Next, you should select Method of estimation. 
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Default makes the standard ShipWeight methods active.  
 

Main parameters use only methods containing main 
parameters. This option can be used when very few of the 
ship’s parameters are known. Use Browse button (…) to 
inspect the methods. 
 
User defined will calculate using the user-defined 
methods. These methods can be checked and edited by 
clicking the Browse button (…) to the right of the option. 

 
Main wgt.grp. will use methods connected to this groups to estimate the 
weights. 
 
 
Then the Coefficient to be used is specified in the last step. 
 

Default will use the default coefficient saved 
for that ship type and weight group. By clicking 
the Browse button (…) the dialog box for 
checking and editing default coefficient is 
opened. 
 
Intersection with regr. line will use the 
coefficient calculated at the intersection 
between the regression line in the graph and 
the plot parameter for the ship. 
 
Sister ship scaling will use the coefficient for 
the ship selected as sister ship. 

 
Sister ship scaling with trend will use the coefficient for the ship selected as 
sister ship, but adjusted according to the trend in the regression line. 
 
By clicking the Calculate button the calculation is executed and the results will 
show in the list at the lower half of the dialog box. 
 
The settings of the Auto estimation dialog box can be saved for later use. First 
enter the name in the Setting field (marked with circle 1), then click the Save 
estimate (marked with circle 2). 
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To retrieve a saved setting, click the Browse button  (…) by the Setting field. 
This will open the Auto estimation setting dialog box. Select one of the saved 
settings from the list to the right, and click OK to apply the settings to the Auto 
estimation dialog box. 
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4.5 User defined estimation methods 
The user can define own methods and store them as a user defined set of 
methods. The user-defined methods are defined in the Method definition 
dialog box, which can be found under the Estimation menu. By default the 
ShipWeight methods are included. The user can edit these to customize own 
methods. 
 
This dialog box makes it possible for the user to define own estimation methods 
for the parametric estimation as an alternative to the default formulas.  Formulas 
can be defined for Weight, VCG and LCG by selecting the appropriate tab in 
the dialog box. 
 

 
 
 
You can navigate through the weight 
groups in the WBS in the tree to the left in 
the dialog box.  When selecting a weight 
group in the tree, the user defined method 
(estimation formula) for this weight group 
can be defined in the grid to the right by 
adding estimation, plot and comparison 
parameters. 
You select the parameters by clicking 
twice in the grid.  This will open a 
dropdown list from where you can select 
the parameter of choice.  Notice the first 
item in the list - <Search…>.  A double- 
click on this will open up a search dialog 
box that helps you find the parameter you 
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are looking for.   Select <Search…> and press ENTER to open the dialog box 
and start typing in the keyword for the parameter.  
 
 
The new defined estimation methods can be used in the Auto estimation 
dialog box by setting the radio button to User defined in the method dialog box, 
or by selecting User defined under the Estimation menu in the main 
Estimation dialog box. 
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4.6  Mapping between code types 
From the View menu select Code Mapping… to open the Mapping between 
codes dialog box. This dialog box enables the user to create a mapping 
between any of the code types. 
 
To create a mapping, first select the two code types: Code 1 and Code 2, e.g. 
Module and Section codes. Then select the values that are to be connected. 
Pairs of linked values can be added, edited and deleted by the buttons at the 
right-hand side of the dialog box. 
 
Code mappings can either be imported directly from other ShipWeight projects 
or via an ASCII-file. 
 
Please note that the mapping is not two-way. In the example below, modules 
are linked with corresponding sections. To create a mapping that works the 
other way round, click the Inverse map button. 
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4.6.1  Code Mapping Sample 

 
First make two codes: “C09 – Compartment code” and ”C10 – Compartment 
description” in the Code Definition dialog box. 
 

 
 
In the Code Mapping dialog box, select C09 and then C1 value in Code 1. 
Then select “Compartment One” under C10 in the Code 2 column. Then click 
Add button.  Do the same for C2->Compartment Two and for C3-
>Compartment Three.  This creates the mapping.  Now close the dialog box. 
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In the Items dialog box, weight items are assigned compartment code (C09), 
but not compartment description (C10): 
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All items to be assigned “Compartment description” through “Code Mapping” 
must be selected in the Table view, and go to Items menu in the Items dialog 
box and select Set Codes by mapping…. 
 
Click OK on the message pop-up and then select “C10” in the pop-up dialog 
box to pick the code to be updated: 
 
 

 
When “C10” is selected in the list click OK and once more click OK to pass the 
message pop-up and then select “C09” in the pop-up dialog box to select the 
code the update should be based on:  
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Click OK again and code C10 should be updated based on the mapping.   
 
You’re done: 
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4.7 The Code Envelopes dialog box 
The Code envelopes dialog box offers a convenient way of checking the items 
tagged to a user defined code structure. To open the dialog box, from the View 
menu, select Code Envelopes….  
 
The dialog box is divided into two parts: a tree view for browsing the code 
structure on the upper part, and the plot area on the lower part. By selecting 
one of the groups in a code structure, the items tagged to this group will be 
plotted both in the XY-plane and the XZ-plane. In the plot each item is 
represented by a number. The items are also listed. 
 

 
 

4.7.1 Plotting multiple envelopes in Envelope dialog box 

 
The Code envelopes dialog box has checkboxes to the left of the custom 
codes holding definitions for envelopes.  Checking these boxes will include the 
envelope and attached items for the code.  The code selected in the list will get 
the envelope and items marked red to distinguish the current selected envelope 
from other envelopes plotted. 
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4.8 Move CoG 
If you want to move certain weight groups quickly to see the result on the center 
of gravity of the total lightship, from the Weight group menu, select Move 
CoG…. 
 

 
 
First select in which direction to move the weights by selecting one of the tabs 
at the top of the dialog box (VCG, LCG or TCG). Then click the Browse button 
[…] at the right of the Top post field to select the weight group to be moved. 
Next set the interval for the groups to move. 
 
To set the start and end limit for weight items to be included in the move, tick 
off the option Restrict limit, and fill in the edit boxes.  
 
The Move Options provides three ways of moving the weight-items: 
 
Check CoG & move absolute – this will move the VCG, VCG_min and 
VCG_max of all weight items with VCG within the move limits. 
 
Check distr. & move absolute – this will move the VCG, VCG_min and 
VCG_max of all weight items with either VCG, aft or fore within the move limits. 
 
Check distr. & scale – this will move the VCG, VCG_min and VCG_max of all 
weight items with either VCG, VCG_min and VCG_max within the move limits. 
Items partly within specified limits will be scaled depending on VCG_min and 
VCG_max values. 
 
Optionally, you can add a filter to select the weight items to be moved. 
 
Finally click the Move button to execute the move. 



 

112 
 

4.9 Importing data to ShipWeight 

4.9.1 Importing from a ShipWeight database (SQL) 

You can easily import data from other ShipWeight databases. Select Project > 
Import > ShipWeight 11.0 data from the menu of the ShipWeight main view. 
 
The Import dialog box will appear. 

 
Now you have to select from which Database you want to import data. The 
Open SQL project dialog box appears. Please choose a database and a 
Project ID to use for import and click the OK button. 
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The Import dialog box includes a list of data to be imported: 
 
Weight groups   Import Weight and CG data for weight groups. 

Important: No weight items are imported, only total 
Weight and CG for each weight group. 

Parameters All defined parameters. To check which parameters 
are imported, please open the Parameters dialog box 
(View > Parameters) of the source project. 

Items Weight items. Please note that the Weight items 
imported are limited by the ‘Topmost wgt.grp.’ 
selected at the bottom of the Import dialog box. 

Equipment  
Code types All defined code types, e. g. C01, C02. Important: 

both Code types and Codes must be selected to 
import the complete code definition. 

Codes All defined codes. 
Logs Log entries (View > Log > Project log…) 

 
 

 
 
Click the Select all button to import all available data. To select two or more 
items from the list, press CTRL or SHIFT when clicking in the list with the 
mouse. 
 
Make sure to set the proper Topmost wgt.grp. Please note that the import of 
weight items are limited by the weight group selected as Topmost wgt.grp. 
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If appropriate, select Overwrite existing data. To start the import process, 
please click the Import button. Click the Close button to exit the Import dialog 
box. 
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4.9.2  Importing weight items from a spreadsheet 

To import weight items into ShipWeight from a spreadsheet, the spreadsheet 
first has to be organized in such a way that ShipWeight is able to import it. The 
weight data in the spreadsheet should be organized in columns. The 
spreadsheet might also have a heading row. The picture below shows an 
example on how a spreadsheet can be organized. 
 

 
 
To know which columns to include and what order to put them, the Import 
dialog box can be checked to find out. The Import dialog box can be opened 
from the Project menu by selecting Text file… from the Import submenu. 
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In the Weight Group list at the right side of the dialog box, possible import 
columns are shown, and what order they should appear in. The columns should 
be in the same order as the vertical order of the quantities shown in the dialog 
box. 
 
You are free to choose whichever columns you like as long as the Weight 
group column is included. This has to be included because the ShipWeight 
import routine needs to know which weight groups to store the imported weight 
items in. If Weight group is selected, the weight groups are connected to the 
weight item directly. If you are using the standard ShipWeight breakdown 
structure, you can choose the SFI Code instead of the Weight group column. If 
the SFI Code is selected, a mapping table in the ShipWeight database will 
translate the SFI code to ShipWeight weight group code. The mapping between 
ShipWeight codes and SFI codes can be checked in the Search… dialog box 
under the menu Weight Group. 
 
After setting up the columns and filling in data so that the spreadsheet is 
organized properly, the spreadsheet file has to be saved as a text file (ASCII) 
with tab delimiter. Give the file the extension .txt if this is not done automatically 
when saving. 
 
Now you are ready to import the file to ShipWeight. If not already done, close 
the spreadsheet file. Select the dialog box Text file… on the submenu Import 
on the ShipWeight Project menu. Enter the path to the import file (the saved 
text file) in the edit field, or find it by clicking the Browse button […]. 
 
If the text file contains a heading row, check the Heading row option. 
 
To replace missing quantity values with default values, make sure to check the 
option Missing qty.=default. The default values for each of the Quantities can 
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be set on the Quantity tab in the ShipWeight Options dialog box. The Options 
dialog box can be accessed from the View menu by selecting Options…. 
 

 
 
To include the imported items in the log database, make sure to check the Log 
checkbox. With logging enabled, the import is more time consuming than 
without. However, logging is needed to be able to create log-reports. 
 
In the dialog box resource ‘Weight group list’, select the same quantities as the 
columns in the text file. 
 

 
 
Finally, click the Import button to start importing the weight items. Click the OK 
button to close the dialog box. 
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4.9.3  Importing parameters from a spreadsheet 

Importing parameters from a spreadsheet is analogous to importing weight 
items. Make sure the spreadsheet is organized in the columns ParamID, 
Description and Value. The spreadsheet must be stored as a tab delimited 
text file (ASCII). 
 
Open the Import text file dialog box and select the Parameters tab. Enter the 
path of the file to be imported, tick off Overwrite and Heading row (if the 
spreadsheet contains a header row) and click the Import button. Warning: If 
the import file contains parameters without value, existing parameters in the 
project will be erased. 
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4.9.4  ShipWeight EasyImport 

The Data File Import dialog box (menu: Project > Import > Data File…) now 
has an extra layer called EasyImport which is designed to provide a wizard-like 
user interface to guide the user through setting up and carry out the import step 
by step of Excel files. 
The first step is to browse and select the spreadsheet file (the Data File import 
dialog box now supports import of XLSX files in addition to XLS files.). 
              

 
Once the Excel file has been selected, a preview of the sheets included in the 
file will be shown.  The next step is to select the sheet to import. 
When a sheet is selected, the Import dialog box will try to guess the mapping 
between the columns in the spreadsheet and ShipWeight fields, based on the 
column headings in the spreadsheet.  Columns where mapping have been 
found automatically will get a green color and the mapping will be shown in the 
list below.  If this mapping is wrong, you can deselect the column either in the 
sheet preview or in the list of linked columns. 
To manually add columns not automatically mapped, click on the column either 
in the preview sheet or in the column list and select the corresponding 
ShipWeight field from the ShipWeight list. 

Picture 5: Browse to find Excel file Picture: Select Sheet 



 

120 
 

While a green column indicates a mapped column, a white column indicates an 
unmapped column and a pink column is a selected but not yet mapped column. 
 
For items not found in the ShipWeight list, you click the New field button. A 
custom code will then be generated and a new window will pop up suggesting 
the same name for the item as in the spreadsheet, but if wanted the user can 
edit the name.  
 

 
 
If you click the More settings button, the dialog box will expand and give the 
user some options to define the settings for this parameter. For more details on 
these settings and how to edit them, see 4.11 The Code Definition dialog box. 
Note that there is no need to edit the code to make the import succeed, this can 
also be done after the import. 
 

  
 
Click OK and the “Section” column turns green and Section has been mapped 
within the Registered mappings.  
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If you chose not to map a column this will not be imported into ShipWeight. In 
the example above the data in the Area column will not be imported. 
 
An import can be run directly from this tab (either to main database or to 
Playground Area), or the mappings and settings can be transferred to the 
normal data file import for more advanced settings and checking. 
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4.9.5  The EasyImport dialog box 

If you want to do more advanced settings importing an Excel file or want to 
import a file in another format, from the Project menu, select Import and then 
Data File… to open the ShipWeight EasyImport dialog box. 
 
The ShipWeight EasyImport dialog box can import all kinds of text files (flat 
files, tab-, comma- and semicolon- delimited files) as well as Excel files and 
Access files. In addition, it can export weight items to Excel format (.XLS) or as 
a Comma Separated Textfile (.CSV). 
 

 
 
Importing 
First of all, make sure you have selected the Import source tab at the upper 
part of the dialog box. Choose file type to import: 
 
No delimiter (flat file) 
Tab delimiter 
Excel file 
Access file 
Custom delimiter 
 
 
If you have selected Access file, please enter the name of the table to use. 
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Click the Browse button next to Data file to import. Now the Open dialog box 
will pop up. Select the file to import and click OK. 
 

 
 
Next, select the Options tab. 
 
At the left side of the Options tab, there are three checkboxes. The Log 
imported items option is used to choose whether the import will be logged or 
not. Logging of weight items is necessary to be able to produce reports based 
on the Log database. 
 
There is an option Update items to allow overwriting of existing items. 
WARNING: ALL INFORMATION ON EXSITING ITEMS WILL BE DELETED 
WHEN ITEMS ARE REPLACED. 
 
If the Trim spaces option is checked, spaces in front of or behind of a value 
will be removed during the import. 
 
Next, you can define the number of header rows in the import file. For Excel 
files one header row is assumed. 
 
Make sure to set the proper units in the file, SI (metric) or US. Default units are 
SI. 
 
The Options tab also includes buttons for deleting and updating weight items. 
 
To delete old weight items, you can use the Clean Log and Clean DB buttons. 
The first will delete all weight items in the Log-database and the second will 
delete the weight items in the project database. 
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WARNING: ALL INFORMATION ON EXISTING ITEMS WILL BE DELETED 
FROM THE DATABASE. THIS ACTION CAN NOT BE UNDONE. 
 
In the Update functions frame, there is a button for updating calculated codes 
quickly after import. The Calculate all weights / Calculate all codes menu 
selection in the Items dialog box is currently using old (slow) methods for 
update – The Calculate all codes button in the new Flat File Import dialog 
box uses new and quick methods. 
 
The Pad ItemNo button will change the format of the item number of existing 
items. First set the number of characters the item number should include. 
Clicking the Pad ItemNo button will add the digit 0 in front of the item number 
so that the item number includes the proper number of characters. Example: 
 123    0000123 
 

 
 
To start a Flat File Import, you first need to define a ShipWeight Import (SWI) 
format – or load an already existing one. 
 
A defined SWI format contains a set of import rules, and each import rule tell 
what data from the flat file goes into a specific field in the database. 
 
To start a new import definition, click the New definition button. This will clear 
the dialog box of any previous definitions. 
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The definition of an import rule is done in the lower area of the window.  
 

 
 
In the Edit definition of selected line frame, the first two edit boxes are used 
to tell which character positions to be retrieved from the import file. Next, to 
specify which field in the database the information in this character field is going 
into, select from the dropdown list of the ComboBox. The ComboBox only spells 
the ID of the field since this title may change from project to project. In the field 
right to the ComboBox, however, you can read the title for this field as defined 
in the project the data will be imported to. 
 
Directly below this, there is a checkbox to tell if the value has decimals not 
separated by a dot. If so, there is also a spin box to indicate the number of 
decimals. 
 
To show or hide advanced settings for the data file, click the Advanced>>> 
button. The advanced settings are used to define is the indicator field. An 
indicator field means that we have a number followed by a character, i.e. 23.4A, 
where the character indicates if the value should be read in as negative or 
positive value. If there is no indicator field, you simply select ‘None’. Otherwise, 
you should select the direction and the character of the indicator field. The 
default indicators are: 
 
X-direction: F (fore) = Negative 
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A (aft)  = Positive 
 
Y-direction: S (starboard) = Negative 
P (portside) = Positive 
 
Z-direction: B (below) = Negative 
A (above) = Positive 
 
At the bottom of the Advanced settings area, you can specify a code e.g. [C01] 
to hold the value ‘S’ to indicate negative weights. 

 
 
When all the correct settings have been selected, click Add button to register 
the import rule. 
 
Any selected row in the definition can be delete by selecting the Delete button 
or edited by the Edit button. 
 
To change the order of the rows, select a row and click the Move up or Move 
down buttons. 
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When all necessary import rules have been defined, the definition can be saved 
by clicking the Save or Save as… buttons. 
An already saved definition can be retrieved by clicking Open definition…  
 
The import is executed by clicking the Start Import button. 
 
Exporting 
The ShipWeight Data File Import dialog box also supports exporting weight 
items.  Weight items can be exported to an Excel file (XLS, max. 1 048 576 
rows), Excel file (XLS, max. 65 536 rows), a Comma separated text file (CSV) 
or a Flat text file. 
 
Select the Export tab. Enter the path and filename of the file to be created. 
Choose format for the export file, XLS, CSV or Flat text file. 
 
To filter the data to be exported, check the Filter box. Next to the Filter box, you 
can add a filter string. The filter string follows the same syntax as the Filter 
dialog box in the Items dialog box. 
 
In example, to export weight information from all 100 weight groups, the filter 
syntax to enter is:  WgtGrp Like ‘1%’ 
 
Next, you must define a set of export rules; i.e. which columns to be exported. 
This is done in the same way as defining import rules when importing. 
 
The export is executed by clicking the Export button. 
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4.9.6   Checking Values during Data Import 

A value range may be specified for the import quantity to do runtime value 
checking during import. 
 

   
 
 
To specify a value range for a quantity, check Add limit checks for current 
line (circle 1).   As long as this is checked, all definition rows added or edited 
will as specified in the Minimum and Maximum fields (circle 2).  Added range 
values can be seen in the columns Minimum and Maximum in the definition 
list (circle 3). 
 
Prior to running the import Check limits (circle 4) must be checked to let know 
that range values are to be checked.  If a quantity is outside the given range, 
the import will halt and give information about of this value and quantity. 
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4.9.7   Test Import for Data File Import 

 
The Data File Import dialog box can perform a test of the SWI file and a test of 
the file to import.  This is done on the Log and Test tab of the Data File dialog 
box: 
 

 
 
On this tab you can test your SWI file for potential errors by clicking the Test 
SWI button.  This should inform of any mandatory fields missing and actions 
needed to be carried out in order to fix the SWI file. 
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4.9.7.1  Checking the import 
 
Clicking the Check Import button will perform a run-through of the import 
without actually writing any data to the project.  You may use the Check for 
duplicates checkbox to indicate whether or not the test should ignore or report 
duplicate weight items (items already existing in the project).   
 
The check will report any errors and/or duplicates detected in the import files 
and finally give a summary of the total weight and center of gravity for the items 
to be imported and separate the contributions from duplicates/non-duplicate 
items. 
This log may be marked and copied out for further investigation. 
 

 
 
In the same way you can check the DB integrity. 
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5 Additional databases/libraries in ShipWeight 

5.1.1 Equipment database 

The Equipment database dialog box is a library of equipment weights and 
other relevant information that can be maintained by the user.  The library is 
project independent, but a project can import weight data from (and export data 
to) the equipment database. 
For maintenance, the Equipment database dialog box is opened from the 
menu Database > Equipment… in ShipWeight main window. 
 

 
 
Maintaining the Equipment library: 
 
To add a new equipment item, type the equipment data in the information fields 
to the left and click the Add button. 
 
To edit an existing equipment item, select the item to be edited in the list to the 
right, change the data in the information fields to the left and click Edit to store 
the revised information. 
 
To delete an equipment item, select the item to be deleted in the list to the right 
and click the Delete button. 
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5.1.2 Import/export weight data between Equipment 
database and Items dialog box 

 
Prepare the Equipment database for import/ export to the Items dialog box. 
 
Depending of the definition of custom codes in the Items dialog box, the various 
information fields for equipment weights will belong to different custom codes 
for different settings.  Therefore the user is able to define the relationship 
between custom codes and equipment information fields in the Equipment 
import setting dialog box.  This window is opened from the Items dialog box 
menu: Setting > Equipment Import Setting… 
 
In the dialog box, ITEM codes are selected in the left list and the corresponding 
EQUIPMENT field is selected in the right field.  By clicking the Add button, the 
mapping is registered and listed in the mapping area below the selection lists.  
To delete a registered mapping, select the mapping in the mapping area and 
click Delete. 
 
A defined mapping can be 
shared between projects by 
using the Export and Import 
buttons in the dialog box. 
 
Import Equipment Weights 
 
To import an equipment weight 
from the Equipment dialog box 
to the Items dialog box, the 
following steps must be 
followed:  First select the item in 
Items dialog box to receive the 
equipment weight and 
equipment information as 
specified in the Equipment 
import setting dialog box.  
Next, from the Items dialog box 
menu, select Items > Import 
from Equipment Database…  
When the Equipment database 
pops up, select the equipment 
weight you would like to import 
by selecting it in the equipment 
list to the right.  To navigate in 
the equipment list, sort by 
clicking the list headers and use 
the scrollbar to scroll the list.  
Once the correct equipment is 
selected, click the OK button and the import will be executed. 
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Export Item Data into Equipment Database 
 
To employ the equipment database with a new weight from the Items dialog 
box, simple select the item you want to export from the Items dialog box and 
select Items > Import / Export > Export to Equipment … from the menu in 
the Items dialog box.  This will bring data from the item into the information 
fields of the Equipment dialog box according to the defined mapping.  
Additional information may be typed in.  Click Add in the Equipment dialog box 
to add the new information to the database. 
 

5.1.3 Addresses 

On the Addresses submenu under the Database menu in the main window, 
information on suppliers, owners, yards, designers and ShipWeight users can 
be stored.  
 
With the Add, Edit and Delete buttons this database can be customized to fit 
the user organization. 
 
The Print button can be used for printing the information. 
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5.1.4  Default coefficient library 

The Coefficient… library to be found on the Database menu is a very important 
database in ShipWeight. This database contains the default coefficients for all 
the weight groups in the hierarchy.  
 
By using the arrow buttons, you can navigate through the structure. Default 
coefficient for the different ship-types and methods can be specified in this 
dialog box.  
 
The default coefficient value will be shown in the estimation graph as a dotted 
line, and can be chosen automatically from the coefficient dialog box under 
estimation. 
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5.2 Changing the top weight group 
In the Main… found in the Weight group menu in the main window, the user 
can select the main group to work on. 
 

 
 
Usually the Lightship or Displacement will be the top weight group, but in some 
cases as when dividing the ship on several project, one project might only work 
on Machinery and other just on Equipment or Hull. Selecting the appropriate 
level in the Main… dialog box will reduce unnecessary clicking in the 
breakdown structure.  
 
Also selecting another top weight group than lightship/displacement will affect 
many other functions in the program, for example weight distribution. Selecting 
Hull as the top weight group, and viewing the weight distribution, will give a 
distribution only for the hull. 
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5.3 The Code Definition dialog box 
The purpose of the Code Definition dialog box is to define a set of codes and 
code-values which can be tagged to a weight item. It is possible to define up to 
99 different codes (C01-C99). 
 
The Code Definition dialog box can be accessed from the View menu in the 
main window, from the View menu of the Items dialog box or by clicking the 
Code Definition button in the Item setting dialog box.  
 
  

 
 
The layout of the Code Definition dialog box is analogous to the Item Setting 
dialog box: a tree-view at the left side, a table in the middle and four buttons at 
the right side. 
 
The tree may have one or more levels: 
 
Name of the codes 
Code values 
 
The table displays information of the level below the one selected in the tree. 
 

5.3.1 Create a new code 

Select the topmost level of the tree. In the table, select the last line. Click on the 
CodeType cell. Expand the dropdown list and choose one of the available 
codes (C01-C99). Press the TAB key to continue entering data: 
 
Title shown in the Items dialog box 
Description explanation of the code 
FieldSize maximum number of characters 
Calculate define a calculation rule for the code, e.g. [Weight]/1000*[LCG] 

or [Weight]*[C21].[Factor] 
Tab align text (left, right or center) 
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Format control the format of calculated fields, e.g. for a three decimal 
digit, type %.3f 

FieldType set how the code is presented in the Items dialog box, either: 
EditBox (default), ComboBox, ListBox, CheckBox or 
ReadOnly. 

 
 

5.3.2 Add a code value 

If the FieldType of a code is set to ComboBox or ListBox, code values should 
be defined. Select the code in the tree. The table will change to show the code 
values for this code. In the table, select the last row. Enter CodeID and 
Description of the code-value. 
 
Optionally you can enter minimum and maximum values for VCG, LCG and 
TCG. This may be applicable for area codes. You also can enter a Factor and 
UnitWeight for the code. 
 
Back in the Items dialog box, the dropdown list of the Code now includes the 
new code-value. 
 

5.3.3 Calculated codes 

The value of a code can either be input from the user or calculated. If a code is 
to be calculated, the calculation rule must be defined in the Calculate field in 
the Code Definition dialog box. 
 
When defining a calculation rule, you can use any numerical database field for 
a weight item. Please note that database field names must be written in 
brackets, e.g. the database field Weight must be written [Weight]. The following 
database fields can be included: 
 
[Weight] [VCG_min] [NoOff] 
[VCG] [VCG_max] [Factor] 
[LCG] [LCG_min] [Length] 
[TCG] [LCG_max] [Width] 
[C01] to [C99] [TCG_min] [UnitWeight] 
 [TCG_max]  

 
The database fields [NoOff], [Factor], [Length], [Width] and [UnitWeight] 
correspond to Quantity 1 to Quantity 5. These are defined in the Options dialog 
box. When including one of these quantities in a calculation formula, please 
refer to its default title: 
 
   Quantity 1  =  [NoOff] 
   Quantity 2  =  [Factor] 
   Quantity 3  =  [Length] 
   Quantity 4  =  [Width] 
   Quantity 5  =  [UnitWeight] 
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Codes [C01] to [C99] can only be used in the calculation formula if the values 
are numerical. 
 
Usually a code with field type ComboBox or ListBox has predefined code-
values. Each code value can hold information of VCG_min, VCG_max, 
LCG_min, LCG_max, TCG_min, TCG_max, Factor and UnitWeight. These 
fields can be included in a calculated code formula using the following syntax:  
 
[Code].[Field]  Example: [C03].[Factor] 
 
The calculation rule accepts the operators + (add), - (subtract), * (multiply) and 
/ (divide). 
 
The ABS() function is available for calculating the absolute value of a database 
field. Examples of usage: 
 
   ABS([TCG]) 
   ABS([WEIGHT]*[TCG]) 
  
An example of a commonly used calculated code is the Vertical Moment: 
 
Vmom = Weight * VCG      [Weight]*[VCG] 
 
Please refer to Chapter 5.3.6 Tutorial: Add custom codes and 5.3.7 Tutorial: 
Define calculated codes for more detailed examples. 
 

5.3.4   Default value for custom code 

You may set a default value for a custom code to be filled in when a new weight 
item is added in the Items dialog box.  The default value is set by typing 
=“<default value>” (including the equal sign and hyphens) in the Calculate field 
of the custom code in the Code Definition dialog box. 
 
 

5.3.5   Formatting codes 

You can use the Format field to set the output-format of code fields. The format 
specification consists of optional and required fields: 
 
%{Width}.{Precision}type 
 
Both the percent-sign and the type-field are required. 
 
type  Required. Determines how the argument is interpreted: 

d  Integer (lowercase) 
f  Decimal digit (lowercase) 
S  String (uppercase)  
Please note that the type field is case-sensitive. 
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width  Optional. Specifies the minimum number of characters output. If 
width is prefixed with 0, zeroes are added until the minimum width 
is reached. 

 
precision Optional. Specifies the number of characters printed or the 

number of decimal places, depending on the type: 
  type = d  Precision = minimum number of digits printed. 

If the number has less digits than given by precision, 
the number is preceded by zeros. 

  type = f   Precision = number of digits after the decimal point 
  type = S  Precision = maximum number of characters printed 
 
Examples: 
 
%05s String with at least 5 digits. Zeroes are added if less than 

minimum width: 123  00123 
%.3f  3 decimal digit: 123,456789  123.456 
%.5d  Integer with at least 5 digits: 123  00123 
 

5.3.6   Tutorial: Add custom codes 

In this tutorial we will make two codes: ‘Drawing Number’ and ‘Weight Status’ 
 
Start a new project and open the Items dialog box (click Items and then All 
Items). From this dialog box, click on Item Setting. 
 
When the Item Setting dialog box pops up, hit New Setting button to create a 
new setting. In the tree-view on the left side, click the plus-sign next to the 
asterisk to expand the tree. A setting named ‘New setting’ has been created. 
Your dialog box should then look like this: 
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By minimizing the tree view you will see the following dialog box 
 

 
 
Next, hit the Code definition… button. This opens up the Code Definition 
dialog box. 
  
In a new project, the Code Definition dialog box is empty. 
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Next, please select the cell in the column CodeType so it becomes activated 
and editable. A new row should then automatically be added, and the cell 
should turn into a ComboBox (dropdown list). 
 

 
 
Next, activate the dropdown list of the ComboBox and select the ID of the 
custom code you want to make i.e. C01. 
 

 
 
 
 
 
  
 
 



 

142 
 

Then, fill in the following fields: 
 
Field    Value     Description 
Title    Drawing no.   Title will show above field in Items dialog box. 
Description Drawing number Information only, no effect 
FieldSize  15       Number of characters allowed in field 
Calculate         Formula for calculated codes (Leave empty) 
Tab    Right      Alignment of value in Items dialog box. 
Format          Formatting of calculated fields (Leave empty) 
FieldType  EditBox     Specify a standard editable field 
 

 
 
You can make sure that the code has been registered by checking that it is 
added to the tree left of the grid. 
 
In the same way, add the code C02 with the following values: 
 
Field    Value      
Title    Weight Status 
Description Weight Status Code 
FieldSize  20 
Calculate  (leave empty) 
Tab    Left 
Format   (leave empty) 
FieldType  ListBox 
 
To finish off the registration of code C02, click with the mouse on the empty line 
in the table. 
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Next, we will add code values to the Weight Status code. In the tree-view, select 
code ‘C02 – Weight Status’. And empty table for adding code values will 
appear on the right side of the tree-view.  
 

 
 
Select the bottom row of the table and fill in these values: 
 
Field     Value      
CodeID    E 
Description  Estimated 
Factor    1.1 
 
Leave the rest of the fields empty, and click on the next row in the table. Enter 
two more code values: 
 
Field     Value      
CodeID    C 
Description  Calculated 
Factor    1.05 
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Field     Value      
CodeID    W 
Description  Weighed 
Factor    1.02 
 
Finish off registering the code value by clicking the last row in the table with the 
mouse. 
 
 

 
 
 
Click Close to close the dialog box and go back to the Item Setting dialog box.  
 
Back in the Item Setting dialog box; expand the Single view branch of the tree 
by clicking the plus sign. Then expand the Hidden group. The new codes have 
been added to the Hidden group. All new codes are by default added to the 
Hidden group and need to be moved from this group to the actual one. 
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We want to move the codes from the Hidden group to the Codes group. To 
move the code we use “drag & drop” in the tree-view. 
Click and hold the mouse-button on the code C01 so it is selected in the tree-
view. 
 
 
 
While you are holding the button down, drag the code by moving the mouse to 
the group Codes. Then release the mouse button. Now it should look like this: 
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In the same way, drag and drop code C02 from the Hidden group to the Codes 
group. To place the C02 code beneath C01, make sure to drop it on the C01 
code. 
 
Also, expand the Table view branch and move the codes C01 and C02 from 
Hidden to Codes. 
 
Next, select the group Codes in the tree-view. In the table you can set the width 
that the code will have in the Items dialog box. Set the width of C01 to 100. 
 

 
 
Click the Close button to go back to the Items dialog box. 
 
In the Items dialog box, select Load Setting from the Setting menu and select 
New setting. Click OK. 
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Then your new setting should load and you should be able to see your new 
custom Drawing No. code in the Items dialog box in the Codes group: 
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5.3.7   Tutorial: Define calculated codes 

In this tutorial we will define two calculated codes: ‘Vert. Mom.’ and ‘Weight with 
Margin’. This tutorial builds on Chapter 5.3.6 Tutorial: Add custom codes. 
 
Open the Items dialog box and load the setting New setting. 
 
Next, open the Code Definition dialog box by selecting Code Definition… on 
the View menu. 
 
Add code C03 with these values: 
 
Field    Value      
CodeType  C03 
Title    Vert. Mom. 
Description Vertical moment 
FieldSize  20 
Calculate  [Weight]*[VCG] 
Tab    Right 
Format   %.3f 
FieldType  ReadOnly 
 
 
Next, add code C04: 
 
Field    Value      
CodeType  C04 
Title    Weight with Margin 
Description Weight multiplied with margin based on Weight Status code 
FieldSize  20 
Calculate  [Weight]*[C02].[Factor] 
Tab    Right 
Format   %.3f 
FieldType  ReadOnly 
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Click the Close button. Back in the Items dialog box, select Items settings on 
the Settings menu. 
 
In the Item setting dialog box, expand the New setting, Single view branch 
and the Hidden group. Move the codes C03 and C04 from the Hidden group 
to the Codes group. Also, expand the Table view branch and move the codes 
C03 and C04 from Hidden to Codes. 
 
 

 
 
 
Close the Item setting dialog box. 
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Back in the Items dialog box; add a weight item with these values: 
 
Field          Value      
UnitWeight       1000 
VCG          10 
C02 – Weight Status    E 
 
 
Now, the calculated codes should be: 
 
Field          Value      
C03 – Vert. Mom.     10000 
C04 – Weight with Margin  1100 
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5.3.8   UnitWeight Function 

The Code Definition dialog box has a column for sub codes where a 
UnitWeight can be defined for a sub code. 
 

 
 
 
This value set in this UnitWeight column can be utilized for automatic setting of 
the UnitWeight quantity field in ShipWeight Items dialog box. 
To activate a custom code to automatically set UnitWeight based on selection 
of sub code, the custom code intended for this use must be set in the Options 
dialog box (menu View > Options…) in the Item tab. 
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Hence a sub code selected from the custom code in the Items dialog box will 
automatically fill in the UnitWeight quantity of the weight item. 
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5.4 Loading Conditions and Hydrostatics 
From the menu View > Load Conditions… a dialog box can be opened to 
handle loading conditions and hydrostatic values. This dialog box can be used 
for calculation of total weight and center of gravity for various loading conditions 
and calculation of hydrostatic values for loading conditions. 
The results can be printed through a canned report, and the results are stored 
in a table and can be used in a custom Crystal Report. 
 

 
 
The Load Conditions dialog box contains tables for input of values to define 
the loading conditions.  In the area 1 in the figure above, each row represent a 
loading condition.  To define a loading condition, add a line to this table and 
enter name of condition (LoadCase) and description.  The other fields in this 
table will be calculated as more information is given on the loads and 
hydrostatics. 
When a specific loading condition is selected in the Load Case table, the 
Weights table (area 2 in the figure above) can be used to define the loads for 
this condition.  Each line in the loading condition represents a single load for 
the selected Load Case and may be of the type Tank, Load or Weight Group. 
The Hydrostatic Calculations list (area 3 in figure above) gives a summary of 
the results of the loading calculations.  For the hydrostatic results to be 
calculated, the Hydrostatics button must be clicked for input of hydrostatic 
values. 
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5.4.1 To Input Values and Import Values 

Values in all tables in the loading condition and hydrostatic task may be added 
manually, but input can also be done by importing the values from tab delimited 
text files.  To input data from text files, right-click the appropriate table and 
select Import Text File…  The text files must have columns similar to the 
columns of the table you are about to import to and for importing to the Weights 
area (importing loads), the text file needs to have an additional first column with 
Load Case to know which Load Case to connect the loads to. 

5.4.2  Setting the Load Type 

 

 
 
In the Weight area in the Load Conditions dialog box you may select between 
load types WgtGrp, Tank or Load.   
A WgtGrp load type gives you the opportunity to refer to any weight group in 
ShipWeight and get the weight and center of gravity from here.  This may be 
the Lightship, a deadweight group or any other SWBS in ShipWeight.  The 
weight group you want to refer to is written in the Source column of the Weights 
table.  See marks 1 and 2 in the figure above.  When assigning a WgtGrp load 
it is important an update it needed to initialize the value.  This is done by right-
clicking the table and selecting Update item(s) from the submenu. 
A Tank load type represents a tank that can be defined with content and 
sounding table.   
A Load type is a defined static mass load to be included in the loading condition. 
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The picture above shows the input tables for hydrostatic properties, tank 
definitions and sounding tables, both dialog boxes are shown by clicking the 
corresponding buttons in the Load Conditions dialog box. 
 
 
 

|  
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5.5 3D Plot of Weights 
A 3D plot of the weights where items are plotted as cubes according to their 
given extension and their position according to their center of gravity can be 
obtained from starting the 3D view dialog box to be found on the menu View > 
3D Plot… 
 

 
 
Custom colors can be set for weight groups to color items by their weight group.  
These colors can be set by selecting menu View Setting > Settings… in the 
dialog box.  This brings up the 3D Settings dialog box where you can pick a 
weight group in the work breakdown structure and set color from the submenu 
(right-click the WBS) by selecting Set Color or Color all subgroups.  In the 
same dialog box you may also change the background color. 
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This dialog box has also filter options, for weight groups and the general item 
filter, similar to filters in Items dialog box, Weight Distribution dialog box and 
Gyration dialog box. 
 
When the weight items are plotted, the user can zoom and rotate the model 
interactively by using the mouse in the plot area.  Standard projection settings 
can also be found on the menu and on buttons in the dialog box. 
 

 
 
 

 
 



 

158 
 

6 Administration 

6.1 The Options dialog box 

The Options dialog box is found on the View menu. It includes ten tabs: 
 
General 
Decimals 
Quantity 
Database 
Log 
Report 
Item 
Estimation 
Workset 
Playground 
 
All users will by default inherit settings in the Options dialog box made by the 
sysadmin user. Special settings can still be set per user if necessary. 
 
Settings in the Options dialog box can be imported from other projects by 
clicking the Import button and select the database and project from where you 
want to import settings.  The settings from the project you select to import from 
will overwrite the existing settings of the current project. 
 

6.1.1 General 
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The General tab includes these options: 
 
Units: Switch between Metric and US units. 
Weight Unit:                       Select the appropriate weight unit. 
Autosave every:  Set the time period between AutoSave. 
Summarize at startup:  Set whether weight-groups should be summarized 

at the start of a new session or not. 
Use default CoG:  (not in use) 
Adm.perm. for Freeze:  set if the user needs administrator privileges to use 

the option Freeze wgt.grp. over on the Estimate 
menu. 

Extent:  ‘default’ is the default extension used for a weight 
item if any of the values VCG_min, VCG_max, 
LCG_min, LCG_max, TCG_min, or TCG_max are 
missing. 
‘min.’ is the minimum allowable extension for a 
weight item. The min value will be used if the given 
extension of a weight item is less than the minimum 
value. 

Autosum Codes 
Only Item Top Rows 
Open Info Windows on New Project 
Weight Field 
Autosum Weight Groups 
Thousand separator 

6.1.2  Decimals 

 
 
 
This tab is used to set the number of decimals for Weight, VCG, LCG, TCG, 
VCG_min, VCG_max, LCG_min, LCG_max, TCG_min or TCG_max. 
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Wgt.grp. Control the number of decimals in the main window of ShipWeight 
Items  Set the number of decimals in the Items dialog box. 
 
The labels for center of gravity position (VCG, LCG and TCG) may be renamed.  
This will affect the label for center of gravity in the main window, the Items 
dialog box, and standard (embedded) reports. 

6.1.3  Quantity 

 
 
The Quantity options define the five quantities. 
 
Quantity unit: Dropdown list for selecting a unit. The available units will vary 

depending on the type of units selected in the General tab. 
(Metric or US units). 

Qty title: Set the name of the quantity. 
No. dec.: Control the number of decimals shown. 
Default 
Merge 
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6.1.4   Database 

 
 
 
Path historical database: It is important to notice the Path historical database, 
which gives the file containing your past ship data. When estimating or 
exporting a project to the historical database, always make sure that you are 
working towards the right historical database. 
Project database prefix: Set a prefix for the database names. 
Log DB 
Connection Timeout 
Record Buffer 
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6.1.5   Log 

 
 
Controls which code fields to display in the Log dialog box. Use the dropdown 
list to select from the existing codes. 
 
Now the selected codes will be available in the Log dialog box for commenting. 
See Chapter 2.9 Log activities and results. 
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6.1.6   Report 

 
 
The Report options controls the appearance of the Standard reports. 
 
Line distance:   Controls the spacing between the lines. 
Header font size:  Set the font size of the header. 
Report font size: Set the font size of the report. 
Summarize calc. fields in Item report 
Report logo: browse and select logo report  
Print SW logo: select to print or not the ShipWeight logo 
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6.1.7   Item 

 
 
Read-only Weight field in Items dialog box: If this selection is checked, the 
weight field/column in the Items dialog box will be locked for editing. At the right 
side of this checkbox you can set the number of decimals for weight and CoG 
shown in the Items dialog box 
Row-lock in Items dialog box: Activates the row-lock. This prevents two users 
to edit the same item simultaneously. 
Row-lock timeout: Set the maximum time an item can be locked. 
Include codes in blank Item setting: Control whether all codes should be 
included when a blank Item setting is selected. 
ItemNo format: Define the format of the item number fields, e.g. ‘%05s’ for 
‘00001’. 
Allow local coordinates: Enables the user to activate local coordinate systems 
in the Items dialog box. 
Check CoG: activate automatic check of sanity between CoG and given 
extension. 
Auto CoG: enable automatic definition of CoG and extensions for weight items 
based on code values. 
Copy/paste log: enable logging of copy/paste operations from the Items dialog 
box. The log-data is stored in a code-field. 
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6.1.8   Estimation 

 
 
For the Workset and Playground option this is described in Chapter 2.7 
Playground Area and Worksets.  
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6.2 The SWLogin-dialog box – managing 
permissions 

 
The Permissions dialog box is used to manage user-groups and user-
accounts. 
 
Permissions are assigned to user-groups. All users are assigned to a user-
group and thus inherit the permission from the group. Any number of user-
groups can be defined and permissions are set custom for each user-group. 
Any number of users can be assigned to a single user-group. 
 
The only default user-group is the sysadmin group. At least one user must be 
assigned as a sysadmin user. Only the users of the sysadmin group are allowed 
to access the Permissions dialog box. 
 
From the Project menu, select Permissions > Administration… to open the 
Permissions dialog box. 
 
The Permissions dialog box is divided into three tabs: Users, Groups and 
Password Policy. 
 

6.2.1  The Users tab 

 
 
The Users tab contains a list-view where the users are listed with username, 
full name and description. 
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There are four command buttons: 
 
New User       add a new user 
Remove      delete the selected user definition 
Properties      view and edit the user definition 
Change Password   set password 
 
The buttons New User and Properties will open a dialog box displaying the 
properties of the current user. See Chapter 6.2.4 The Create New User dialog 
box. Clicking the Change Password button will open a dialog box for setting 
the password. 
 

6.2.2   The Groups tab 

 
 
The Groups tab lists the name and description of all available User-groups. In 
addition, there are three command buttons: 
 
Add      add a new user group 
Remove    delete the selected user-group  
Properties    view and edit the properties of a user-group 
 
Clicking either the Add or the Properties button will open a dialog box showing 
the properties of the User Group. See Chapter 6.2.6 The New User Group 
dialog box. 
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6.2.3   The Password Policy tab 

 
 
The Password Policy tab is used to set accepted password properties. The 
system will only approve setting password according to these properties. 
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6.2.4   The Create New User dialog box 

 
 
The Create new user dialog box opens when clicking either the New User or 
the Properties button on the Users tab.  
 
The User name and User group fields are mandatory. The fields Full name, 
Description, Department and E-mail are optional. 
 
At the lower half of the dialog box, there are five check-boxes: 
 
User must change password at next logon 
User cannot change password 
Password never expires 
Account is disabled 
Account is locked out 
 
The latter two are disabled when creating a new user, but will be available when 
viewing the user properties. 
 
When you have finished entering user information, click the Ok button to create 
the user. The Change Password dialog box will appear. 
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6.2.5   Change your password in ShipWeight 

From the ShipWeight main window menu Project > Permission > Change 
Password… you can open a dialog box that allows you to change your 
ShipWeight password at any time. 
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6.2.6   The New User Group dialog box 

The User Group dialog box opens when clicking Add or Properties button 
from the Groups tab. The dialog box is divided into three tabs: Members, 
Permissions and Weight groups. 
 
The Members tab 
 

 
 
The Members tab contains two input-fields: Group ID and Description. The 
Group ID field is the only mandatory field. Description is optional. 
 
Below the input-fields, there is a list of the members belonging to the group, 
showing User Name and Full Name. 
 
In addition there are two buttons: 
 
Add      add a user to the current user group 
Remove    remove a user from the current user group 
 
Clicking the Add button opens the Add User to Group dialog box.  
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Back in the User Group dialog box, the user has been added to the Members 
list: 
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The Permissions tab 
 

 
 
 
The Permissions tab in the New User Group dialog box, contains a tree-view. 
The tree-view is used to limit the actions of the current user group. 
 
Clicking a box in the tree will check or uncheck an element or a branch. Double-
clicking an element on the first or second level of the tree, will expand or 
collapse a branch. 
 
The topmost level in the tree is Full control. If you tick off this box, all the boxes 
below will be ticked off as well, giving the user group maximum control of 
ShipWeight. 
 
The second level of the tree-structure divides ShipWeight into four main areas: 
 
WgtInfo  Items dialog box, Code Wgt.&CoG dialog box 

This represents the permission that implies everything from 
weight items and weight information following the weight 
item. 
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ProjectInfo  This is the permission for project information and project 
Parameters, basically it is the information entered in the 
Project and Parameter dialog box. 

 
Project Info dialog box, Main Ship Parameters dialog box, 
Parameters dialog box, Methods dialog box 

 
Setting  Is the permission for the Code Definitions, Item Setting 

and Options dialog box. 
 
Estimate Is the permission for the Estimation dialog box (graph), 

Auto Estimation dialog box 
 
Playground It is similar to the WgtInfo permission, but implies the 

Playground Area 
 
For each of these areas you can control the following actions: 
 
Read 
Edit                        Changing one Item at the time 
MultipleEdit            Permission to make a change to several items at once 
Output 
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The Weight groups tab 
 
 

 
 
The Weight groups tab shows a tree-view of the work-breakdown structure. A 
branch can be expanded or collapsed by double-clicking it with the mouse. 
 
Checking the boxes in the tree-view will restrict the users of the current group 
to only operate within certain parts of the work breakdown structure. 
 
 

Important! 
Changes made on the Permissions and Weight groups tabs will be valid for 
the current project only! This enables the administrator to set different user 
group permissions for each project.  
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6.2.7   Permission Settings per Custom Code 

The Codes tab in the permission settings dialog box allows for ShipWeight 
administrators to specify access to custom codes on a single code level by 
checking boxes to the left of the code ID to grant access.  By default, all codes 
are checked and thus access granted. 
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6.3 The Project Settings dialog box 

 
 
From the Project menu, select Settings… to access the Project Settings 
dialog box. 
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6.4 The Item setting dialog box 
The Item setting dialog box is used to administrate the layout of the Items 
dialog box, both Single view and Table view. 
 
Mainly, the Item setting dialog box is used to select and group the data which 
is displayed in the Single view and Table view of the Items dialog box. It is 
also possible to specify color codes for groups. This makes it easy to recognize 
the groups and see the relation between the Single view and Table view. 
 
The Item setting dialog box is opened by clicking the Item settings… button 

 in the Items dialog box. Alternatively, select Item settings… on the Setting 
menu.  
 
The dialog box consists of a tree-view at the left, a table-view in the middle and 
five buttons at the right. 
 

 
 
The tree has four levels: 
 
Name of the setting 
Single view or Table view 
Groups 
Fields 
 
The table displays information of the level below the one selected in the tree. 
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The seven buttons at the right side of the dialog box have the following 
functions: 
 
New setting – to start a new item setting 
Delete setting – to delete an existing item setting 
Code definition – open the code definition setting for these item setting 
Import SW 
Import ASCII 
Export ASCII 
Close 
 

6.4.1   Using the Item Setting dialog box 

Create a new dialog box setting 
There are two ways to create a custom dialog box-setting: 
 
Save the current dialog box setting: In the Items dialog box, click the Save 
setting as… button on the toolbar. Enter a name of the new setting, e.g. ‘New 
Setting’, and click OK. Next, open the Item setting dialog box. The saved 
setting will show in the tree. 
Create new: Click the New button in the Item setting dialog box. 
 

 
 
Browse the tree 
Now you can browse the setting. Click the ‘+’-sign at the left of e.g. ‘New Setting’ 
to expand the tree. To work with the Single view settings, click the ‘+’-sign at 
the left of Single view. Now the groups in Single view will show.  
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Add a new group 
To add a new group, select Single view in the tree. Now the groups of the 
Single view will show in the table. Select the last line of the table, and click the 
GroupID cell. Type in the group id, e.g. DrawingRef. Press the TAB key to 
move to the next column. Enter a Title, e.g. Drawing References, and 
description. 
 

 
 
To set the color of group, go to the color column and enter a color code. The 
color code is on the form xxx,xxx,xxx , where xxx is an number from 0 to 255. 
The first number is the amount of red, the second green and the third blue.  
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For instance: 255,0,0 is red, 0,0,255 is blue, 0,0,0 is black and 255,255,255 is 
white. 
 
To create a group in the Table view, select Table view in the tree and repeat 
the same procedure.  
 
Move fields 
Fields can be moved between the groups by dragging and dropping the fields 
in the tree. Expand the desired group in the tree, e.g. Codes. Click and hold 
one of the codes, e.g. C01 with the left mouse-button. Drag the code to the 
desired group, e.g. Drawing References, and release the button. 
 

 
 
The order of the fields within a group is controlled in the same way, by dragging 
and dropping the fields in the tree. 
 
Hide fields 
Codes can be hidden by dragging and dropping them into the Hidden group. 
E.g. drag and drop the field C02 from the group Codes to Hidden. 
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Load a custom dialog box-setting (Items dialog box) 
To see the result, go back to the Items dialog box. Select Load Settings (either 
the button on the toolbar or the selection on the Setting menu), marked 1. Now 
the Open Item Setting dialog box will appear. Select the custom setting, in this 
case New Setting, and click OK. 
 
Alternatively, you can select the dialog box setting to be used directly from the 
Dialog box Setting dropdown list on the toolbar, marked 2. 
 

 
 
Now the new Items dialog box setting is active. In the Single view the group 
Drawing References has been added. The code (field) C01 has been moved 
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from the group Codes to Drawing References in Single view. The field C02 
has been hidden. 
 

6.4.2  Import settings 

Dialog box settings can be imported from other projects. Click the Import 
settings button to open the Import item settings dialog box. 
 
To select a SQL Server project to import from, click the Browse button in the 
Source frame. If there are Item settings defined in the selected project, these 
will appear in the list at the bottom of the dialog box. 
 
Next, specify a prefix or extension to the setting ID. This is optional. Select the 
Overwrite option if there already exists settings with the same id as those you 
are to import. 
 
In the list, select the settings to import. Finally, click the Import button. 
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6.5 Database administration 

6.5.1   Delete project / database 

ShipWeight Administrators can remove a project from a database or remove an 
entire database directly from within ShipWeight. 
 
To delete a project from a database, select Project > Delete > Delete Project 
from the menu bar. The Delete Project dialog box will appear. Select the proper 
database and then the Project ID of the project to be removed. When clicking 
OK, a warning will appear. Click Yes to confirm that you want to delete the 
project permanently. 
 

 
 
 

 
 
To delete a complete database, including all projects on the database, select 
Project > Delete > Delete Database from the menu bar. In the Delete Project 
dialog box, select the database to be deleted and click OK. You will need to 
confirm that you want to permanently delete the database. 
 
WARNING: WHEN DELETING A PROJECT OR DATABASE, THE DATA IN 
THE PROJECT/DATABASE WILL BE PERMANENTLY REMOVED. IT IS NOT 
POSSIBLE TO RECOVER DATA FROM A DELETED PROJECT/DATABASE 
OR TO UNDO THE CHANGES. 
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6.5.2   Execute SQL commands on database 

 
From the SQL dialog box, administrator users can execute SQL commands on 
the databases directly from ShipWeight. To open the SQL dialog box, select 
Database > Query > Project Database. SQL commands can be executed 
either on the historical database or the current project database. 
 
WARNING: INCORRECT USE OF SQL COMMANDS ON THE DATABASES 
MAY DESTROY THE DATABASES, CAUSE LOSS OF DATA OR PREVENT 
SHIPWEIGHT FROM FUNCTIONING PROPERLY. GREAT CARE SHOULD 
BE TAKEN WHEN EXECUTING SQL COMMANDS ON THE DATABASE. 
EXECUTING SQL COMMANDS ON THE DATABASE SHOULD ONLY BE 
CARRIED OUT BY PERSONS EXPERIENCED IN THE USE OF SQL 
COMMANDS AND WITH THE PROPER KNOWLEDGE OF THE 
SHIPWEIGHT DATABASES. IT IS RECOMMENDED THAT A COMPLETE 
BACKUP OF THE DATABASES IS MADE PRIOR TO EXECUTING ANY SQL 
COMMANDS ON THE DATABASES. 
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6.5.3   Project and Log Database Table View 

 
A ShipWeight sysadmin can access Project or Log database through a GUI 
where each table in the project database is shown complete with all columns.  
These functions are located on the menu in ShipWeight main window Database 
> Administrator > Project Database/Project Log Database.   
 

 
 
In the database window, there is one tab per table and all tables are shown with 
all columns and rows.  Cells are editable in this view and a small edit box at the 
bottom of the window allows for simple filter settings (i.e. WgtGrp like ‘111’) to 
retrieve subsets of the data. 
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6.6 Changing the SQL Server in ShipWeight 
 
By selecting the menu item Project > Change Server… from ShipWeight’s 
main window, a popup dialog box showing all available SQL Servers on the 
network will allow for changing the SQL Server instance.  ShipWeight 
databases must be installed on any SQL instance selected for ShipWeight to 
work properly on the SQL instance.  ShipWeight must be restarted for the 
change to take effect. 
 

 
 
Alternatively, the SQL Server instance may be changed by entering Windows 
Register directly and modify the ServerName string in 
HKEY_LOCAL_MACHINE\SOFTWARE\BAS 
engineering\ShipWeight\7.0\Database. 
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6.7 Edit Weight Groups in the main Work 
Breakdown System 

 
The main Work Breakdown System (WBS), such as the ESWBS and 
ShipWeight WBS, should ideally never be edited as these systems should lay 
firm to preserve consistency between weight groups in historical data.  This is 
especially important when utilizing the parametric estimation in ShipWeight.  It 
is crucial to the reliability of the parametric estimation that historical data in 
weight groups are comparable and on a “one-to-one” relationship in terms of 
definition. 
 
Still, there may be occasions when editing and/or expansion of the WBS is 
needed.  For this, the Edit Weight Groups dialog box has been made.  It is 
opened from the ShipWeight main window menu Database > Administrator > 
Wgt.grp. Definition… 
 

 

6.7.1   Navigating in the WBS 

 
The WBS is structured in the explorer tree to the left in the Edit Weight Groups 
window and you may navigate through the WBS by expanding and collapsing 
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the tree nodes.  Clicking on a tree node will bring up this weight group in the 
grid to the right. 

 

6.7.2   Understanding the grid columns 

The grid list contains 3 columns: sPostID, sPostName, sPostOver. 
 

 sPostID represents the WBS id of the weight group 

 sPostName represents the name of the weight group 

 sPostOver represents the id of the parent WBS.  The WBS is 
located as a child node in the hierarchy to this weight group 

 sSort represents the order in which the weight group is sorted 

 sIcon represents the icon for the weight group 
 

6.7.3   Changing Sort Order and Icons in the WBS 

Sort order and Icons in the main work breakdown structure can be set.  The 
columns sSort and sIcon can be used to override the normal sorting.  In the 
example below, 3 subgroups can be sorted by typing 1, 2, 3 in the sSort column 
to specify the order for these.  Further you can use numbers 0 through 6 to 
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specify icon type in the sIcon column.  See the sample picture below where 
order has been rearranged for group A1-A3 and new icons have been given. 
You must restart ShipWeight for the changes to take effect. 

The numbers and corresponding icons are: 
0. No icon 

1. Equipment icon 

2. Deadweight icon 

3. Hull icon 

4. Machinery icon 

5. Remainder icon 

6. Vessel icon 

6.7.4   Changing a weight group 

 

 To edit a weight group  
Navigate and select the weight group you want to edit in the grid 
list.  Click twice in the grid containing the information in the 
weight group you want to edit.  The grid will then turn into edit 
mode and you can make the changes. Press the ENTER key to 
confirm. 

 

 To delete a weight group 
Navigate and select the weight group you want to delete in the 
grid list.  Use the mouse to right-click the weight group in the grid 
list and select Delete from the submenu.  Confirm by clicking 
Yes in the confirmation pop-up window. 

 

 To add a new weight group 
Use the scrollbar to the far right in the dialog box to scroll to the 
end of the grid list.  At the end there is an empty row.  Click twice 
in the grid to enter in the details for the new weight group.  All 
three columns must be filled in. Press the ENTER key to 
confirm.  (A new empty row will appear at the end of the list once 
a new weight group is registered.) 

 

Picture: Change order and Icons of WBS 
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 To copy a weight group 
Navigate and select the weight group you want to copy in the 
grid list.  Use the mouse to right-click the weight group in the grid 
list and select Copy from the submenu. 

 

 To paste a weight group 
Navigate and select the weight group you want to paste in the 
grid list.  Use the mouse to right-click the weight group in the grid 
list and select Paste from the submenu. 

 
Close the dialog box and restart ShipWeight for the changes to take effect. 
 
 

6.8 Backup and Restore Projects from within 
ShipWeight Executable 

 
Given backup permission for the windows user on the SQL Server you may 
backup and restore ShipWeight databases to a folder of choice from within 
ShipWeight.  Open the Backup Database dialog box from ShipWeight main 
window menu Project > Backup…  
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 To backup a ShipWeight database 

Select the database(s) you want to backup in the Database list.  Next, 

select the folder where you want to store the backup files by clicking 

the Browse button […] next to the Path field.  Click the button Backup 

database(s) to create the backup files.  The backup file will show in the 

Backup list at the bottom of the dialog box.  The date and time of the 

backup creation will be stored in the file name. 

 

 To restore a backed up database 

Select the file(s) corresponding to the database you want to restore the 

backup from in the Backup list.  Click Restore backup(s) button. 

 

6.9 Exchanging ShipWeight Projects (Import/Export 
complete projects) 

ShipWeight can export and import complete projects through a project text file 
(dump file).  A typical use of this is for transferring projects between physically 
separated networks. 
 

 
 
The function is found in the menu Project > Export > Project (text file)… and 
opens up a dialog box for saving (export) the dump files. 
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7 Hints and tricks 

7.1 Show Frames 

A useful feature in ShipWeight is to view and edit longitudinal measurements 
relative to the frame-system. To activate this, from the Weight Groups menu, 
click Show Frames or click the equivalent button on the toolbar (marked with a 
circle in the figure below). The # -symbol is used to indicate frame-number, e.g. 
frame number 39.39 will be written #39.39. 
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7.2 Convert to item / Convert to weight group sum 
After estimating the weight, VCG or LCG of a weight-group, it is possible to 
convert the result of the estimate to an item. The advantage of this is the 
possibility of tagging items to a user-defined report. See Chapter 4.6 for 
information about user-defined reports. 
 
To convert an estimate to an item, from the Weight Groups menu, select 
Convert to Item. The Items dialog box will pop up. 
 
To convert all the estimates belonging to a weight group to items in one 
operation, simply highlight the weight group of interest and from the Weight 
Groups menu select Convert All to Items. 
 
Likewise, a weight group made up by items may be converted to a weight group 
sum from the Weight Groups menu by selecting Convert to wgt. grp. sum. 
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7.3 Calculating parameters 
A dialog box for calculating area- and volume-parameters needed for estimation 
is available in the Auto Estimation and the Define Methods dialog box. The 
intention is to give a reasonable estimate of unknown parameters. 
 
The following example will show how this feature can be used. 
 
We want to estimate the weight of H3 Superstructure. Open the Estimation 
dialog box. Notice that the parameter Volume Superstructure is empty. This 
parameter is needed to do an estimate of the weight. To calculate this 
parameter, type ‘calc’ in the Value field. 
 

 
 
 
 
The Composite Parameter dialog box pops up. By filling in the length, height 
and breadth, the volume is calculated. Now it is possible to continue the weight 
estimation. 
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This dialog box can also be accessed from the Methods dialog box. 
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7.4 Fix item weight group coding 
The function Fix Item Wgt.Grp Coding is found on the Items menu. This 
function moves items with incorrect weight group code to the Remainder weight 
group. Parameter values may be lost in the process. 
 
It may be useful to run this function after importing items from a spreadsheet. 
 

 
 



 

198 
 

7.5 Using the secondary coordinate system 
By entering data for Coord.ref.point and Coord.ref.dir in the Project Info dialog 
box, a secondary coordinate system may be defined. The Coord.ref.point X, Y 
and Z values define the origin of the alternative coordinate system. The positive 
direction of the axes is set by Coord.ref.dir. 
 

 
 
 
To turn on the secondary coordinate system, select Show Reference CoG on 
the Weight Groups menu or click the equivalent button on the toolbar. While 
the reference CoG is active, the CoG values in the grid will turn red. 
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200 
 

7.6 Company logo in reports 
It is possible to add your company logo to all reports created in ShipWeight. 
Simply create a bitmap of your logo with the name COMPANY.BMP and store 
it in the same folder as the ShipWeight.exe is located (usually C:\Program 
Files\ShipWeight) 
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8 Introduction to the databases 

 
The following is a short explanation of the databases used by ShipWeight (SQL-
version). The purpose is to show where to find information on weight and main 
parameters of a ShipWeight project. A basic knowledge of the databases is 
necessary e.g. for using Crystal Reports to create custom ShipWeight reports. 
 

8.1 Overview of the databases 

 
Basically, ShipWeight needs three SQL-databases to run: 
 
SW00_ProjectName: For storage of project specific information, e.g. weight, 
CoG and defined parameters. 
 
The name of the database is made up of a prefix and the Project name. 
 
The prefix is used to determine which Work Breakdown Structure the project 
belongs to. 
 
 

Prefix Work Breakdown Structure 

SW00_ ShipWeight 

SW01_ RigWeight 

SW02_ PBSWeight 

SW03_ MaradWeight 

SW04_ SWBSWeight 

SW05_ IMPWeight 

SW06_ ESWBS_Carrier 

SW07_ BSCI_Carrier 

SW08_ ESWBS_Submarine 

SW09_ ESWBS_Submarine_2 

SW10_ BSCI_Submarine 

 
 
wdb_WeightDB: Contains general information used by all projects, e.g. 
information of the work breakdown structure, estimation methods, definition of 
parameters. 
 
The database containing the standard ShipWeight work breakdown structure is 
named wdb_WeightDB. Following is a list of the database names of the 
available Work Breakdown Structures: 
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Database Name Work Breakdown Structure 

wdb_WeightDB ShipWeight 

wdb_NGNNC1 ESWBS_Carrier 

wdb_NGNNC2  BSCI_Carrier 

wdb_NGNNS1 ESWBS_Submarine 

wdb_NGNNS2 ESWBS_Submarine_2 

wdb_NGNNS3 BSCI_Submarine 

 
 
sdb_ShipDB: This is the historical database containing information exported 
from completed projects. The historical database is used for estimation. This 
database will not be explained. 
 
 
  

8.2 About the SW0x_Project database 

Important! 
A project database can hold any number of projects. Each project is uniquely 
identified by a ProjectID. The ProjectID is found in every table of the Project 
database. 
 
Project Info 
The information found in the Project Info dialog box of ShipWeight can be 
found in the SHIP-table. This includes Name, Owner, Main type, Sub type, Build 
year, Frame spacing etc. 
 
 
Weight, Center of Gravity and Extension 
Information of Weight, Center of Gravity and Extension for each weight item 
can be found in the ITEMS-table. 
 
The ITEMS-table contains 123 columns/fields. These are: 
 
WgtGrp The name of the weight-group the weight-item belongs to. 
ItemNo  An id-number for the weight-item (unique within the weight 

group). 
Description Name of the weight-item. 
RegUser  Name of the user who created the weight-item. 
RegDate  Date of registration. 
NoOff  Quantity #1 
Factor  Quantity #2 
Length  Quantity #3 
Width  Quantity #4 
UnitWeight Quantity #5  
VCG  Vertical center of gravity 
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LCG  Longitudinal center of gravity 
TCG  Transversal center of gravity 
VCG_min  Minimum vertical extension 
VCG_max  Maximum vertical extension 
LCG_min  Minimum longitudinal extension 
LCG_max  Maximum longitudinal extension 
TCG_min  Minimum transversal extension 
TCG_max  Maximum transversal extension 
C01-C99  Code-field number 01-99 
EditUser  Used for Row-lock in the Items dialog box 
EditDate  Used for Row-lock in the Items dialog box 
UniqueNo  An integer to uniquely identify each weight item. The UniqueNo 

field is automatically assigned. 
 
 
The total weight and CoG for each weight-group is available in the SHIP_POST-
table. The SHIP_POST-table contains five fields. The three most important are: 
 
ProjectID ID to uniquely identify each project in the database. 
sPostID  The name of the weight-group, e.g. LW 
sType Type of information. A = Aft, F = Fore, L = LCG, V = VCG, T = 

TCG, W = Weight, P=port side (TCG_min), S=starboard 
(TCG_max), B=bottom (VCG_min), U=up (VCG_max) 

fValue Value. Records of type V, L, T, P, S, A, F, B and U are given in 
meters, while records of type W is given in tons. 

 
 
Parameters 
Various parameters, such as lengths, areas, volumes etc. can be found in three 
tables: SHIP_FATT (float parameters), SHIP_IATT (integer parameters) and 
SHIP_TATT (text parameters). 
 
The SHIP_FATT-table includes two columns/fields: 
 
ProjectID  ID to uniquely identify each project in the database. 
sFAttID   ID of the parameter 
fFAttValue  Value of the parameter. 
 
Likewise the SHIP_IATT and SHIP_TATT include a field for ID and a field for 
value. 
 
The full name of the parameter can be found in the WeightDB database (see 
next page). 
 
The parameters found in the Main ship parameters dialog box are: 
 
lm   Ship length over all 
lPE  Length betw. perp. 
bm  Ship breadth 
hDU  Depth upperm. cont. deck 
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hDM  Depth to maindeck 
dCW  Draught, CWL 
dm  Scantling draught 
wDP  Displacement 
nPA  Numb. passengers 
nCR  Numb. crew 
nCS  Numb. cars 
nCO  Numb. containers 
vGO  Gross tonnage 
vNT  Net tonnage 
wDW Deadweight 
eME  Main-engine power 
nME  Numb. main engines 
iME  Rot. speed main-engine 
om  Service-speed 
dPR  Propeller diameter 
zmMA Main-hull material 
zlC  Ice-class 
kmCB Block-coefficient 
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8.3 About the wdb_WeightDB database 
 
Work breakdown structure 
The ShipWeight work breakdown structure is defined in the POST-table. The 
post table contains three fields: 
 
sPostID    ID of the weight-group, e.g. H1.1 
sPostName  Name of the weight group, e.g. Afterbody 
sPostOver   ID of the parent weight-group, e.g. H1 
 
 
Parameters 
The parameters available in ShipWeight are found in the tables FATT (float), 
IATT (integer) and TATT (text). The FATT-table contains the following fields: 
 
sFattId   ID of parameter 
sFAttName Name of parameter 
sUnit    Unit 
sFAttSymb  
fFASIFak  Factor 
fMax    Maximum allowed value 
iDecimals  Number of decimals 
 
The parameter-ID consists of two to four characters and is subject to strict 
naming rules. The syntax of the ID is: 
 
{unit}{area}{object} 
 
The first character in the id, the “unit”, is always small letter. It tells what type of 
parameter this is. The most important are: 
 
a Area      [m2] 
b Breadth     [m] / [mm] 
d Distance    [m] / [mm] 
e Power     [kW] / [kVA] / [t] 
f Percentage   [%] 
h Height     [m] / [mm] 
n Number of 
l Length     [m] / [mm] 
q Capacity    [t/h] / [m3/h] 
s Specific weight  [t/m3] 
t Thickness    [mm] 
v Volume     [m3] 
w Weight     [t] 
 
A complete list of the unit-codes is found in the UNIT-table in WeightDB 
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The “area” code of the id is optional. If present, it is also a second small letter. 
It tells which area of the ship the parameter belongs to. The most commonly 
used are: 
 
a Afterbody 
c Cargo-area 
d Deckhouse 
e Engine-area 
f Forebody 
g Galley 
i Small deckhouse 
k Keel 
m Main hull 
n Accommodation 
o Forecastle 
p Poop 
s Superstructure 
u Upper area 
w Wheelhouse 
 
The full list of area-codes can be found in the table AREA in the WeightDB 
database. 
 
The “object” code consists of two capitalized letters and is also optional. If 
present, it tells which object the parameter belongs to. The most common 
abbreviations are: 
 
BP Bottom plating 
BW Bulwark 
DK Deck 
DS Double sides 
ER Engine room 
FO Foundations 
HC Hatch coamings 
HT Hatches 
IB  Inner bottom 
LB Longitudinal bulkheads 
LT  Longitudinal and transverse 
SH Shell 
SP Side plates 
TB Transverse bulkheads 
 
A complete list of available object-codes can be found in the OBJECT-table in 
WeightDB. 
 
Examples of parameters: 
 
lk     length keel 
aBW    area BulWark 
acLB    area cargo-area Longitudinal Bulkheads 
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teSH    Plate thickness engine area Shell 
 
In addition to the float-, integer- and text parameters, ShipWeight includes a set 
of calculated parameters. The definition of these can be found in the CATT-
table. The CATT-table contains four fields: 
 
sCAttID   ID of calculated parameter 
sCAttName Name of parameter 
sUnit    Unit 
sCAttExp  Formula for calculating the parameter 
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9 Introduction to Crystal Reports 

 
There are two ways of reporting from ShipWeight: by using the standard reports 
and Crystal Reports. 
 
The standard reports includes a Weight Item report, a Code report, a Weight 
Distribution report and a Weight tracking report to mention some. They are 
easily accessible from ShipWeight. 
 
The standard reports are built into – or “hardcoded” into ShipWeight. This 
means that they are included in the Shipweight-executable file. Therefore, a 
ShipWeight user cannot do any changes to these reports. The layout and the 
information to be included are locked. 
 
Naturally, many ShipWeight users need custom made reports. To meet this 
need, ShipWeight includes a powerful reporting engine based on Crystal 
Reports. 
 
Crystal Reports by Business Objects is the industry leading report-software 
created.  
  
ShipWeight includes a Crystal Reports viewer. 
 
Basically, the ShipWeight Reports dialog box does three things: 
 
1. reads a predefined report formatting file 
2. extracts data from the current database 
3. displays the report on screen 
 
Once your report is displayed on screen, you can send the report to a printer or 
export the report to various file formats. This includes formats such as Microsoft 
Word DOC and RTF and Adobe PDF. 
 
ShipWeight only comes with the viewer part of Crystal Reports. To be able to 
create your own reports, you must purchase the full version of Crystal Reports. 
 
The full version of Crystal Reports is a powerful, yet easy-to-use, tool for 
designing reports. Using Crystal Reports, you set up a report template 
specifying: 
 
1. what data the report should contain 
2. the order the data should appear 
3. the format of the report 
 
You can easily insert graphics, such as your company logo, into the report. Also 
a variety of charts are available for use in your report. 
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When you created a report template, you save it as a .RPT file. Make sure to 
set up Crystal Reports so that data are not saved with the report. This means 
that the .RPT file will not contain any data – only the formatting of the report. 
 
Now you can easily share your .RPT file with any ShipWeight user in your 
organization. Any user authorized to access the ShipWeight Report Viewer can 
run, view and print the report. 
  

9.1   The main window of Crystal Reports 
 
The Crystal Reports main window includes two main parts: The ‘Field Explorer’ 
and the Design Area. 
 

 
 
 
The Field Explorer includes all data that is available for use in the current report. 
This includes: 
 
• Database Fields  
• Formula Fields (calculated data) 
• Parameter Fields (user input) 
• Running Total Fields 
• Group Name Fields 
• Special Fields (page number, date etc.) 
 
The easiest way of adding data to the report, is to simply drag it from the ‘Field 
Explorer’ into the Report. 
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The design area at the right side is divided into several sections: 
 
• Report Header  First part of the report – For report title, chart, etc. 
• Page Header      Repeated on top of every page – For logo, date, etc. 
• Group Header  Repeated at the beginning of a group – For group title 
• Details           The main data of the report 
• Group Footer  Repeated at the end of a group – For group summary 
• Report Footer  Last part of the report – For report summary 
• Page Footer      Repeated at the bottom of every page 
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9.2   Developing Own Crystal Reports 

9.2.1 The Report Creation Wizard 

 
ShipWeight is delivered with a set of sample reports to be used with the Report 
Viewer. In many cases, the easiest way of creating your own report will be to 
modify one of the sample reports. This is especially useful if you just want to do 
minor changes such as inserting your company logo or change the formatting 
of a report. 
 
In this session, we will create a new report from scratch using the ‘Report 
Creation Wizard’. 
 
To start the wizard, you need to click the New Report button on the toolbar: 
 

 
 
 
  
Now, the ‘Report Creation Wizard’ will appear. This wizard will guide you 
through the process of creating a report. 
 
The first step is to choose the data you want to report on. Basically, this means 
choosing the database and tables to use in the report. 
 
The Data window of the wizard contains a list of ‘Available Data Sources’ on 
the left side, and ‘Selected Tables’ on the right side. 
 
In the list of ‘Available Data Sources’, you first expand the branch named 
‘Create New Connection’. This is done either by clicking the small plus sign or 
by double-clicking it with the mouse. 
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Next, you should expand the ‘OLE DB (ADO)’ branch. A new dialog box-window 
titled OLE DB (ADO) will appear. This window is used to set up the connection 
to the database. 
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In the ‘Provider’- list, you should select ‘Microsoft OLE DB Provider for SQL 
Server’. Click the Next button to continue. 
 
Now you will be asked to provide the necessary information to log on to the data 
source. 
 
The first thing you need to do is to check the ‘Integrated Security’ button. 
When ‘Integrated security’ is selected, Crystal Reports will connect to the SQL 
database using your Window username and password. Now you will not need 
to enter the ‘User ID’ and ‘Password’. 
 
Next, you should enter the name of the SQL server in the ‘Server’ field. Make 
sure to ask your database administrator for the name of the server containing 
the ShipWeight databases. 
 
Now, select one of the available databases from the ‘Database’ dropdown list. 
Databases starting with SW0 are project databases. 
 
For more information on the databases used in ShipWeight, please refer to the 
Chapter 8 Introduction to the databases. 
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Click the Finish button to close the ‘OLE DB’ window. 
 
Back in the wizard, you will now find the database in the ‘Data Sources’ tree. 
 
Double-click on the database name to expand the branch. Next, expand the 
‘dbo’ branch. A list of the available tables will appear. 
 
Now you need to drag-and-drop the ‘ITEM’-table’ to the ‘Selected Tables’ list 
at the right side. 
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Click the Next button. 
 
  
The next step of the wizard is to choose the fields to display in the report. 
 
The wizard now shows two lists: ‘Available Fields’ and ‘Fields to Display’. 
The Available Fields list shows all the fields in the ITEM table. 
 
To include fields in the report, simply drag-and-drop them to the ‘Fields to 
Display’ list. 
 
You can re-arrange the order of the selected fields by simply dragging them to 
a new location in the ‘Fields to Display’-list. 
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When you have selected the data you want in the report, click the Next button 
to continue to Grouping. 
  
If you want to group the data in the report, simply drag-and-drop this field from 
the ‘Available’-list to the ‘Group By’ list. 
 
In this example we will group on code C01, which is a Section code. 
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Click Next to go to the Summaries-part of the Wizard. 
 
To add summary information to the report, simply drag-and-drop the field to the 
‘Summarized Fields’-list. 
 
All numerical fields in the report are automatically added to the ‘Summarized 
Fields’-list. 
 
Please note that the default type of summary is Sum. Make sure to change 
summary type for VCG, LCG and TCG from ‘Sum’ to ‘Weighted average with 
Weight’. 
 



 

218 
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When you click the Next button, you come to the Group Sorting. We will not 
use group sorting in this example, so you should click the Next button once 
more to go to the Chart-section of the Wizard. 
 
We will include a Pie Chart showing the Weight of each section. Select Pie 
Chart. Optionally you can change the Chart title. 
 
Make sure the On change of field is set to ITEM.C01, which is our Section 
code in this example. Also check that Show summary is set to Sum of 
ITEM.Weight. 
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Click Next to go to Record Selection. You can use record selection to include 
only a part of the data from the database in the report. 
 
We will not be using record selection in this example. Click Next to continue to 
the last item in the wizard: Template. 
 
Crystal Reports comes with a set of predefined templates. You can use one of 
these to quickly change the look of your report. 
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Click the Finish button to exit the Report Creation Wizard. 
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9.2.2 Filtering data on ProjectID 

Each project database can contain several projects. The report will now include 
data from all projects on the database. To list data from the current project only, 
it is necessary to insert a filter. 
 
First, we will insert a parameter field to prompt for the current project name. 
Click Parameter Fields in the Field Explorer with the right mouse button. If 
the Field Explorer is not present, get it from the View menu.  From the right-
click menu, select New… 
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In the Create New Parameter dialog box, enter ProjectID (1.) as the name of 
the parameter. 
 
To add a dynamic list of values to the ProjectID parameter, select Dynamic 
(2.). You then click the Insert button (3.), and select ProjectID from the 
dropdown list. In the Parameters column, click on the text Click to create 
parameter (4.). The text will change to ProjectID. 
 
Click the OK button to close the Create New Parameter dialog box. 
 
Now we are ready to create the data filter. This is done by creating a Record 
Selection formula. Choose Selection Formulas and then Record… on the 
Report menu. 
 
In the Report Fields list of the Formula editor, expand the database and the 
item table. Select the database field ProjectID with the mouse, and drag it into 
the formula text window. 
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In the formula text window, type the sign of equality (1.) after the text 
{ITEM.ProjectID}.  
 
Select the parameter named ProjectID (marked with a question mark icon in 
the list) in the ‘Report Fields’ branch. Drag and drop it to the formula text window 
(2.). 
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The selection formula should look like this: 
 
{ITEM.ProjectID}={?ProjectID} 
 
Click the Save and close button. The report data will now be filtered to include 
the selected ProjectID only. 
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9.2.3 Formatting a report 

 

 
 
 
The preview shows that the report needs some formatting. 
 
Some of the fields are too short to display the number. The easiest way to fix 
this is to click on the field in the preview area and expand it using the mouse. 
 
The group summary fields are in the wrong position. Drag and drop them into 
place. 
 
To switch between preview and design mode, simply click the tab in the top left 
corner of the preview/design area. 
 
  

9.2.4 Displaying data in US-units 

 
Next, we want to display the data in US-units. In the database, all data are 
stored in metric units.  
 
Since the database does not contain any data in US-units, you need to create 
a formula to convert the value from metric to US units. 
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To create a new formula, you can right-click the Formula Fields in the Field 
Explorer. Select New… 
 
Enter the name of the formula: ‘US Weight’. 
 
Now the Formula Editor will appear. 
 
In the Formula editor, you will find a list of the available fields. Expand the 
branch ‘Report Fields’. Drag-and-drop the field ‘ITEM.Weight’, into the formula 
editor. 
 
Finish the formula by entering the multiplication sign (asterisk) and the 
conversion factor. The formula to convert from kg to lb should be: 
 
{ITEM.Weight} * 2.20462262184877 
 
Click the Save and close button on the toolbar. 
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Back in the main window of Crystal Reports, you will find the new formula under 
‘Formula fields’ in the ‘Field Explorer’. 
 
Before you insert the ‘US Weight’ field, you need to delete the original weight 
field from the report. Simply select the field in the design view, and click the 
Delete button. 
 
Now, you need to drag-and-drop the ‘US Weight’ formula into the Details 
section of the report. 
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Finally, you must change the summary fields to summarize the ‘US Weight’ 
formula instead of the ‘Weight’ database-field. 
 
To do this, select the Group Summary field in the design view, and click on it 
with the right mouse button. Select Edit Summary from the dropdown menu. 
 

 
 
 
The ‘Edit Summary’-window pops up. Select US Weight in the Choose the 
field to summarize ListBox. Click OK to close the window. Repeat this for the 
Report Summary. 
 

 
 
The report now shows the weight in pounds instead of kilograms. 
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9.2.5 Summarizing a Code-field 

 
In the project we have used, Code C03 is the Vertical Moment. We would like 
to summarize the moments. 
 
Crystal Reports can only summarize numerical fields. And since ShipWeight 
stores the code values as strings, you cannot summarize code values directly. 
 
The solution is to create a formula that converts the string C03 into a numerical 
value. 
 
Create a new formula named ‘VMom’. In the Formula Editor drag-and-drop the 
field ITEM.C03 into the editor. 
 
To convert a string to a number, you need to use a Crystal-Reports function 
named TONUMBER(). The formula should look like this: 
 
tonumber({ITEM.C03}) 
 

 
 
 
Now, the formula ‘VMom’ is available in the ‘Field Explorer’. 
 
In the design area, select and delete the field ‘C03’. Then drag the formula 
‘VMom’ into the report. 
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To insert a summary of the Vertical Moment, choose Insert Summary from the 
Insert menu. 
 
Now the Insert Summary dialog box will appear. First, select ‘VMom’ in the 
‘Choose the field to summarize’ list box. 
 
Then make sure the Calculate this summary option is set to ‘Sum’. 
 
Finally, set ‘Summary Location’ to ‘Grand Total (Report Footer)’ 
 

 
 
 
In the same way, insert a Group summary. Hint: in the ‘Insert Summary’ 
window, you will need to set the ‘Summary location’ to ‘Group #1: ITEM.C01 – 
A’ 
 
Now, you successfully have inserted a summary of code values into your report. 
Click the Preview tab to see the result. 
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9.3   Upgrading existing reports to include ProjectID 
 
From ShipWeight version 7.5 and onwards, any number of projects can be 
stored on the same project database. To identify which project the data belongs 
to, every table in the project databases now have a ProjectID-field.  
 
Crystal Reports created for ShipWeight versions prior to version 7.5 does not 
take the ProjectID into account. Therefore data from all projects on the same 
project database are reported. 
 
To correct this, the data listed in the report must be filtered to include data from 
the current project only. In order to accomplish this for an existing report, there 
are three steps to follow: 
 
Refreshing the Datasource 
Creating a Record Selection formula 
Change Subreport links 
 

9.3.1 Replace Datasource 

When you open an existing pre-ShipWeight 7.5 report in the Crystal Report 
designer and expand the Database Fields in the Field Explorer, you will notice 
that the ProjectID field is missing. To be able to create a Record Selection 
formula based on project ID, the ProjectID-field must be present in the 
Database Fields list. 
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To achieve this, the Datasource must be replaced with an updated database. 
On the database menu, select Set Datasource Location. 
 
The Set Datasource Location dialog box is used to change the location of the 
data source. This is done by selecting a database in the ‘Current Data Source’ 
list, and choosing a database to replace it with from the ‘Replace with’ list. Then 
click Update. 
 

 
 
The report used in this example, is connected to three databases. To view the 
details of the database connection, please expand the Properties branch in the 
‘Current Data Source’ list. 
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The Initial Catalog entry of in the properties list, shows the name of the 
database. In this case, the database name starts with SW0, indicating that this 
is a project database. 
 
Next, you must locate a project database to replace it with. In the ‘Replace 
with’ list, please expand the ‘Create New Connection’ branch either by 
double-clicking it with the mouse or by clicking the plus sign next to it. Locate 
‘OLE DB (ADO)’ in the list and double-click it with the mouse. 
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The ‘OLE DB (ADO)’ window will open. Select ‘Microsoft OLE DB Provider 
for SQL Server’ in the Provider list. Click the Next button. 
 

 
On the next screen, check the Integrated Security option. Select or type in the 
name of the SQL server and choose a database to replace the current 
database. Click the Finish button. 
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Back in the ‘Set Datasource Location’ window; make sure the correct 
database is selected in the ‘Current Data Source’ list. Select the newly created 
database connection in the ‘Replace with’ list. Click the Update button. 
 

 
Now the database connection is updated. Next, we need to replace each 
database table listed below the data source connection. 
 
In the ‘Current Data Source’ area, click the table to be updated, in this case the 
item table. In the ‘Replace with’ area, expand the database branch and then the 
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dbo branch. Now a list of the available database tables will appear. Click the 
table to replace with and click the Update button. 
 

 
 
Repeat this procedure for all database connections and database tables in the 
‘Current Data Source’ list. This must also be done for database connections 
and database tables used by Sub-reports. 
 
Please note that you only have to replace project databases and project log 
databases. These have names starting with SWXX_, where XX can be any 
number between 00 and 10. 
 
When you are done, close the Set Datasource Location window. On the 
Database menu of the Crystal Reports designer, select Verify Database. A 
message saying ‘The database is up to date’ should appear. 
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In the Field Explorer, you can see that the ProjectID field is available. 
 

 
 
 

9.3.2 Adding a ProjectID parameter field 

In order to filter the data on the current ProjectID, we need to ask for the project 
name at run-time. This is done by inserting a parameter field into the report. 
The parameter field will cause a dialog box to open when the report is run, 
asking the user to enter the required parameter values. 
 
To insert a parameter field, click Parameter Fields in the Field Explorer with 
the right mouse button. From the right-click menu, select New… 
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In the ‘Create New parameter’ dialog box: 
 
Enter the name of the parameter (ProjectID). Make sure that Type is set to 
String (default). 
 
Set ‘List of Values’ to Dynamic. 
 
Click the Insert button, and select ProjectID from the dropdown list. 
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Click on the text Click to create parameter in the table. The text will change to 
ProjectID (name of the parameter). 
 
Optionally, set Allow multiple values to True in the options list. This will enable 
the user to include several ProjectIDs in the selection. This could be useful 
when creating a report to include data from a project and its master-project. 
 
Click OK to close the dialog box. 
 
IMPORTANT: You can only add a dynamic list of ProjectID-values to a 
parameter if you have installed Crystal Reports version XI. Users of earlier 
versions of Crystal Reports must skip step 2, 3 and 4 above. 
 
 

9.3.3 Create Record Selection Formula 

Now we are ready to create the data filter. We want to create a filter that selects 
only data with ProjectID equal to the current project name. 
 
Filtering of data is done by creating a Record Selection formula. On the Report 
menu, choose Selection Formulas and then Record… Now the Formula 
Workshop window opens. 
 
In the Report Fields list, expand the database and the appropriate database 
table, in this case the item table. Select the database field ProjectID with the 
mouse, and drag it into the formula text window. 
 

 
 
In the formula text window, type the sign of equality after {ITEM.ProjectID}.  
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Next, expand the Report Fields branch. Locate the parameter named 
ProjectID. Drag and drop it to the formula text window. Parameter fields are 
marked with a question mark icon in the list. 
 

 
 
The selection formula should look like this: 
 
{ITEM.ProjectID}={?ProjectID} 
 
Click the Save and close button. 
 
To view the effect of the filter, preview the report in the Crystal Reports 
designer. Select Print preview on the View menu. 
 
Now a prompting dialog box appears, asking you to enter ProjectID. Select a 
ProjectID from the dropdown list and click OK. 
 
Please note that users of Crystal Reports version 10 and earlier will not be able 
to display the available ProjectIDs in a dropdown list. The ProjectID must then 
be entered manually. 
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If there are no sub-reports in your report, you can save and close the report. 
 

9.3.4 Change Sub-report Links 

If your report contains sub-reports, you most likely will need to filter the data 
used in them to include data from the selected project only. 
 
In the Crystal Reports designer, select the sub-report and right click on it with 
the mouse. Choose Change Subreport Links… from the right-click menu. 
 

 
 
The Subreport Links dialog box opens. In the ‘Available fields’ list, locate and 
select the ProjectID parameter (marked by a question mark icon). Click the 
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right arrow button. The ProjectID parameter is now moved to the ‘Field(s) to 
link to’ list. 
 

 
 
Make sure ‘Select data in subreport based on field’ is checked, and that the 
field ‘ProjectID’ is selected. 
 
Click OK to apply the changes. 
 
Repeat this for all sub-reports included in the report. 
 
The report now contains data from the selected project only. Finally, save the 
report before closing it.  
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