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1 Introduction 
 
This tutorial is designed to give a walkthrough of the most important features of 
ShipWeight. 
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2  Preparing a project 

A  Getting started 
 
Start ShipWeight. Create a new design project by selecting New from the Project 
menu, or by clicking the ‘New project’ button on the toolbar. 
 

 
 

It is necessary to fill in the fields Database ID, Project ID, Main type and Sub type, -
the others are optional. 
 
Select Other Specialized Vessel as Main type, and Research Ship as Sub type. The 
other fields can be typed in as pleased. 
Click OK. 
 
The Choose main weight group dialog will now pop up. Select OK to verify that DISP 
displacement should be the main post. 
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The Main parameters dialog will now pop up. Fill in the fields for main particulars. 
 

 
 

 
For a suggestion of values to fill in, see the above figure or chapter 7 Data for MS 
Breeze. 
 
Click the Close button. 
 
 



 

ShipWeight  Tutorial                     

 

 

2011 BAS engineering AS      6 

B  Preparing the item dialog 
 
Open the item dialog 
To open the item dialog, select Items… on the Wgt.Grp menu. Alternatively, press 
the ‘Item level’ button on the toolbar:  
 
The item dialog now opens in default mode. Next we will add default codes 
 

 
 
Open the Code Definition dialog 
To open the Code Definition dialog, select Code definition… on the View menu of the 
Item dialog. The Code Definition dialog contains a tree-view on the left side, and a 
table on the right side. 
 
 
Define Drawing number code 
To create a code, select the cell in the column “CodeType” of the table. The cell will 
become activated and editable. A new row automatically will be added, and the cell 
will turn into a combo box (editable dropdown list). 
 
Next, activate the dropdown of the combo box and select the ID of the custom code 
you want to make e.g. C01. 
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Next, fill in the following fields: 
 
Field    Value     Description 
Title    Drawing no.   Title will show above field in Item dlg. 
Description Drawing number Information only, no effect 
FieldSize  15       Number of characters allowed in field 
Calculate  (leave empty)  Formula for calculated codes (Leave empty) 
Tab    Right      Alignment of value in Item dlg. 
Format   (leave empty)  Formatting of calculated fields (Leave empty) 
FieldType  EditBox     Specify a standard editable field 
  
To finish off the registration of code C01, click with the mouse on the empty line in 
the table. You can make sure that the code has been registered by checking that it is 
added to the tree left of the grid. Click the minus/plus sign to (un)expand the tree. 
 
The FieldType in this case is EditBox. This means that the custom code field will be 
an editable box where the user may type in freely. 
 
The other Fieldtypes are: 
 

• ListBox – the user must select value for the field from a dropdown list of 
predefined values 
 

• ComboBox – the user may select value for the field from a dropdown list of 
predefined values or type in freely 
 

• ReadOnly – the value cannot be changed by the user 
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Define Weight status code 
In the same way, add the code C02 with the following values: 
 
Field    Value      
Title    Weight Status 
Description Weight Status Code 
FieldSize  20 
Calculate  (leave empty) 
Tab    Left 
Format   (leave empty) 
FieldType  ListBox 
 
Next, we will add code values to the Weight Status code. In the tree-view, select 
code ‘C02 – Weight Status’. An empty table for adding code values will appear on the 
right side of the tree-view.  
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Select the row of the table and fill in these values: 
 
Field     Value      
CodeID    E 
Description  Estimated 
Factor    1.1 
 
Leave the rest of the fields empty, and click on the next row in the table. Enter two 
more code values: 
 
Field     Value      
CodeID    C 
Description  Calculated 
Factor    1.05 
 
Field     Value      
CodeID    A 
Description  Actual 
Factor    1.02 
 
Finish off registering the code value by clicking the last row in the table with the 
mouse. 
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Define Weight with margin code 
 
Next, click the topmost asterisk in the tree-view to display the Code Definition table. 
Add code C03 with the following values: 
 
Field    Value      
CodeType  C03 
Title    Weight with Margin 
Description Weight multiplied with margin based on Weight Status code 
FieldSize  20 
Calculate  [Weight]*[C02].[Factor] 
Tab    Right 
Format   %.4f 
FieldType  ReadOnly 
 
Click the empty row of the table to finish off the registration of C03. Finally, close the 
Code Definition dialog. 
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Open the Item setting dialog 
 
Back in the Item dialog, select Item settings… in the Setting menu to display the Item 
setting dialog. Alternatively, press the  Item setting… button on the toolbar. 
 
The Item setting dialog controls the layout of the Item dialog. 
 

 
 
 
Create a user defined input view 
 
When the Item Setting dialog pops up, press the New Setting button to create a new 
setting. In the tree-view on the left side, click the plus sign next to the asterisk to 
expand the tree. A setting named ‘New setting’ has been created. Your dialog should 
then look like this: 
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Change SettingID from ‘New setting’ to ‘Default set ting’ 
 
Make sure the topmost asterisk is selected in the tree. Click the ‘New setting’ cell in 
the SettingID column of the table. Change the Setting ID from ‘New setting’ to e.g. 
‘Default Setting’. 
 
 
In ‘Single view’-view: Move code C02 from Codes gro up to Weight & CoG 
group, next to the Weight field. 
 
Next, expand the tree further by clicking the plus sign in front of ‘New Setting’, ‘Single 
Record’, ‘Weight & CoG’ and ‘Codes’. 
 
Select ‘C02’ in the ‘Codes’ branch of the tree. 
 

 
 
 
Using the mouse, drag ‘C02’ from the ‘Codes’ group and drop it on Weight in the 
‘Weight & CoG’ group. C02 will now be placed directly after the Weight field in the 
Single Record area of the Item dialog. 
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In ‘Table’-view: Hide TCG_min and TCG_max 
 
Collapse the ‘Single Record’ branch by clicking the minus sign in front of it. Next, 
expand the ‘Table’ branch and then the ‘Weight & CoG’ branch. 
 
Select ‘TCG_min’ with the mouse. Drag and drop it in the ‘Hidden’ group. Repeat this 
for TCG_max. 
 

 
 



 

ShipWeight  Tutorial                     

 

 

2011 BAS engineering AS      14 

The TCG_min and TCG_max fields will now be hidden in the Single View area of the 
Item dialog. 
 
 
Apply the new dialog setting 
 
Close the Item setting dialog. Back in the Items dialog, select ‘Default Setting’ from 
the ‘Setting’ dropdown list on the toolbar. 
 

 
 
Now, the Item dialog should look like this: 
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Note:  This is only one setting.  You may make as many settings as you like.  The 
purpose of this is to only see fields that are relevant for the work process you are 
currently in. 
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3 Getting data into ShipWeight 
 

A  The item dialog: entering data 
 
Open the Items dialog for weight group 111 Shell Pl ating. 
 
In the ShipWeight main dialog window, navigate to weight group 111 Shell Plating 
and open the Item dialog. 
 

 
 
 
Add weight item ‘Plate 1’ using the ‘Single Record’  area 
 
To register a new item weight using the Single Record area of the Item dialog, you 
must start by selecting Weight Group 111 from the WgtGrp dropdown list. 
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Jump to the ItemNo field by pressing the TAB button. Enter Item number 1. When 
pressing TAB once more, the item will be created. Continue filling in data for the 
weight item. 
 
Data for Section 1, 111 Shell Plating: 
 
Field     Value      
WgtGrp:   111 
ItemNo:    1 
Description:   Plate 1 
NoOf:    1.000 
Factor:    1.000 
Length:    1.000 
Width:    1.000 
UnitWeight:  300.00 
Weight Status: C 
VCG:    4.300 
LCG:     -1.250 
TCG:    0.000 
VCG_min:   1.500 
VCG_max:  6.000 
LCG_min:   -5.000 
LCG_max:  2.500 
TCG_min:   0 (hidden field) 
TCG_max:  0 (hidden field) 
Drawing no.  123-456 
 



 

ShipWeight  Tutorial                     

 

 

2011 BAS engineering AS      18 

To complete the registration of the weight item, press the right-arrow on the toolbar, 
or click the empty row in the table. 
 
 
Add weight item ‘Plate 2’ using the ‘Table’ area 
 
Select the empty row in the table and double click the WgtGrp cell. WgtGrp will now 
be set to 111. Click the TAB-key to jump to the next column. Continue entering item 
data for ‘Plate 2’. 
 

 
 
Data for Plate 2, 111 Shell Plating: 
Field     Value      
WgtGrp:   111 
ItemNo:    2 
Description:   Plate 2 
NoOff:    1 
Factor:    1 
Length:    1 
Width:    1 
UnitWeight:  730 
VCG:    4.2 
LCG:     6.25 
VCG_min:   1.5 
VCG_max:  6 
LCG_min:   2.5 
LCG_max:  10 
Drawing no.  123-654 
Weight Status: C 
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Local Coordinates 
 
Local coordinate systems are only available in the Item dialog and the function must 
be enabled through the “Option” dialog (menu: View->Option…). 
 

 
 
To set up a local coordinate system, press the ‘Local coordinates’ button on the 
toolbar, or select ‘Local coordinates’ on the Setting menu in the Item Dialog. 
 
The Local coordinates dialog includes a grid with four columns. To create a local 
coordinate system, simply fill in the fields: 
 
Title   Name of the local coordinate system 
VCG-ref  Vertical reference point 
LCG-ref  Longitudinal reference point 
TCG-ref  Transverse reference point 
 
Up to ten different local coordinate systems can be defined. The unit of the VCG, 
LCG and TCG reference points is determined by the Units selected in the options 
dialog: meters when Metric units are selected and feet when US units are selected. 
Please note that the reference points are not converted when changing Units from 
Metric to US units and vice versa. 
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When you have finished adding/editing local coordinate systems, press the Close 
button to close the dialog window. 

 
To activate a local coordinate system select it from the ‘Local coordinates’ dropdown 
list on the toolbar of the Item dialog. 
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A  Importing data 
 
In this tutorial we will import weight data from an Excel workbook. This can be done 
using the ‘ShipWeight Data File Import’
 
To follow this tutorial, please open an appropriate project or create a new project. 
you have just completed the previous chapters, you are set. Otherwise, p
to chapter 2 for details on creating a new project.
 
In the ShipWeight main dialog window, 
Now, the ShipWeight Data File Import
 
First we set the ‘Import source’ options. On the ‘Import source’ tab
the Browse button. Using the ‘Open dialog window, we locate the Excel file to 
Press the Open button to select the file
 

 

                

 

 

In this tutorial we will import weight data from an Excel workbook. This can be done 
using the ‘ShipWeight Data File Import’-dialog. 

w this tutorial, please open an appropriate project or create a new project. 
you have just completed the previous chapters, you are set. Otherwise, p
to chapter 2 for details on creating a new project.  

In the ShipWeight main dialog window, we select Project � Import 
Data File Import dialog opens. 

First we set the ‘Import source’ options. On the ‘Import source’ tab
the Browse button. Using the ‘Open dialog window, we locate the Excel file to 
Press the Open button to select the file “SwbsImport.xls”. 
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In this tutorial we will import weight data from an Excel workbook. This can be done 

w this tutorial, please open an appropriate project or create a new project. If 
you have just completed the previous chapters, you are set. Otherwise, please refer 

Import � Data file…. 

First we set the ‘Import source’ options. On the ‘Import source’ tab-sheet, we press 
the Browse button. Using the ‘Open dialog window, we locate the Excel file to import. 
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Back in the ‘ShipWeight Data File Import’ window, 
file’ (default).  
 
Next, we must verify that the name of the Worksheet to be imported is correct
important that the name of the Worksheet given in the ‘ShipWeight Data File Import’ 
dialog is exactly the same as the name of the spreadsheet in the Excel file.
 

The next step is to define a set of import rules. The 
database field the data from each column of the Excel file will be stored.
 
In the ‘Edit definition of selected line’ 
data in the first column in the Excel sheet. In this case, since the f
spreadsheet contains ‘Wgt
‘Add’ button to apply the rule.
 

                

 

Back in the ‘ShipWeight Data File Import’ window, check that file type 

Next, we must verify that the name of the Worksheet to be imported is correct
important that the name of the Worksheet given in the ‘ShipWeight Data File Import’ 
dialog is exactly the same as the name of the spreadsheet in the Excel file.

 
The next step is to define a set of import rules. The import rules determine in which 
database field the data from each column of the Excel file will be stored.

In the ‘Edit definition of selected line’ panel, we select the database field to store the 
data in the first column in the Excel sheet. In this case, since the first column of our 

tGrp’ data, we must select the field ‘WgtGrp’. Press the 
‘Add’ button to apply the rule. 
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ile type is set to ‘Excel 

Next, we must verify that the name of the Worksheet to be imported is correct. It is 
important that the name of the Worksheet given in the ‘ShipWeight Data File Import’ 
dialog is exactly the same as the name of the spreadsheet in the Excel file. 

 

determine in which 
database field the data from each column of the Excel file will be stored. 

, we select the database field to store the 
data in the first column in the Excel sheet. In this case, since the first column of our 

Grp’ data, we must select the field ‘WgtGrp’. Press the 
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Continue adding database fields according to the columns in the spreadsheet. In this 
tutorial we will add the following database fields: 
 

• WgtGrp 
• ItemNo 
• Description 
• NoOff 
• Factor 
• Length 
• Width 
• UnitWeight 
• VCG 
• LCG 
• TCG 
• LCG_min 
• LCG_max 
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This import definition list may be saved (click “save” button in the dialog) and 
restored by clicking from the “Open” button later. 
 
 
In case of Item numbers missing from the import file: 
 
Before we start importing data, we must set the import options. Click the ‘Options’ tab 
sheet. 
 
First we will check off the option ‘Auto ItemNo starting from’. The reason for this is 
that our spreadsheet doesn’t contain a column for item numbers.  
 
Please note that the import will fail if you try to import data with item numbers already 
in use in the database. If this is the case, please try to increase the number in the 
‘Auto ItemNo starting from’ field. Alternatively, check off the ‘Update existing’ option 
to overwrite items with identical item numbers.  
 
We also want to pad the item numbers with zeros. Check off the option ‘# of 0’s to 
pad ItemNo’.  Please note that the option ‘Number of header rows’ is disabled. The 
‘ShipWeight Data File Import’ always assumes that the spreadsheet contains one 
header row. 
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Now we are ready to start importing data. Make sure that the spreadsheet you are 
going to import is not open in Excel.  
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You will get the following question after import: 
 

 
 
No need to update as no calculated codes are affected, so click “No”.  When the 
import is complete, select ‘Close’. 
 
You will get a dialog that ask you to ‘Summarize wgt.grp’ in the ‘Wgt.Grp’ menu. 
Please do this after returning to the main dialog window of ShipWeight.  
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4 Manipulating Data 
 
Create a filter to display weight items with VCG > 4 m 
 
In the tree-view on the main dialog, navigate to weight group E2.2 under LW – 
Lightship � 100 � 110 � 111 Shell Plating, and open the item dialog. 
 
Press the  ‘Apply filter’ button on the toolbar, or select Tools � Filter � Apply… 
on the Tools menu. The Item Filter dialog will pop up. 
 

 
 
In the ‘Table Fields’ list, select VCG. Select the ‘>’ operator from the ‘Operators’ list. 
Set the ‘Value’ to 4, and press the Insert button. 
 
Press OK to apply the filter. Now, 5 items which have VCG’s larger than 4.0 meters 
will be listed. 
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To remove the filter, select Tools � Filter � Clear, or press the  ‘Clear Filter’ 
button. 
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Sort the weight items on Description and Weight 
 
To open the Sort dialog, select Sort � Apply… on the Tools menu, or press the  

 ‘Sort’ button on the toolbar. 
 
Click the ‘Field Name’ cell of the empty row. The cell will change to a combo box. 
Activate the dropdown list, and select Description. 
 

 
 

Click the ‘Data Type’ cell. By default, the value will be set to ‘Ascending’. 
 
On the next row, select 
 
Field Name:   Weight 
Data Type:  Ascending 
 

 
 
Press the OK button to apply the Sort. 
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Splitting Items 
 
The Split item dialog is used to divide an item into two or more parts. In the Items 
dialog, select a weight item. Choose ‘Split item…’ on the Items menu.  
 
Next, select the number of sub-items to split the item into. Choose whether to split 
the weight or not. Select how to treat the original item: ‘Delete’, ‘Keep remainder’ or 
‘Keep unchanged’. 
 
Press the OK button to create the new items and close the dialog. 
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Merging Items 
 
From the Items menu “Merge items” you may go also merge item by selecting them 
(consecutive) in the Item Dialog and run the merge function from the menu. 
 
Multiple Editing of Items 
 
You can use the ‘Set field values’ option to edit several weight items in one 
operation. The fields available for editing are: 
 
Description 
Quantities 
Weight (if not read-only) 
CoG 
Extensions (CoG_min and CoG_max) 
Codes 
 
Select the desired items, and choose ‘Set field values…’ on the Edit menu. Next, 
choose the field to be changed in the ‘Select field type’ dialog window and press OK. 
The ‘Set value’ dialog will appear. Type a value into the field at the upper left corner 
of the dialog window or select one of the available values in the list below. Press OK 
to apply the changes. 
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Code Mapping 
 
First make two codes: “C05 – Compartment code” and ”C06 – Compartment 
description” in the code definition dialog. 
 

 
 
In the Code Mapping dialog, select C05 as Code Type 1 and C06 as Code Type 2.  
Select “C1” value in the first drop list, then “Compartment one” in second drop list 
and click “Add” button.  Next I select “C2” in first drop list and “Compartment two” in 
second drop list and click “Add” button. Finally, select “C3” in first drop list and 
“Compartment three” in second drop list and click “Add” button.  This creates the 
mapping.  Now close the dialog. 
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In the Item Dialog, weight items are assigned compartment code (C05), but not 
compartment description (C06): 
 

 
 
All items to be assigned “Compartment description” through “Code Mapping” must be 
selected in the Table View, and go to “Items” menu in the Items Dialog and select 
“Set Codes by mapping…”. 
 
Click “OK” on the message pop-up and then select “C06” in the pop-up dialog to pick 
the code to be updated: 
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When “C06” is selected in the list click “OK” and once more click “OK” to pass the 
message pop-up and then select “C05” in the pop-up dialog to select the code the 
update should be based on:  
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Click OK again and code C06 should be updated based on the mapping.   
 
You’re done: 
 

 
 
Changing Weight Group Code for Items 
 
The easiest way of moving weight items from one weight group to another is to use 
the ‘Change wgt.grp. code…’ option. Select the desired items in the table and select 
‘Change wgt.grp. code…’ option on the Edit menu. The ‘Select Weight Group’ dialog 
will appear. Choose a weight group and press OK. 
 
Cell Formula in Item Dialog 
 
A formula typed into a grid cell in the Item Dialog (i.e. =5*4+2) is stored for later use.  
If a grid cell value is calculated from such formula, this grid cell will show the formula 
in a tooltip when the mouse pointer is resting on the cell.  When editing the grid cell 
later, the calculated result value transforms back to this formula in the cell. 
 
Frame Conversion 
 
If frame spacing is defined in Project Data dialog (menu View->Project Data… ) then 
frame number can be entered into the LCG, LCG_min and LCG_max field of the Item 
dialog by typing a # sign in front of the value.  The frame number will then 
automatically be converted to metric or US units (depending on unit setting) 
according to the frame spacing defined.   
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5 Weight Monitoring and Reporting 

A  Standard reports 
 
From the Project menu, select Report setup. Select:  
 

Report values  Defined 
Sort by     Unit 
Wgt.grp.    Sum 
Code type    C01 – Drawing no. 

 

 
 
Click OK to close the dialog. 
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Select Reports and 4 Wgt.grp Weight and CoG on the Project menu. The report will 
be opened in the Print Preview dialog. 
 
In the Print Preview dialog, press the MS Word button to export the report. Close the 
Preview window. 

 
 



 

ShipWeight  Tutorial                     

 

 

2011 BAS engineering AS      38 

Crystal reports 
 
Start ShipWeight Report by selecting Crystal Reports… on the Project menu of 
ShipWeight. 
 

 
 
The first thing to do is to select the report you want to run. In this example we will use 
the report Three-digit sample.rpt. Locate the report file on your hard drive by pressing 
the Browse button to open the Open dialog window. 
 
When you have located and selected the file Three-digit sample.rpt, press open. Now 
the file name will show in the Select report field. 
 
Next, press the ‘Run report’ button. 
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In the “Enter project ID” dialog that now pops up, select “Tutorial” from the dropdown 
list and click “OK”. 
 
The report should now be displayed after a few seconds. 
 
 

 
 
Now, use the toolbar or the group tree to navigate through the report. Also try 
exporting the report to portable document format (PDF), Word or Excel. 
 
You may try the same with the Weight and CoG sample.rpt 

6 Additional Features 

A  Gyradius values 
 
From the View menu in main window, select Gyradius… 
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Approximate gyradius values for the project will now be shown. Close the gyradius 
dialog. 
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B  Weight distribution curve 
 
From the View menu in main window, select Weight distribution… and then Curve. 
 
 

 
 
 
The weight distribution curve will be displayed. Tick off the Weights checkbox to 
show centre of gravity for weight items as points in the graph. Click (and hold) on one 
of the points to view information about the weight item. 
 
Click the Print/Export button to show possibilities for export. Close the dialog. 
 
Please note that for the weight distribution curve to be displayed it is necessary not 
only to define weight, VCG and LCG, but also Aft and Fore location of the item. 
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C  Move CoG 
 
Open the Move CoG dialog from the Wgt.Grp. menu. Make sure the VCG-tab is 
selected. 
 

 
 
 
Click the browse button (…) next to the Topmost wgt.grp. field. 
 
 

 
 
Expand the tree, select weight group M1 and click OK. 
 
Enter Move interval 0.5 m. 
 
Press Move and then Close. 
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7  Weight Estimation 

A  Preparing an estimate 
 
Starting a new project  
 
Start a new project using the Project data and Main Parameters of MS Breeze. See 
chapter 7 for details. 
 
Please refer to chapter 2 Solution A for instructions. Make sure to select a unique 
project ID. 
 
Select historical Demo database 
 
To be able to follow the tutorial, the historical database must be switched to demo 
mode.  To do this, follow these steps: 
 
Select “Options...” from the “View” menu and select the “Advanced” tab.  Next, select 
the browse button [...] and select the historical database sdb_Demo_Swbs.  Click OK 
to save and close the options dialog. 
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Ship types 
 
Open the Ship types dialog by selecting Ship Types… on the Estimate menu. 
 
Select the node ‘9 Other Specialized Vessel’ branch by clicking it’s plus sign. Click 
the ‘Include’ button. 
 

 
 
Now, historical data from ships of type ‘Other Specialized vessel’ will be included in 
the graph when estimating weight and centre of gravity. The vessels mentioned here 
might have been selected by default. 
 
Select OK.  
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Reference Ships 
 
On the Estimate menu, select Reference ships… to make sure that all ships are 
included as reference ships. The vessels should have a green R to the left of the ship 
ID to be included. If there are no green Rs, click Include All button. 
 
 

 
 
Click OK. 
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B  Estimating lightship weight 
 
Navigate to the lightship weight group LW in the main window. In the Estimate menu, 

select Weight or click the  Estimate weight button on the toolbar. The Estimation 
dialog appears. 
 

 
 

In the estimation dialog, select the regression coefficient in the graph, either by 
selecting the first button in the Select coefficient dialog, or by moving the horizontal 
coefficient line in the graph by using the mouse. The horizontal coefficient graph 
should then be moved until it intersects with the regression line and the vertical plot 
parameter line. 
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Select the  button in the estimation parameter dialog to execute the 
calculation of the lightweight weight group. 
 
In the right column of the estimation parameter dialog, click the  button to 
set the uncertainty value as suggested by the system. Enter 0 (zero) in the grids for 
uncertainty of the other formula values to obtain the standard deviation for the 
calculated weight. (If it is impossible to enter a value into a grid, the value is a 
composite variable. The grid should then be double clicked to enter a dialog to set 
the values of the composites) 
 

 

 
 

 
 
From the Graph menu in the estimation dialog, select Print graph to document the 
estimation. The print dialog can be resized. Also, selecting Save Current Settings 
from the Setting menu will save the settings in the dialog in order for you to find it the 
same way the next time you enter the estimation window in this weight group. 
 
Close the estimation dialog by selecting Close in the Window menu in the dialog. 
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C  Log result 
 
You can log your work using the Project Log dialog. 
 
In the main window, select View � Log � Project Log… and enter a comment, click 
the Get weight groups button and the Add to log button to store the initial result. 
 

 
 
Click the Close button to get back to the main window. 
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D  Refining the estimate 
 
Navigate one level down to the 100, 200, ... , 700 groups and estimate these. Select 
the 400 weight group and enter the estimation dialog once more. 
 
Notice that the standard deviation is around 13% for the regression value. Click on 
the two coefficient dots in the graph that is farther away from the . The ships 
coefficients are circled and numbered 1 and 2.  
 

 
 
 
The comparison data for the two selected ships are now displayed in the columns in 
the lower part of the estimation dialog. Notice that the two ships are particularly short 
compared to the rest of the vessels displayed, less than 50 meters long. 
 
Click on the Lengt betw. perp text in the comparison area to highlight this value. 
Next, select Filter limits… from the Graph menu in the estimation dialog. 
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Enter 80 as upper limit and 50 as lower limit for the main engine power. Click OK. 
The selection of coefficient plotted in the graph is now narrowed down to be only 
those with Length between perpendiculars between 50 and 80 meters. 
 
Notice that uncertainty standard deviation have gone down from about 13% to 9%. 
Because of the automatic scaling of the graph, it is hard to see this reduction of 
uncertainty just from the graph. Tick off Zoom in the Graph menu to have a look at 
the graph without scaling . 
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E  User defined estimation methods 
 
On the menu Estimate, click Define Methods… The dialog window will show three 
main areas with tree-resources. The area to the left contains the work breakdown 
structure. In this area, use the mouse to select the weight group Hull. The method for 
this weight group will be shown in the area in the middle.  
 

 
 
You want the method for Hull to be W=k*(length^2)*breath*(depth^0.5)  and plot the 
coefficient against ship length. Select the estimation parameters and click once more, 
to reveal a combo box. Select – on top of the list to clear the parameter. 
 
Select the plot parameter and delete it. Leave the comparison parameters as they 
are. 
 
Under ESTIMATION, select a "length parameter" (e.g. Ship length over all) in the 
combo box for No.1. Add breadth and depth parameters in same way (e.g. Bm Ship 
breadth and hDM Depth to maindeck). Set the power parameters to be 2, 1 and 0.5. 
 
Under PLOT, select the "length parameter" again in the right area and click ADD 
button. Now you are done, select the OK button. 
 
To be able to use your own method do the following: 
Enter the main estimation dialog window in the weight group H Hull. From the menu 
Method select User defined. Now your own method will be applied when estimating. 
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8 Administrative Functions 

A  User permissions 
 
Add a user group 
 
The Permissions dialog is used to manage user groups and user accounts. To open 
the Permissions dialog, click Project � Permissions � Administration... 
 
The Permissions dialog is divided into three tab-sheets: Users, Groups and 
Password Policy. To administrate the user groups, please select the Groups tab. 
 

 
 
To add a new user group, please select the Add… button. 
 
The New User Group dialog opens. The dialog is divided into three tab-sheets: 
Members, Permissions and Weight groups. 
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In the Members tab-sheet, please set the Group ID field to ‘Machinery only’ and enter 
a description. 
 
Next, select the Permissions tab-sheet. 
 
 

 
 



 

ShipWeight  Tutorial                     

 

 

2011 BAS engineering AS      55 

The Permissions tab-sheet in the New User Group dialog, contains a tree-view. The 
tree-view is used to limit the actions of the current user group. 
 
Please check off Read in the ProjectInfo-branch. 
 
Select the Weight Groups tab. 
 

 
 
Please expand the tree in the Weight groups tab-sheet. Please check off the weight 
group M and its sub groups should be selected automatically. 
 
Press OK to exit the ‘New user group’ dialog. 
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Add a user 
 
Back in the Login dialog (permissions dialog), select the Users tab sheet. 
 

 
 
 
Click the ‘New User’ button. The New User dialog will open. 
 

 
 

Enter the username Joseph and full name Joseph Jones. In the User group 
dropdown list, please select ‘Machinery only’. 
 
When you have finished entering user information, press the OK button to create the 
user. The Change Password dialog will appear. 
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Enter a password and close the dialog by pressing the OK button. 
 
Start ShipWeight and log on with the new user. Try navigating the work breakdown 
structure to verify that this user only has access to weight group M and its sub 
groups. Also try accessing the Estimation dialog or Options dialog. 
 

 

9 Developing Own Crystal Reports 

A  The Report Creation Wizard 
 
ShipWeight is delivered with a set of sample reports to be used with the Report 
Viewer. In many cases, the easiest way of creating your own report will be to modify 
one of the sample reports. This is especially useful if you just want to do minor 
changes such as inserting your company logo or change the formatting of a report. 
 
In this session, we will create a new report from scratch using the ‘Report Creation 
Wizard’. 
 
To start the wizard, you need to press the ‘New Report’ button on the toolbar: 
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Now, the ‘Report Creation Wizard’ will appear. This wizard will guide you through the 
process of creating a report. 
 
The first step is to choose the data you want to report on. Basically, this means 
choosing the database and tables to use in the report. 
 
The Data window of the wizard contains a list of ‘Available Data Sources’ on the left 
side, and ‘Selected Tables’ on the right side. 
 
In the list of ‘Available Data Sources’, you first expand the branch named ‘Create 
New Connection’. This is done either by clicking the small plus sign or by double 
clicking it with the mouse. 
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Next, you should expand the ‘OLE DB (ADO)’ branch. A new dialog-window titled 
OLE DB (ADO) will appear. This window is used to set up the connection to the 
database. 
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In the ‘Provider’- list, you should select ‘Microsoft OLE DB Provider for SQL Server’. 
Click the ‘Next’ button to continue. 
 
Now you will be asked to provide the necessary information to log on to the data 
source. 
 
The first thing you need to do is to check the ‘Integrated Security’ button. When 
‘Integrated security’ is selected, Crystal Reports will connect to the SQL database 
using your Window username and password. Now you will not need to enter the 
‘User ID’ and ‘Password’. 
 
Next, you should enter the name of the SQL server in the ‘Server’ field. Make sure to 
ask your database administrator for the name of the server containing the 
ShipWeight databases. 
 
Now, select one of the available databases from the ‘Database’ dropdown list. 
Databases starting with SW0 are project databases. 
 
For more information on the databases used in ShipWeight, please refer to the 
ShipWeight User’s Guide chapter 7: Introduction to the ShipWeight databases. 
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Press the ‘Finish’ button to close the ‘OLE DB’ window. 
 
Back in the wizard, you will now find the database in the ‘Data Sources’ tree. 
 
Double-click on the database name to expand the branch. Next, expand the ‘dbo’ 
branch. A list of the available tables will appear. 
 
Now you need to drag-and-drop the ‘ITEM’-table to the ‘Selected Tables’ list at the 
right side. 
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Click the ‘Next’ button. 
 
  
The next step of the wizard is to choose the fields to display in the report. 
 
The wizard now shows two lists: ‘Available Fields’ and ‘Fields to Display’. The 
Available Fields list, shows all the fields in the ITEM table. 
 
To include fields in the report, simply drag-and-drop them to the ‘Fields to Display’ 
list. 
 
You can re-arrange the order of the selected fields by simply dragging them to a new 
location in the ‘Fields to Display’-list. 
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When you have selected the data you want in the report, click the ‘Next’-button to 
continue to Grouping. 
  
If you want to group the data in the report, simply drag-and-drop this field from the 
‘Available’-list to the ‘Group By’ list. 
 
In this example we will group on code C01, which is a Section code. 
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Click ‘Next’ to go to the Summaries-part of the Wizard. 
 
To add summary information to the report, simply drag-and-drop the field to the 
‘Summarized Fields’-list. 
 
All numerical fields in the report are automatically added to the ‘Summarized Fields’-
list. 
 
Please note that the default type of summary is Sum. Make sure to change summary 
type for VCG, LCG and TCG from ‘Sum’ to ‘Weighted average with Weight’. 
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When you click the ‘Next’ button, you come to the ‘Group Sorting’. We will not use 
group sorting in this example, so you should click the ‘Next’-button once more to go 
to the Chart-section of the Wizard. 
 
We will include a Pie Chart showing the Weight of each section. Select ‘Pie Chart’. 
Optionally you can change the Chart Title. 
 
Make sure the ‘On change of’ field is set to ‘ITEM.C01’, which is our Section code in 
this example. Also check that ‘Show summary’ is set to ‘Sum of ITEM.Weight’. 
 

 
 
  
Click ‘Next’ to go to ‘Record Selection’. You can use record selection to include only 
a part of the data from the database in the report. 
 
We will not be using record selection in this example. Click ‘Next’ to continue to the 
last item in the wizard: ‘Template’ 
 
Crystal Reports comes with a set of predefined templates. You can use one of these 
to quickly change the look of your report. 
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Click the ‘Finish’-button to exit the Report Creation Wizard. 
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B  Filtering data on ProjectID 
Each project database can contain several projects. The report will now include data 
from all projects on the database. To list data from the current project only, it is 
necessary to insert a filter. 
 
First, we will insert a parameter field to prompt for the current project name. Click 
‘Parameter Fields’ in the Field Explorer with the right mouse button. From the right-
click menu, select ‘New…’ 
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In the ‘Create New parameter’ dialog box, enter ProjectID as the name of the 
parameter. 
 
IMPORTANT:  If you have installed Crystal Reports version XI, you can add a 
dynamic list of ProjectID-values to the parameter. This means that the available 
ProjectIDs will be listed in a dropdown list when the end user is going to select 
ProjectID. This is a new feature of Crystal Reports XI, and is not available for users 
of earlier versions of Crystal Reports.  
 
To add a dynamic list of values to the ProjectID parameter, set ‘List of Values’ to 
Dynamic. You then press the Insert button, and select ProjectID from the dropdown 
list. In the Parameters column, click on the text ‘Click to create parameter’. The text 
will change to ProjectID. 
 
Click the OK button to close the ‘Create New Parameter’ dialog window. 
 
Now we are ready to create the data filter. This is done by creating a Record 
Selection formula. Choose ‘Selection Formulas’ and then ‘Record…’  on the Report 
menu. 
 
In the Report Fields list of the Formula editor, expand the database and the item 
table. Select the database field ProjectID with the mouse, and drag it into the formula 
text window. 
 

 
 
In the formula text window, type the sign of equality after the text {ITEM.ProjectID}.  
 
Select the parameter named ProjectID (marked with a question mark icon in the list) 
in the ‘Report Fields’ branch. Drag and drop it to the formula text window. 
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The selection formula should look like this: 
 
{ITEM.ProjectID}={?ProjectID} 
 
Press the ‘Save and close’ button. The report data will now be filtered to include the 
selected ProjectID only. 
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C  Formatting a report 
 

 
 
 
The preview shows that the report needs some formatting. 
 
Some of the fields are too short to display the number. The easiest way to fix this is 
to click on the field in the preview area and expand it using the mouse. 
 
The group summary fields are in the wrong position. Drag and drop them into place. 
 
To switch between preview and design mode, simply push the tab in the top left 
corner of the preview/design area. 
 
  

D  Displaying data in US-units 
 
Next, we want to display the data in US-units. In the database, all data are stored in 
metric units.  
 
Since the database does not contain any data in US-units, you need to create a 
formula to convert the value from metric to US units. 
 



 

ShipWeight  Tutorial                     

 

 

2011 BAS engineering AS      72 

 
 
 
To create a new formula, you can right-click the ‘Formula Fields’ in the ‘Field 
Explorer’. Select ‘New…’ 
 
Enter the name of the formula: ‘US Weight’. 
 
Now the Formula Editor will appear. 
 
In the Formula editor, you will find a list of the available fields. Expand the branch 
‘Report Fields’. Drag-and-drop the field ‘ITEM.Weight’ into the formula editor. 
 
Finish the formula by entering the multiplication sign (asterisk) and the conversion 
factor. The formula to convert from kg to lb should be: 
 
{ITEM.Weight} * 2.20462262184877 
 
Press the ‘Save and close’-button on the toolbar. 
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Back in the main window of Crystal Reports, you will find the new formula under 
‘Formula fields’ in the ‘Field Explorer’. 
 
Before you insert the ‘US Weight’ field, you need to delete the original weight field 
from the report. Simply select the field in the design view, and press the ‘Delete’ 
button. 
 
Now, you need to drag-and-drop the ‘US Weight’ formula into the Details section of 
the report. 
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Finally, you must change the summary fields to summarize the ‘US Weight’ formula 
instead of the ‘Weight’ database-field. 
 
To do this, select the Group Summary field in the design view, and click on it with the 
right mouse button. Select ‘Edit Summary’ from the dropdown menu. 
 

 
 
 
The ‘Edit Summary’-window pops up. Select ‘US Weight’ in the ‘Choose the field to 
summarize’ listbox. Click OK to close the window. Repeat this for the Report 
Summary. 
 

 
 
The report now shows the weight in pounds instead of kilograms. 
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E  Summarizing a Code-field 
 
In the project we have used, Code C03 is the Vertical Moment. We would like to 
summarize the moments. 
 
Crystal Reports can only summarize numerical fields. And since ShipWeight stores 
the code values as strings, you can not summarize code values directly. 
 
The solution is to create a formula that converts the string C03 into a numerical 
value. 
 
Create a new formula named ‘VMom’. In the Formula Editor drag-and-drop the field 
ITEM.C03 into the editor. 
 
To convert a string to a number, you need to use a Crystal-Reports function named 
TONUMBER(). The formula should look like this: 
 
tonumber({ITEM.C03}) 
 

 
 
 
Now, the formula ‘VMom’ is available in the ‘Field Explorer’. 
 
In the design area, select and delete the field ‘C03’. Then drag the formula ‘VMom’ 
into the report. 
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To insert a summary of the Vertical Moment, choose ‘Insert Summary’ from the 
‘Insert’ menu. 
 
Now the ‘Insert Summary’ dialog will appear. First, select ‘VMom’ in the ‘Choose the 
field to summarize’ list box. 
 
Then make sure the ‘Calculate this summary’ option is set to ‘Sum’. 
 
Finally, set ‘Summary Location’ to ‘Grand Total (Report Footer)’ 
 

 
 
 
In the same way, insert a Group summary. Hint: in the ‘Insert Summary’ window, you 
will need to set the ‘Summary location’ to ‘Group #1: ITEM.C01 – A’ 
 
Now, you successfully have inserted a summary of code values into your report. 
Click the Preview-tab to see the result. 
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