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1. Creating a new project 

Double-click the ShipWeight icon from your desktop to launch the program. 

The first thing that pops up is the Login dialog: 

 

 
Make sure to select Windows Authentification method and the (local) SQL Server. 

The User Name is not your Windows user name, but is your ShipWeight user name. 

Fill in also the corresponding Password.  

For System select ShipWeight, which will determine the main SWBS structure that 

the software will open. 

Open Last Project check box should not be checked. 

Click OK button to launch ShipWeight. 
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ShipWeight window will open, with no project loaded: 

 
To start a new project: 

- go to the Project menu and select New or  

- go to the toolbar and click the new button  

 
The Project info dialog pops up: 
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There is two mandatory fields in the Project info dialog that needs to be filled out: 

• The project Database ID* is the place where to store the new project, so you 

can select an already existing database from the dropdown list or type in a 

new database id. For this tutorial, please select ProjectDB  

 
• The Project ID* is the id of your project, and the user can type anything as 

long as it is unique. For this tutorial, please type Tutorial 

 
 

Name field: MS Breeze 

Main Type field: select Offshore Vessel from the dropdown list 

Type field: select Anchor Handling Tug from the dropdown list 

The Frame Spacing field: is a bit important because this will allow to include frame 

spacing in the input and use frame spacing instead of position, when the user enters 

the position for location of an item in the X direction.  

Example:  - for frame spacing of 0.65 meters, simply type 0.65# 

                 - for dynamic frame spacing, type for example 0.65#25;0.7#90;0.6# 

                    The tooltip here will show an example of the coding for this dynamic   

                    frame spacing:  

                    
 

For more information, press the F1 keyboard button, which will launch the Context-

sensitive Help File: 
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Units field: keep the Metric units 
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Click OK and the new project will start.  

 
Now, the user will be asked to choose the main weight group for the the new project. 

In this case keep the DISP Displacement selection and then press OK.  

The next dialog that pops up is the Parameters dialog: 

 
 

Expand the window and enter the main parameters that are currently available for 

the project: 
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Notice that some of the parameters have a green icon to the right of the Value cell. 

For example the Block-coefficient. If the user knows the block-coefficient value, he 

can just type in directly. 

 If the block-coefficient is unkown, the green icon will open the Composite 

Parameter dialog, which will allow the user to enter other parameters to help 

calculate the block-coefficient value. Input 7700 for Displacement [t] field, and then 

let the rest of the parameters as they are. The Block-coefficient will instantly be 

calculated: 
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Press the Close button. 

 

 
Now click OK to close this dialog. 
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The Project Info can be found on the top right side of ShipWeight window and the 

Parameters info on the lower right side. The information can be changed anytime 

when working with the project, by clicking on the Project Info and on the 

Parameters headers. 
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2. Project Administration  

The first thing is to start again ShipWeight and login: 

 
to open up the main window: 

 
Right now ShipWeight opens without any project loaded into the main window. 
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So, to load a project into the main window you can either open a project from the 

menu, going on Project -> Open or you can go to the toolbar and find the Open 

Project button . Either way you choose, the Open Project dialog will pop up: 

 

The upper part shows the name of the Server, which usually stays the same, you 

rarely change the server name. 

The next part will show the Database, the project databases that are on your server. 

You need to have at least one project Database. Each project database can contain 

any number of projects. 

Now click on the lower part of the project Database, for example click on 

SW00_ProjectDB. You will see in the lower part of the Project ID all the existing 

projects from the selected Database: 

  



14 
 

Now, select from the Project ID list the Tutorial project and then click OK to open 

up this project, and then after few seconds the project is loaded into ShipWeight: 

 

To make a copy of this project, go to Project menu, then select Save As… 

Choose the Database you want to save it in (ProjectDB) and then type the Project ID 

to be used for the copy of the existing project: 

 

Now hit the OK button and a copy of Tutorial project is stored as Tutorial_Rev1. 
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 To get back to Tutorial project, you can open it from the Open dialog, but also on 

the project menu there are some shortcuts that shows the last four projects: 

 

So this is how you can open and save projects on ShipWeight. 

To delete a project, navigate to Project menu, select Delete, then Delete Project: 
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The Delete project… dialog will appear, which contains the same, the Server, 

Database and Project ID. 

 

Now select the Database SW00_ProjectDB, and the Project ID Tutorial_Rev1: 

 

And then click OK to delete it. 

Now, when you go to open a project, you may find that some of the project Database 

can contain a lot of Project, as in the following database (SW00_DB_Space): 
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The list below here will get very long and tedious to select from. In this case you 

may organise your project in a hierarchy, by clicking the button to the right  

This opens up the Project Browse dialog: 

 

Here you can see again your project Databases and the projects id within each of 

your project databases. 
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This dialog allows you now to create some folders, by right click on 

SW00_DB_Space: 

 

Let’s create one folder, type in the name for the folder and then drag and drop your 

appropriate projects into the new folder to organize them better, as in the following 

example: 
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Another important part in the Project Administration is in the Options dialog. The 

Options dialog has important settings for each of the projects. 

To open the Options dialog go into the View menu, and select Options… 

 

This will bring up a dialog that has many tabs, and in each tab you can set various 

options: 
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For example the first tab is General, where you can select: 

• the Units in Metric or US 

• The Weight Unit 

• Whether it should summarize at startup etc. 

 

The next tab is the Decimals settings, for the weight groups in the main window and 

for the detailed items in the Item dialog: 
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Next you have names for Quantity and default settings for Quantities when a new 

row is added: 

 

For more details about this settings hit the F1 key to bring up the context sensitive 

help, which will show you explanations for various tabs of the Options dialog: 
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Finally, in the Project Administration chapter, we will see how to navigate in the 

work breakdown structure.  

The main area of the main window shows the work breakdown structure as a 

hierarchy and you can navigate in it just like you navigate in windows explorer, by 

exploding and colapsing nodes: 

 

To the right of the main window, we have Project information, Parameters and 

Codes. These extra information can be hidden by using the  button. 
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3. Getting data into ShipWeight  

3.1 Code Definition Basic  

To open the Code Definition dialog, select Code definition… on the View menu 
of ShipWeight dialog.  

 
 
The Code Definition dialog contains a tree-view on the left side, and a table on the 
right side. It allows the user to define his own fields in ShipWeight. 

 

Define Drawing number code  

To create a code, select the cell in the column “CodeType” of the table. The cell 
will become activated and editable. A new row automatically will be added, and 
the cell will turn into a combo box (editable dropdown list). Next, activate the 
dropdown of the combo box and select the ID of the custom code you want to 
make e.g. C01. 
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Next, fill in the following fields: 

 
Field               Value                         Description                                                         

Title                Drawing no.               Title will show above field in Item dlg.  

Description     Drawing number        Information only, no effect  

FieldSize         20                               Number of characters allowed in field  

Calculate         (leave empty)             Formula for calculated codes (Leave empty)  

Align               Right                          Alignment of value in Item dlg.  

Format            (leave empty)              Formatting of calculated fields (Leave empty)  

FieldType        EditBox                      Specify a standard editable field  

 

To finish off the registration of code C01, click with the mouse on the empty line in 

the table. You can make sure that the code has been registered by checking that it is 

added to the tree left of the grid. Click the minus/plus sign to (un)expand the tree. 
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The FieldType in this case is EditBox. This means that the custom code field will be 

an editable box where the user may type in freely.  

The other Fieldtypes are:  

• ListBox – the user must select value for the field from a dropdown list of 

predefined values  

• ComboBox – the user may select value for the field from a dropdown list of 

predefined values or type in freely  

• ReadOnly – the value cannot be changed by the user 
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Define Weight status code 

In the same way, add the code C02 with the following values:  

Field                   Value                                                                             

Title                    Weight Status  

Description         Weight Status Code  

FieldSize             20  

Calculate             (leave empty)  

Align                   Left 

Format                (leave empty)  

FieldType            ListBox  

 
Next, we will add code values to the Weight Status code. In the tree-view, select 

code ‘C02 – Weight Status’. An empty table for adding code values will appear on 

the right side of the tree-view. 

 
 

Select the row of the table and fill in these values:  
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Field                             Value                                                                             

CodeID                         E  
Description                   Estimated  
Factor                           1.1  
 
Leave the rest of the fields empty, and click on the next row in the table. Enter two 

more code values:  

 
Field                             Value                                                                             

CodeID                         C  
Description                   Calculated  
Factor                           1.05  
 
Field                             Value                                                                             

CodeID                         W  
Description                   Weighed  
Factor                            1.02  
 
Finish off registering the code value by clicking the last row in the table with the 

mouse. 

 



28 
 

Define Weight with margin code 

Next, click the topmost asterisk in the tree-view to display the Code Definition table. 

Add code C03 with the following values:  

 
Field                           Value                                                                             

CodeType                   C03  

Title                            Weight with Margin  

Description                 Weight multiplied with margin based on Weight Status code  

FieldSize                     20  

Calculate                     [Weight]*[C02].[Factor]  

Align                           Right  

Format                         %.3f  

FieldType                    ReadOnly  

 
Click the empty row of the table to finish off the registration of C03.  
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Hit F1 button to bring up the Help file for Code definition dialog: 

 
 
In the Help file, select the Calculated Codes to find all the options to use for the 

calculated fields and how to set the calculations: 
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Finally, close the Code Definition dialog. 

 
Now open the Items Dialog, in ShipWeight main window select Items and choose 

List Itels -> All… 

Alternatively, press the ‘Item level’ button on the toolbar:  

The Items dialog now opens in default mode. In the Items view, it can be noticed all 

of the added codes: 

 
The Code Definition dialog can be reopened anytime from Items dialog, View menu 

-> Code Definition. 

 

In the Item Settings dialog the user will have the possibility to take these codes and 

move them to different positions of the Items view, and learn how to generalize and 

customize this view. 
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3.2 Item Setting dialog  

Back in the Items dialog, select Item settings… in the Setting menu to display the 

Item setting dialog. Alternatively, press the Item setting… button on the toolbar. The 

Item setting dialog controls the layout of the Item dialog. 

 
 

After the Item Setting dialog pops up, to start creating a new setting, press the New 

Setting button. This will generate the starting point for the new setting. 

 

In the tree-view on the left side, click the plus sign next to the asterisk to expand the 

tree. A setting named ‘New setting’ has been created. Your dialog should then look 

like this: 
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Make sure the topmost asterisk is selected in the tree. Click the ‘New setting’ cell in 

the SettingID column of the table. Change the Setting ID from ‘New setting’ to e.g. 

‘Default Setting’: 
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Next, expand the tree further by clicking the plus sign in front of ‘Default Setting’, 

‘Single view’, ‘Weight & CoG’ and ‘Codes’. Select ‘C02’ in the ‘Codes’ branch of 

the tree: 

 
 
Using the mouse, drag ‘C02’ from the ‘Codes’ group and drop it on Weight in the 

‘Weight & CoG’ group. C02 will now be placed directly after the Weight field in 

the Single Record area of the Item dialog: 
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Now go to Table view.  

 
Expand the ‘Table View’ branch by clicking the plus sign in front of it, and then the 

‘Weight & CoG’ branch. Select ‘TCG_min’ with the mouse. Drag and drop it in the 

‘Hidden’ group. Repeat this for TCG_max. 

The TCG_min and TCG_max fields will now be hidden in the Table View area of 

the Item dialog. 

 

 
 

 
To activate the new setting ‘Default Setting’, close the Item Setting window, and 

then select ‘Default Setting’ from the ‘Setting’ dropdown list on the toolbar: 
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Now, the Item dialog should look like this: 
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Based on the changes made in the Item Settings dialog, now it can be noticed that 

C02 code (Weight Status), is located in the Single View: Weight & CoG: 

 
 

To change the width of items in the Single View, open the Item Settings dialog, go 

to Single view, then Codes, and click on C01-Drawing no.  
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Now change the standard C01 code Width from 100 to 300: 

 
The result will be: 

 
As long as the Item Setting ‘Default Setting’ is selected in the drop list, any changes 

that the user will do to the ‘Item Setting’ dialog will automatically be applied to the 

‘Items’ dialog. 
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3.3 The Items dialog  
There are three ways to open the item dialog: 

• Select Items and choose List Items -> All 

 
• Alternatively, press the ‘Item level’ button on the toolbar:  

 
• Or select Items header on this preview window: 
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Choose one of the specified options to open the Items dialog: 

 
It is very important to know the link between the selected weight group in the main 

window and the actual item dialog that pops up. 

When the Items dialog was opened, the focus was on the SWBS group H – Hull, and 

this means that H is now opened in the item dialog. In the weight group filter we can 

see H: 

 
To close the Items dialog press the Close dialog icon . 
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3.4 Entering data in Items dialog 
 
Open the Items dialog for weight group H1.1 Aftbody. 

In the ShipWeight main dialog window, navigate to weight group H1.1 Aftbody and 

open the Item dialog. 

 

 
 

Add weight item ‘Section 1’ using the ‘Single Record’ area  

To register a new item weight using the Single Record area of the Item dialog, you 

must start by selecting Weight Group H1.1 from the WgtGrp dropdown list. 
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Jump to the ItemNo field by pressing the TAB button. Enter Item number 1. When 

pressing TAB once more, the item will be created. Continue filling in data for the 

weight item.  

 
Data for Section 1, H1.1 Aftbody:  

 
Field                           Value                                                                             

WgtGrp:                     H1.1  
ItemNo:                      1  
Description:               Section 1  
NoOff:                        1.000  
Factor:                        1.000  
Length:                       1.000  
Width:                        1.000  
UnitWeight:                66000.00  
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Field                           Value                                

Weight Status:            C  
VCG:                          4.300  
LCG:                          -1.250  
TCG:                           0.000  
VCG_min:                  1.500  
VCG_max:                 6.000  
LCG_min:                 -5.000  
LCG_max:                  2.500  
TCG_min:                   0 (hidden field)  
TCG_max:                  0 (hidden field)  
Drawing no.                123-456 
 

 
To complete the registration of the weight item, press the right-arrow on the toolbar, 

or click the empty row in the table. 
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 Add weight item ‘Section 2’ using the ‘Table’ area  

Select the empty row in the table and double click the WgtGrp cell. WgtGrp will 

now be set to H1.1. Click the TAB-key to jump to the next column. Continue 

entering item data for ‘Section 2’. 

 
 
Data for Section 2, H1.1 Aftbody: 

 
Field                           Value                                

 

WgtGrp:                     H1.1  
ItemNo:                      2  
Description:               Section 2  
NoOff:                        1  
Factor:                        1  



44 
 

Length:                       1  
Width:                        1  
UnitWeight:                73000  
VCG:                          4.2  
LCG:                           6.25  
TCG:                           0.000  
VCG_min:                  1.5  
VCG_max:                 6.000  
LCG_min:                  2.500  
LCG_max:                  10  
Drawing no.                123-654 
Weight Status:            C  
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3.5 Import Data File 

In this tutorial we will import weight data from an Excel workbook. This can be 
done using the ‘ShipWeight Data File Import (EasyImport)’-dialog.  

To follow this tutorial, please open an appropriate project or create a new project. 
If you have just completed the previous chapters, you are set. Otherwise, please 
refer to chapter 1 for details on creating a new project.  

The Data File Import dialog (menu: Project -> Import -> Data file….) has an extra 
layer called EasyImport which is designed to provide a wizard-like user interface 
to guide the user through setting up and carry out the import step by step. 

 

 
 

First we browse and select the spreadsheet file. On the ‘Assistant’ tab-sheet, we 
press the Browse button. Using the ‘Open dialog window, we locate the Excel file 
to import. Press the Open button to select the file “Tutorial.xls”. 
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The Data File Import Dialog supports the import of XLSX files in addition to XLS 

files. Once the Excel File has been selected, a preview of the sheet included in the 

file will be shown. Then, the next step is to select the sheet to import. 
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When the sheet is selected, the import dialog will try to guess the mapping between 

the columns in the spreadsheet and ShipWeight fields, based on the column headings 

in the spreadsheet. 

 
Columns where mapping have been found automatically will get a green colour and 

the mapping will be shown in the list below. If this mapping is wrong, you can 

deselect the column either in the sheet preview or in this list of linked columns.  

To manually add columns not automatically mapped, click on the column either in 

the preview sheet or in the column list and select the corresponding ShipWeight field 

from the ShipWeight list.  

An import can be run directly from the ‘Import’ tabsheet (either to main database or 

to Playground area), or the mappings and settings can be transferred to the normal 

data file import for more advanced settings and checking. 
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This import definition list may be saved (click “Save” button in the dialog) and 

restored by clicking from the “Open” button later. 

Before we start importing data, we must set the import options. Click the ‘Options’ 

tab sheet. First we will keep the option ‘Auto ItemNo start’. The reason for this is 

that our spreadsheet doesn’t contain a column for item numbers.  

Please note that the import will fail if you try to import data with item numbers 

already in use in the database. If this is the case, please try to increase the number in 

the ‘Auto ItemNo start’ field.  

The ‘Pad ItemNo’ button will change the format of the item number of existing 

items. First set the number of characters the item number should include. Pressing 

the ‘‘Pad ItemNo’ button will add the digit 0 in front of the item number, so that the 

item number includes the proper number of characters. Please note that the option 
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‘Number of header rows’ is disabled. The ‘ShipWeight Data File Import’ always 

assumes that the spreadsheet contains one header row. 

 
Now when the settings are ready we can choose either to Import or Test it. 

To test the import, first we go to the ‘Log and Test’ tab sheet: 
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Select ‘Test SWI’ button to see if there are any errors detected in the import 

definition file. As we can see, right now there is no errors: 

 
Then, we can also select the ‘Check import’ button, to perform the import without 

actually importing it. Now it runs throught the import and it will show you a small 

report, that the import is completed: 
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Now we are ready to start importing data. Make sure that the spreadsheet you are 
going to import is not open in Excel. 
 

 

In the Import complete dialog press OK button. Then press Close button in the 

Import dialog. The Update Information dialog will appear, asking you to 

‘Summarize wgt.grp.’ in the ‘Wgt.Grp’ menu.  

 

Click OK. 

Now, in the main dialog window of ShipWeight, go to Weight Groups menu and 

select ‘Summarize Wgt.grp’: 
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3.6 Sort, Filter, and MultiEdit 
 
Create a filter to display weight items with VCG > 4 m. 

In the tree-view on the main dialog, navigate to weight group E2.2 under LW – 

Lightship -> E – Equipment -> E2 – Ship equipment, and open the item dialog.  

Press the ‘Apply filter’ button on the toolbar, or select Tools -> Filter -> Apply… 

on the Tools menu. The Item Filter dialog will pop up.  

 

In the ‘Table Fields’ list, select VCG. Select the ‘>’ operator from the ‘Operators’ 

list. Set the ‘Value’ to 4, and press the Insert button.  
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Press OK to apply the filter. Now, 5 items which have VCG’s larger than 4.0 meters 

will be listed.  

 

To remove the filter, select Tools -> Filter -> Clear, or press the ‘Clear Filter’ button.  
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Sort the weight items on Description and Weight  

To open the Sort dialog, select Sort -> Apply… on the Tools menu, or press the 

‘Sort’ button on the toolbar.  

 

Click the ‘Field Name’ cell of the empty row. The cell will change to a combo box. 

Activate the dropdown list, and select Description. 

 

Click the ‘Sort’ cell. By default, the value will be set to ‘Ascending’.  

On the next row, select Field Name: Weight. 

Data Type: Ascending  

 
Press the OK button to apply the Sort.  
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4. Weight Monitoring and Reporting 

4.1 Standard reports 
 
From the Project menu, select Report setup. Select:  

Weight Groups      Defined  

Parameter sort       Unit  

Wgt.grp.                Sum  

Code type              C01 – Drawing no 

 

Click OK to close the dialog. 

Select Reports and 4 Weight and CoG wgt.grp. summary on the Project menu. The 

following dialog will open – just press OK 
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The report will then be opened in the Print Preview dialog. In the Print Preview 

dialog, press the MS Word button to export the report. Close the Preview window. 
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4.2 Crystal reports 

Start ShipWeight Report by selecting Crystal Reports… on the Project menu of 

ShipWeight. 

 

The first thing to do is to select the report you want to run. In this example we will 

use the report Three-digit sample.rpt. Locate the report file on your hard drive by 

pressing the Browse button to open the Open dialog window.  

When you have located and selected the file Three-digit sample.rpt, press open. Now 

the file name will show in the Select report field.  

Next, press the ‘Run report’ button. 
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In the “Enter project ID” dialog that now pops up, select “Tutorial” from the 

dropdown list and click “OK”. 

 

The report should now be displayed after a few seconds. 
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Now, use the toolbar or the group tree to navigate through the report. Also try 

exporting the report to portable document format (PDF), Word or Excel.  
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5. Weight Estimation 

5.1 Preparing an estimate 

Starting a new project  

Start a new project using the following Project info: 

  
Press OK. 

 
Press again OK. 
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Fill in the following values for Parameters dialog: 

 
 

 
Select historical Demo database  

To be able to follow the tutorial, the historical database must be switched to demo 

mode. To do this, follow these steps:  

Select “Options...” from the “View” menu and select the “Database” tab. Next, select 

the browse button [...] 
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and select the historical database sdb_Demo: 

 
 

Click OK to save and close the options dialog. 
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Ship types  

Open the Ship types dialog by selecting Project Types… on the Estimate menu.  

 
 

The Project Types… dialog opens. 

Expand the ‘6 Offshore Vessel’ branch by clicking it’s + sign. Select e.g. ‘600 
Supply Vessel’ and click the ‘Include all’ button. 
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Now, historical data from ships of type ‘Offshore vessel’ will be included in the 

graph when estimating weight and centre of gravity. The vessels mentioned here 

might have been selected by default. Select OK. 

Reference Ships  

On the Estimate menu, select Reference Projects… to make sure that all projects are 

included as reference projects.  

 
The vessels should have a green R to the left of the ship ID to be included. If there 

are no green Rs, click Include All button. 

 
Click OK. 
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5.2 Estimating lightship weight 

Navigate to the lightship weight group LW - Lightship in the main window. In the 
Estimate menu, select Weight or click the  Estimate weight button on the 
toolbar. The Estimation dialog appears. 

 
This dialog has three main areas:  

The Graph area itself which plots historical data. Each point represents a historical 
reference shi, and each point represents the relationship between the weight and 
parameters of the method. 
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In this case we are at the Lightship level, and the estimation formula can be seen in 

the Parameter area: 

 
This method has been reversed plotting all historical coefficients, the coefficint value 

k on the Y axis and plot parameter LBDu on the X axis, indicating our plot value 

LBDu number or cubic number by the vertical line (circled in blue color) from the 

graph and our currently selected coefficient on the horizontal dotted line (circled in 

red color). 
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In the Reference Projects dialog we had 35 different vessels, and in the estimation 

dialog there are only 12 reference ships showing. 

This brings us to the Comparison area with Filters, which can be seen below the 

Graph area: 

 
The Comparison area, contains the comparison parameters and filters that belongs 

to the Lightship weight. 

By default there is one filter that is automatically set, and that is the Project Type 

filter, as you can see that is enabled when the check box is checked: 

 
And this is why there are displayed only 12 ships in the Graph area. 
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By default, ShipWeight will always filter on the same main type as the vessel that is 

curently estimated. So now we are estimating an Offshore vessel and thus it shows 

all offshore vessels. 

To change this, just click on the link of the filter parameter “Offshore Vessel…” and 

this brings up the Project Types dialog, and if we wanted to include the Tanker as 

well, just click on Tanker and then press Include button: 

 
Then click OK.  

 
Now in the Graph area, there are 19 reference ships, the tankers are down near the 

X axis and the offshores are up near the Y axis. We can clearly see that at this level 

it doesn’t make much sense, to include both Offshore vessels and Tanker vessels in 

the same graph at this weight group. 

That being said it can make perfectly sense in other weight groups, further down in 

the hierarchy to mix different vessel types. 
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So, let’s exclude our Tanker vessels again, and to know that these are the right 

Tankers, just go to Graph menu, and select Labels: 

 



72 
 

Now we can see the labels in the Graph area and know which the Tanker ships are 

and which are the Offshore vessels: 

 

Let’s go back to Project Types dialog and exclude again the Tanker vessels, by 

clicking on Tanker, then select Exclude button and press OK: 
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And now we are left only with the 12 offshore vessels: 

 

The next step would be to make sure that the 12 offshore vessels are relevant all of 

them for the estimation. The easiest way is to click on the points in the graph, let’s 

say to check FA006, FA011 and FA005.  
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We can see they got circles and numbers, and we can find them in the lower right 

area of the Estimation window. The parameters values for the selected vessels are 

now visible and we can compare them with the parameters values of the vessel we 

are currently estimating. 

Tipically, we will look at points that are far from the trendline, such as vessel numer 

(3) FA005, we can notice that the Length betw. perp. parameter for the vessel 

cureently estimated is around 70 m, same with vessel number 1 and 2, but vessel 

number 3 is only 59.7 m. This may lead to conclude that this ocefficient is a bit off 

the trendline, because it is very short vessel and maybe it is not good to include too 

short vessels.  

 

So, to exclude vessels that are not in the right range, the easy way is to right click on 

the point from the graph and just select Exclude Project: 
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However, it is recommended not doing that, but rather use the Filters, because that 

seems to bring more logical approach how to exclude and include vessels. 

So, instead of doing that, just go down to Length betw. perp. and select the filter 

criteria “0.00-450.00” , which will open the Limits for Comparison Parameter 

dialog: 

 

We can see the maximum is 450 meters and minimum 0 meters, so this needs to be 

changed to maximum 80 meters and minimum 60 meters. 



76 
 

 

Click OK. Now, we can see the new range, 60.00-80.00.  

 

To activate this filter, check the checkbox from this filter. We have in the graph 12 

reference ships, but after we activate the new filter range, we will have only 9 

reference ships: 
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We can also see the trendline looks better fitted: 
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Another way of checking if you have done a good selection of the reference ships, 

is to notice the regression standard deviation Std. dev…, which was 7.2 with the 12 

reference ships included, and now is 4.02 with 9 reference ships included. 

 

 

Selecting the coefficient 

So, now we have a set of relevant ships, a trendline, a plot value and we should now 

select the coefficient from the graph.  

To select the coefficient, it can be done subjectively: 

• select Subjective from the Parameter area: 
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and grab the coefficient tear and move it up and down: 

 
To put it wherever you want to select the Y value: 
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• Or select Regression coefficient, which is the crossing of the trendline and 

the X line. The horizontal coefficient graph should then be moved until it 

intersects with the regression line and the vertical plot parameter line. 

 
 

The r2 value from the Graph area represents the coefficient of determination, 

and is a number that indicates the proportion of the variance in the dependent 

variable that is predictable from the independent variable (s). 

 
There are several definitions of r2 that are only sometimes equivalent. One 

class of such cases includes that of simple linear regression where r2 is used 

instead of R2.  

When an intercept is included, then r2 is simply the square of the 

sample correlation coefficient (i.e., r) between the observed outcomes and 

the observed predictor values. If additional regressors are included, R2 is the 

square of the coefficient of multiple correlation. In both such cases, the 

coefficient of determination ranges from 0 to 1. See in our graph r2= 0.21. 

https://en.wikipedia.org/wiki/Regression_intercept
https://en.wikipedia.org/wiki/Pearson_product-moment_correlation_coefficient
https://en.wikipedia.org/wiki/Regressor
https://en.wikipedia.org/wiki/Coefficient_of_multiple_correlation
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The most general definition of the coefficient of determination is: 

 

 
More information about r2 coefficient of determination can be found here: 

https://en.wikipedia.org/wiki/Coefficient_of_determination  

 

• The Default coefficient is a static one, which can be saved. 

 

https://en.wikipedia.org/wiki/Coefficient_of_determination
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• If you define a Sister project (ship), you can do a coefficient by scaling on 

one vessel. 

• Adj. sister ship means moving the trendline through one of the sister ship, 

but still using the trendline to find the coefficient. 

• Factor is the average coefficient.  

 

In this case we have a clear trendline, so the right coefficient to be used is 

Regression. So, select this back: 

 

And Save . 

Move the Estimation dialog a little bit away, so that it can be seen in the ShipWeight 

main window the first estimation of the Lightship: 3998 tones, saved into the weight 

group hierarchy 
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Now move on, doing estimation for the LCG and VCG. 

In the Estimation dialog, go to the Estimate menu, and switch from Weight to LCG 

first. 

The calculation method now is the historical coefficient k * the Lpp: 
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In other words, we look at the historical relation between LCG and Lpp, again this 

relationships by the k factor plotted in the graph. We can go in and investigate: 

Click on FA005 and FA008, making sure we have relevant vessels: 

 
Select the Regression coefficient and Save: 
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Now, we can go and Estimate the VCG. Select from the Estimate menu, VCG: 

 
Select Regression coefficient from Parameter area and FA009 from the graph: 
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Save, and then close the Estimation dialog.  

The first estimation of Weight and Center of Gravity can be seen in ShipWeight 

main window: 

 
Oviously, we want to do more detailed estimation, so we now want to go down to 

Equipment, Hull and Machinery groups.  

 

Select Equipment and now we should estimate this group: 
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Since, ShipWeight is by default doing a calculation that goes bottom-up, we should 

take some care, because if we now estimate de Equipment weight group, it’s going 

to start summarize the Equipment, Hull and Machinery, and remove the initial 

Lightship estimation, and give the sum of whatever has estimated down here. 

To prevent this, go to the toolbar and click on the button with the key, which locks 

the parent group: 

 
 

Now the values from the Lightship will not be lost, but the deviation between the 

summary of the subgroup and the parent group will be automatically kept in the 

Remainder. 

 

So selecting Equipment group, and open up the Parametric Estimation dialog, 

which will give now the window with the Estimation of Equipment weight group: 
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Again, we need to investigate, pick projects in the graph, FA001, FA008, and do the 

filtering. Check the Subjective coefficient: 
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And estimate the Weight by pressing the calculator button: 

 
Then save: 
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And now we can use the arrow button to go to the Next Weight Group, from 

Equipment to Hull: 

 
 

The Hull weight default method it is a little bit complex: 

 
It is the weight W= k*C07*E^1.36 

k: is the coefficient 

C07: is the adjusted block coefficient 

E: is the Watson E-parameter 
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The parameters for the current vessel are displayed on the Parameter area: 

 
 

To enter the Watson E-Parameter, click on the  icon. The Composite Parameter 

dialog will open: 

 
In the last row, we can see the entire formula for the Watson E-Parameter. 

We can see as well, the rest of the parameters that are lacking to be able to calculate 

the Watson E-Parameter, to get the X value for the graph and do an estimation. 

 

Because it is too early in the project to know the values of these parameters, we need 

to change to a different method, so just Close the Composite Parameter dialog. 

Go to the Method menu, select Main Parameter option. Now we can see there is a 

simpler parameter estimation formula: 
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Select Regression coefficient and Save: 

 
Next, click the arrow to move to Machinery weight: 
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For the Machinery weight, select FA002, FA004 reference ships: 
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We can see the FA004 project has very havy machinery 17013 kW, maybe this 

should be filtered out.  

For the Machinery weight group, the weight formula is: 

 
And the comparison parameters have changed. They are attached to the weight group 

and the method. 

Now, let’s do a filter of the main-engine power. Click the link for main-engine 

power, and the Limits for Comparision Parameter dialog will open: 

 
And change Maximum from 100 000 to 15 000, and Minimum from 0 to 8000: 
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Click OK and activate this filter by checking the box to the left of 8000-15000: 
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We are now left with 7 reference ships. In this case, maybe the trendline is not so 

clear. So, it is better to select the Average coefficient and then Save: 

 

Close the Estimation dialog. In ShipWeight main window, now are visible the results 

from the parametric estimation for Equipment, Hull, Machinery. 
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The sum of Equipment, Hull and Machinery is 31 tones less than the initial 

estimation of the Lightship.  

If we think the Equipment, Hull and Machinery estimation is more accurate that the 

Lightship estimation, we can just remove the Remainder and use the sum of these 

weight groups.  

Instead, we can just go and unlock the Lightship, and delete the Remainer group, 

and now we have the sum of the subgroups: 

 

The next step will be to continue, to go into the subgroups of Hull, Equipment and 

Machinery and then start estimating all under: 
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Or we can lock the parent groups again, to keet the parent groups unchanged. 

Finally, at some point you may want to list Items in detail in the subgroup. In that 

case, just select the weight group: 
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And open the Items dialog and read the items from that weight group: 

 

So, it is not a problem to combine line items and parametric estimation. And 

tipically, as the project mature you may eventually exchange all parametric groups 

with line items and also check the deviation between the parametric subgroup to see 

when the list of items is more mature. 
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5.3 Log result  

You can log your work using the Project Comments dialog.  

In the main window, select View -> Comment -> Project Comments…  

 
 

The Comment dialog will open: 
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In the Wgt.grp field select from the listbox LW – Lightship: 

 
 
Then click the Get Wgt.grps… button and the LW information will be displayed 
in the Comment area: 
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And then click the Add to log button to store the initial result: 

 
 
Click the Close button to get back to the main window. 
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5.4 User defined estimation methods 

On the menu Estimate, click Define Methods…  

 
The Method Definition dialog window will show up: 
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The area to the left contains the Default parameters. Select Main Parameter as 
Default. 

The area in the middle contains the work breakdown structure. In this area, use the 
mouse to select the weight group Hull.  

The method for this weight group will be shown in the area to the right.   

 

You want the method for Hull to be W=k*Lpp*B*D and plot the coefficient against 

ship length. Select the estimation parameters and click once more, to reveal a combo 

box. Select – on top of the list to clear the parameter.  

Select the plot parameter and delete it. Leave the comparison parameters as they are. 

Under ESTIMATION, select a "length parameter" (e.g. Length betw. perp) in the 

combo box for No.1. Add breadth and depth parameters in same way (e.g. Ship 

breadth and Depth upperm. cont. deck). Set the Power parameters to be 1, 1 and 1.  
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Under PLOT, select the "length parameter" again in the right area and click ADD 

button. Now you are done, select the OK button.  

To be able to use your own method do the following: Enter the main estimation 

dialog window in the weight group H Hull. From the menu Method select User 

defined. Now your own method will be applied when estimating. 
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6. Basic Additional Features 

6.1 Weight distribution curve 

For this we will use the Tutorial project from 1-4 chapter.  

To get a good distribution curve it is a big advantage if you have the starting point 

and ending point of your weight items. Basically you should have the LCG, and the 

LCG_min, LCG_max values for each item to get a good weight distribution curve. 

 

 

However if there are some items who do not have extensions, default extensions can 

be set to be used for those. To do this go to View menu and select Options: 
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The Options dialog will pop up: 

 

Change the default Extent from 0 to 2 and min. from 0.01 to 0.5 meters: 
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And then click OK. 

Now, to open the weight distribution window go to View menu, and select Weight 

Distribution…: 

 

Or the shortcut from the toolbar . 
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Then the Weight Distribution is opened for the vessel: 

 

By default we are looking at Accurate weight distribution curve type, and to see the 

data behind the curve you can enable the plotting of the Weights option: 
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The center of gravity location for each weight in the database is plotted. The black 

dots represent the steel weights, the green dots for equipment weights, and the red 

dots for machinery weights. 

To check the weight data for any dot, click and hold on the specific dot: 

 

In this way you an check suspicious looking items. If you find some items which are 

not correct, the double click on the point and it will bring up the Items dialog, and 

finds that item for you and allows you to change that item: 
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Now in addition to get this accurate curve, you can also select Stations curve type 

and type in 20 stations curve: 

 

You can also do Individual stations curve type, and by typing the numbers and 

points 0;20;30 where you want to see the various stations: 
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You can also right click and select Create SAWE stations: 

 

Which will be default give 20 stations between AP and FP and then 1 station in front 

of FP and 1 station behind the AP: 
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In addition, there is also the Item Filter, can be opened from the Item filter   

browse button in the lower left corner of the Weight distribution window: 

 

And you can set any filter you want, WgtGrp, ItemNo, Description, etc.  

If everything looks ok with the curve, you can go and export the weight distribution 

curve by using the Print/Export button: 
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The Print/Export Distribution Setup dialog pops up and you can select the desired 

Format to get formats that are suitable for import to this stability software for doing 

longitudinal strength calculations: 

 

Finally, the user should know that not only the longitudinal extent (X-Z dir.), but 

also other directions to look at the curve are available. For example in the Y-Z 

direction, go to the tab sheet Y-Z dir., and it will show the distribution curve over 

the beam of the vessel: 
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6.2 Compare dialog 

The Compare dialog allows the user to compare his current project with any other 
project in ShipWeight. To open the Compare window go to View menu, and select 
Compare… 

 
This will bring up the Compare dialog with the aditional features: 
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Now we can see the values for our project as Displacement, Lightship and so forth. 

To add a project, right click in the Project area and select Set Project Database…: 

 

The Open SQL project dialog will appear: 

 

Now select SW00_DB_Space database, and for example TestSpace Space_test 

Project ID: 
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Then we get the new project added in the Project list: 

 

We can also give a Label, for example Estimate: 
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Now we can see the values for the current project compared to the values from the 

selected project, and the deviation as well: 

 

Now we are looking for the Absolute deviation. But we can also look at the Relative 

Deviation: 

 

And the View can be Grid or Tree view: 
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We are comparing now only with one project, but more projects can be added 

anytime into this dialog for comparison. 
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6.3 Gyradius Calculations dialog 

It can be opened from the View menu, and then select Gyradius… 

 

This brings up calculation for gyradius and moment of inertia for the vessel: 
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Here we can apply Item filters: 

 

 

 

Now it is calculating Moment of Inertia and Gyradius values for Roll, Pitch, Yaw, 

and also for the product of inertia Pitch/Yaw, Roll/Yaw, Roll/Pitch: 
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Here you can find details for each individual item: 

 

The way ShipWeight is calculating: 

The Moment of Inertia by taking the Transverse inertia using the Steiner’s theorem 

or paralel axis theory and that it’s done for all items. If there is an item that has 

extents in all three directions then the item will be approximated to a box and also 

calculate the local inertia for that particular item. 

It is also possible to point to custom codes which can have exact values for the 

moment of inertia stored in the custome codes if you can get such values from the 

CAD software. 
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Finally, if the GM values for transverse and longitudinal are known from the stability 

software. So let’s type in some values: 

 
Also based on this we can calculate the Oscilation period (T): 
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6.4 Find identical items… 

Open the Items dialog. Go to Tools menu, select Find and then Identical Items… 

 
This brings up the Find Items dialog: 
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We can find here identical items based on the way we define them. So, for example 
let’s say we want to check items with the same Description. Then click on 
Description in the Compare Field area: 

  
And push the Query -> button: 
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Then in the upper right dialog information is provided: 

 The first column is the Count, the findings 
 And the second column is the Description  

 

 
 
In other words, it finds two places where it says “D door D-dk.” description, and 
three places where it says “A door D-dk.” Description, and so forth. 
To have a look at this, click on the first row 2 A door D-dk. and down in the lower 
right corner it will show all the detailed information about the items that’s been 
described as “A door D-dk.”  
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To check items with the same Weight in the same Weight Group, check the boxes 

from Weight and WgtGrp from Compare Field area, and then press Query 

button: 

 
The result will be displayed in the upper right corner. So, for example in weight 

group E3.7.1 there are two instances where the items have the same weight “30”: 

 
 

If we click on VCG, LCG and TCG and then press Query button, it will give items 

in the database that have the eaxct center of gravity location: 
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So there are two items located at VCG 8.5, LCG -2, and TCG 6.1. So click on this 

line and it will bring up those two items: 
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7. Setting up the Playground Area 

Step1: Create (or select existing) code definition to be used for grouping items 
in worksets! 

To set up a succesful playground area first we have to select a custom code that will 
work as our work packages or that will group the items that we need to check in and 
out of the playground area. 

Go to the View menu and select Code Definition…  

 
The Code Definition window will open: 
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Within the code definition dialog we could have selected any of the existing codes 
to be used as our playground area codes: 

 
or we can define our own code, specific playground area code: 

 
Now we need to add few subcodes for the work package so that we can use to group 
items to check them in and out of the playground area. Select the new code C04 – 
Work Package: 
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And add the following subcodes: 

 
So, basically we have the code to groups the items that need to be checked in and 

out of the playground area. 

In principle, any code may work as a workset code (drawing number, CAD 

package, department number, etc…) 

Now Close the Code Definition dialog.  

Step 2: Enable the “Playground” in the Option dialog 

Go to the View menu and select Options… 
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The Options dialog will pop up: 

 
Now, enable the workset, by checking the Use Worksets box, and select C04 – Work 

Package code: 

 
Below there are some Comment Labels which can be freely edited. 
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Step 3: Define margins! 

Finally, in the Options dialog are the margins, in the lower right corner. These 

margins can be set and defined in the Margins dialog. To open the Margins dialog, 

press the browse button: 

  
The margins dialog pops up: 
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Define the following margins: 

 
Click Close. 

So, now we have defined the Workset to start working with the Playground: 

 
 



135 
 

Step 4: Choose a background color for the Playground item dialog! 

The last thing is to select the Playground Color. To do this, from the Options dialog, 

go to Layout tab and click the Browse button: 

 
The Color dialog will appear: 

 
 

 



136 
 

Choose the background color: 

 
Press Add to Custom Colors and click OK. 

 
This was done to distinguish the difference between the live database and the 

playground area database. 

Click OK to close the Options dialog. 

 



137 
 

8. Using the Playground Area 

Now open the Item Playground dialog.  

From ShipWeight main menu -> Items -> List Playground Items -> All… 

 
 
The Item Playground dialog opens: 
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The playground dialog got the blue background, so we clearly can see this is working 

in the playground and not in the live database (the Items dialog). 

So, currently there are no items in the playground dialog. Now we have to check 

some items into the playground. Close the Playground dialog for now. 

Step 1: Assign items to a workset and check out the workset 

To do this we need to select items in the live database, mark them with the work 
package and check them out. So, open up the live database: 

 
 

The Work Package column should already be visible in the Table view area. If it is 

not visible, then it means it is hidden and needs to be moved from Hidden to Codes 

in the Item Settings dialog. So, open the Items Settings dialog from Setting menu -> 

Item Settings… and expand the single and table view Hidden folders: 
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Because C04 – Work Package is hidden, we need to drag and move it to Codes 

folder: 

 

Now press Close. You will notice that the Work Package column has been added in 

the Table View: 



140 
 

 

Select all of the items in group E4 using Ctrl A  

 
and go to Items menu and select Set Field Values… 
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The Select field type dialog will open: 

 
Select C04 – Work Package: 

 
And then press OK. 

The Select code dialog will appear: 
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Assign all of this to W3 code to group the items: 

 
And press OK. 

Now, if we scroll to the right, we can see the work package, we have W3 for all 
items from E4 group, and they are still in the live database: 
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To get these items into the playground area, we need to check them out.  

Go to Items menu and select Worksets… 

The Worksets dialog opens: 

 
Now to check out the items market with W3, in the Worksets dialog select W3 and 

press the Check Out button:  

 
The following message will be displayed: 
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Click OK. Now we can see we have a new line with a red arrow which indicates 
that items with W3 have been checked out: 

 
Close the Worksets dialog. 

 

These items are still existing in the live database (Items dialog), but also a copy of 
them have been moved into the Playground area.  
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Step 2: Make your changes to the weights in the playground area! 

For example delete one item, by using right click and Delete option: 

 
 

You will be asked the following: 

 
And click Yes. 

 

You can also change the UnitWeight for one item, for example: 
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For item no 00370 instead of 430 for UnitWeight, type for example 1000: 

 
 



147 
 

Or add a new item: 

 
After we added the new item, we also need to assign it to the work package. So go 
the Test item line, to Work Package column and select from the list W3: 
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Close the Item Playground dialog and save. 

 
 

Step 3: Validate the change in the net change dialog! 

Now we can go and check in the net changes. Go to Items menu, then Worksets… 

 
Click on the red arrow, which represents the items that we checked out and click the 
Review button.  
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Once Review button has been clicked, the Workset Review, Approve & Check 
In dialog will appear: 

 
In this dialog we can see the net changes that have been done to the workset.  

In the upper level, it can be noticed the User ID detail, who checked the workset out, 

and the date, also who is the last person that changed it.  

Also, the net overall changes can be seen here: 
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Also the detail changes, under the overall changes: 

 

From the detail changes, we can see a new item (Test) has been added. The green 

circle means it is a new item. 

Orange circle indicates that the item had some changes to it. 

The red circle means that the item has been removed. 

Finally, the net change of all these items is shown here, in the orange line: 
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Step 4: Review, Accept (or Reject) change! 

Now to approve this click Review OK.  

If the results are not satisfactory click Reject. 

If we click Review OK, and close the dialog, we will see the arrow changed from 

red to orange, meaning that this has now been reviewed ok, but it has not yet been 

checked in.  

So, no changes has currently been done to the live database. To make the changes 

effective to the live database, select the orange arrow and click Checkin button: 

 

And the Workset Review, Approve & Check In dialog will open: 
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Final step: Approve and check in workset! 

Give an approved comment: 

 
Net change must be assigned to a margin: 
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Then select Approve & Check In button. 40 items checked in: 

 
And the orange arrow become green: 

 
Now close the workset dialog. Then open the Playground area. It is empty, the items 

have been checked in. 

And the live database has been updated with the changes done in the playground 

area.  
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9. Use of Phase codes 

Doing weight tracking for series production of vehicles with configuration changes 

raises some challenges. 

Phase coding means looking at the series production as a timeline, where: 

• The timeline is starting with vessel 1 and ending at vessel n. 

• The user defines the necessary phases, ranging from any start and endpoint on 

the timeline 

• Weight items are tagged to a phase, meaning that they are to be included for 

vehicles in this phase 

• The total weight of an individual vehicle is the sum of all items tagged to the 

phases that the time of the vehicle corresponds to  
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Examples: 

• Vessels: series of 10 monohull with modifications 

 
 

• Aircrafts: aircraft series production  

Various configurations during production: 
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• Offshore construction: lifecycle phases of an offshore construction 

 

 

• Satelite: satelite phases 

 
 

We consider the building of 20 vessels of the same class. Now this 20 vessels will 

not be completely identical, so we can not have them in only one project, but we can 

define phases containing the differences and use the phase codes to handle all 20 

vessels still in one project. 

So, we imagine we have a timeline, representing the number of vessels, going from 

0 to 20: 
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Then we can imagine we have an initial phase (Phase 0), which defines all weight 

items that will belong to all 20 vessels. So Phase 0 will stretch from 0 to 20:  

 

 

And then if there are modifications, or some special equipment that is valid for 

example only for the first vessels, then we define a new phase (Phase 1) for these 

vessels only: 
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Another modification or change in design may happen at any time, so in this example 

we also have a Phase 2, going from vessel 2 to 10: 

 

 

 

And another phase which indicates a modification or change, from vessel 6 to 16 

(Phase 3): 
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Phase 4 going from 4 to 20: 

 

 

And finally, the last phase (Phase 5) goes from 14 to 20: 
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We combine all of this weight items in one project, and tag items to the phases and 

then if we need to know the weight of for example vessel number 9, we slice through 

the database at vessel number 9: 

 

And only add up the items that are tagged to phases or modifications that are valid 

for that vessel or that time. In this case we can see that slicing through phases at 

vessel number 9, indicates that we need to include items tagged with Phase 0, Phase 

2, Phase 3, 4 and leave out Phase 1 and 5 for this vessel. 

Another way of representing this graph is to not use the bar, but just show the 

numbers for Start and End point. 
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Now, let’s define these phases in ShipWeight. To implement or to use this 

functionality, first we need to define these codes. Open the code definition: 

 

The Code Definition dialog will open: 
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And we notice we already have defined a phase code C10 - Phase: 

 
And defined the phase ids as well: 

 
So far this is just like any normal custom code. But the special thing is that at the 

end of this table where we can define the codes we added two columns Start and 

Stop (which are the same values as in the previous example): 
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Now Close the Code Definition dialog. 

In the Items dialog, items will be tagged to the phase code in a normal way: 

 
 

You can anytime set a different phase for any item: 
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Now we have to do the “slicing”, menaing we have to filter out only the items 
relevant for the vessel we want to know the weight and CG of… 

Because right now the total displacement shows 2512 tonnes, will be the summary 
of all items, meaning the summary of all phases, which is not any particular vessel: 
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So, to get the weight and center of gravity for a particular vessel, we need to apply 
a global filter for this one vessel.  

To be able to do that there is one thing we need to do first, to set in the options dialog 
(View -> Options), and go to the Report tab: 

 
You will see that last option Use Phase Code. Check the box and select from the list 
C10 – Phase: 
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And then press OK. 

Now we can set up a global filter for each individual vessel. And this is done in the 
global filter dialog: 

 
Click the browse button to get the filter dialog: 

 



167 
 

And in the global filter dialog, we can see we are able to define any type of filter.  

Give a Time, then a Filter Name, and then press the Save button:  

 
Then click OK. 

The filter will be activated and we will see that now in the main window the 
weight will be reduced from 2510 to 1934 tones. And this is the weight for vessel 
number 9. 
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To change the vessel numer, press again on browse button and change the Time 
and Filter name: 

 
Save and press OK. And now the weight and CG have changed based on vessel no. 
5: 
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Now we have two existing filters: 

 
And we can change anytime between vessel no.5 and no.9. 

When we enable filters, is not only the CG from the main window that changes, 
but now everything in ShipWeight changes according to this filter. So, if we go to 
the Items dialog we will see items belonging only to vessel no. 5 if the filter is 
Vessel no 5. 

Advantages of the Phase Code Approach: 

• Items are only needed once (one row) in the database regardless of how 
many vehicles are in the production line 

• It is easy to deploy weight items to a range of vehicles, and to change the 
extent of the range 

• You can easily find the weight of an individual vehicle by slicing through 
the phases at the time of the vehicle 

• Same approach can be used for multiple phases of a single vehicle 
throughout its life-cycle 
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10. QA Methods 

10.1 Find Duplicates/Identical Items 

Open up the items dialog to see all items: 

 
On the Tools menu choose Find -> Identical Items… 
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This will bring up Find Items dialog to help you find identical items: 

 
The combination of weight group and item number has to be unique in ShipWeight, 

so you are not allowed to enter any items with the same combination of weight group 

and item number. So, that is the first way to prevent duplicate items going into the 

database. 

There can be errors that make duplicate items going into different items number and 

different weight groups, so you can use this tool to detect those. 

Firstly, the user checks the boxes next to the Compare Field. For example if we want 

to find any items in the database that share same Description and Weight: 

 

Then click the Query button, the dialog is going to search through the database: 
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On the right side we can see several instances with items that share the same 

Description and Weight: 

 

And if we click on the first one, then we get the details under: 

 

The detail shows that weight group E3.3.1 contains two items (00214 and 00217) 

with the same Description and Weight. 
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10.2 Checking for Extreme Values 

Another typical mistake is entering in wrong CG or Weight, by for example putting 

in mm instead of meters, or somehow else getting some extreme value. 

The easiesnt way to check is by going into the Items dialog, make sure you are listing 

all items: 

 
Then go to the Table View, and click on the headers to sort. For example, go to TCG 

column and click once on the header. It’s going to start with the lowest TCG value  

-11.4: 
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If we click again, the largest value will be the first one displayed: 

 
So, here is a typical mistake, when someone entered millimeters instead of meters. 

So it is very easy to find the extreme values, by clicking on the header. 

Now we can just go and correct the value, by putting the decimal: 

 
And we can also do the same procedure to check the LCG and VCG. 

We can notice the VCG value is also not introduced correct, and we will show you 

another way to find the extreme values. 
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Another way to discover errors is to compare on the weight group level.  

Close the items dialog. 
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10.3 Compare Function 

 Go to View menu and select Compare…  

 

This brings up the Compare dialog: 
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Which will show the Weight, VCG, LCG and TCG. It is sorted by hierarchy, and 

you can add previous revisions or previous projects in the upper right area, and 

compare values on the weight group level. 

To add more projects, right click in the Project area and select Set Project 
Database…: 

 
The Open SQL project dialog will open. For example, SW00_DB_Space database 
and TestSpace Space_test project ID: 

 
Then click OK. 
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Now it will show the values for the weights and center of gravity for the current 
project compared with the weights and center of gravity values for the selected 
project: 

 
By default is sorted by Absolute deviation, and obviously if you list all the hierarchy, 
then the agregated weight groups to top weight groups will come up on the top of 
the column. 

To avoid this, go to List and select Input: 
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We can also sort by Relative deviation, to show which group has the largest 
relative deviation. 

All the information can be copied with Copy Table option and paste it to excel: 

 
We can also print the table to make the report, by using the Print option.  

You can also shift from the Grid View to the Tree view, which will show you the 
weight groups in a hierarchy tree. 
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10.4 Code Envelope Check 

If you have defined a custom code, for example for area: 

 
And this custom code C05 has sub areas A1, A2 and A3 (these areas have been given 
box limits): 

 
 
Press Close.  

Now in the items dialog, Items have been tagged to various areas: 
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And we can check the correctness of these by going to menu View and Code 

Envelopes. This brings up the Code envelopes dialog: 

 
This will show the custom code. If we select Show all option, the boundaries of the 

boxes will be displayed.  
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Now check the Box label option and by clicking in A1, A2 or A3 row, various boxes 

will be highlighed: 

 
 
If we highlight A2 and also check the box in front of A2, all items tagged to A2 will 

be printed in the XZ-plane and XY-plane: 
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We see if all of the items are inside the box. We see one item outside the box: 

 
The item number is 39, so we can scrolll down to Pos. 39 and find item 39: 
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And obviously this is an error, so either item 39 has wrong CoG value or it has been 

tagged to the wrong area code.  

You can also print out the report for this using Print command.  
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11. Loading Conditions and Hydrostatics 

To start the Loading conditions window, go to View menu and select Load 

Conditions… 

 

The Load Conditions dialog will appear: 

 

The first thing to do here, is to get Hydrostatics into ShipWeight: 
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To get the hydrostatics table into ShipWeight, press the Hydrostatics button and this 

brings up the Hydrostatics dialog: 

 

We can input all the needed values or Copy them from Excel (taken from the stability 

software): 
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And then Paste them in the Hydrostatics dialog: 

 

 
And press Close. 

Now we can start to create the loading conditions. The Loading Conditions are 

created in the Load Cases area, where each row will define one loading case. Let’s 

start by creating the Lightship condition. Type LW for LoadCase, then Lightship for 

Description. As always in ShipWeight when you create a new row, go to the row 

below to make sure this data has been properly registered in the database, then go 

back to the first row: 
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The definition of the lightship condition is done in the Weights area, and since is the 

lightship only, is just one weight to be defined: 

 
 

And select LW for Source column: 
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So, we are refering to the weight group Lightship in ShipWeight main window: 

 
 

Then right click and select Update Item(s) option: 
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And now it brings in the numbers of the weight and cg of the lightship, and also 

calculates the values for the Hydrostatics on the right side of the dialog: 

 



191 
 

Let’s create a new loading condition, which now can be the capacity load: 

 
And the Lightship and C-loads weights: 

 
 
Again, select both lines from Weights area, right click and Update Item(s): 
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This brings in the numbers of the weight and cg of the lightship, and also calculates 

the values for the Hydrostatics on the right side of the dialog: 
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Let’s create a third loading condition, a full load condition LWFL: 
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The links that we create to ShipWeight, they are not live, so we need to select these 
items and right click and Update Item(s) manually every time: 
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Now we have created 3 loading cases, and have the hydrostatics values calculated 
for all 3 of them. All of the loading cases have one line each, but of course more 
weights can be added for each loading condition. 
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Another way to create loading conditions is just refering to weight groups in the 
main hierarchy. 

So let’s define BALLAST condition: 

 
We will not refer to any weight groups, we will only define the lightship weight in 
ShipWeight: 
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